How can I read files on LaCie Drive using Linux

I have a LaCie 2Big drive that had an enclosure failure. It was operating in "SAFE" RAID 1 mode, so I believe the data is secure and still on each of the internal drives. I was sent an advanced replacement unit and had hoped to simply plug my old drives into the new enclosure and be back up and running, but no such luck since the firmware on the new enclosure was different.

As a MAC user, I am not completely familiar with PC operating systems, but do have an Intel MacBook Pro, so I thought I would take a crack at running Linux (Ubuntu) to read one of the drives.

After MUCH pain, I was finally able to see through the system Checkbox Report the "file path" to the drive and the USB controller I am using to attach it.

When I go to its location (ctrl-L) by typing the path, i can see all sorts of Linux folders and file names, but can not find my data.

Can someone PLEASE tell me where to look? Is the data somehow hidden, or encrypted? This is too complicated for a Mac user. I don't like to think this hard...LOL
59 answers Last reply
More about read files lacie drive linux
  1. Depending on Ubuntu version, you can access the partition editor in System -> Administration -> Partition Editor. Could you give us the partition layout of the drive?

    A screenshot would be preferable. Text output can also be done usng the terminal "fdisk -l /dev/sdX" replace the X with the name of your disk.
  2. I can not find the Partition Editor in my version of Ubuntu.

    I ran the terminal "fdisk -l /dev/sdX" but must have done something wrong. See below:

    jason@jason-ubuntu:~$ fdisk -1 /dev/sdb
    fdisk: invalid option -- '1'

    Usage: fdisk [-b SSZ] [-u] DISK Change partition table
    fdisk -l [-b SSZ] [-u] DISK List partition table(s)
    fdisk -s PARTITION Give partition size(s) in blocks
    fdisk -v Give fdisk version
    Here DISK is something like /dev/hdb or /dev/sda
    and PARTITION is something like /dev/hda7
    -u: give Start and End in sector (instead of cylinder) units
    -b 2048: (for certain MO disks) use 2048-byte sectors
    jason@jason-ubuntu:~$


    I also ran a Checkbox Report, but it is quite long, what is the best way to share it with you?
  3. Its fdisk -l not fdisk -1, although i admit it looks very similar. :)

    So its the underscore version of the 'L' letter, it stands for "List partition table", but linux is case-sensitive, so you have to use underscore -l:

    fdisk -l /dev/sdb
  4. Tom's has a linux section under software, they should be able to help you
  5. OK, now when i type "fdisk -l /dev/sdb" I get the message "cannot open /dev/sdb"
  6. Try sudo:

    sudo fdisk -l /dev/sdb

    maybe this thread can be moved to the linux/bsd forum by a mod?
  7. I posted screen shots, XML report and dumped the text from a checkbox report.

    http://www.thebeighs.com/ubuntu/ubuntu_question_site/Photos.html

    Hopefully this will help.
  8. You posted alot of data, but not the partition table layout as far as i can see. Could you post this as well? It should be text as its output in the terminal, so you don't have to paste it in here.

    Also, you can install partition editor by selecting Application -> Add/Remove software, and then launch it in System->Administration-> Partition Editor. This is a graphical app like Partition Magic and can display your partitions as well.

    Once i know what your disk looks like, you can try mounting it and see if you can access the data. But please give me a partition list output first.
  9. Also, how did you connect the drive(s)? You said using USB, but you said you had a failure with the Lacie enclosure. Normally that means taking the disks out and connecting one of the disks directly to your computer, using Serial ATA cable.

    Maybe that's not required, but please tell me how you connected your disks, are you still using the external Lacie enclosure?
  10. Take a look at pic #1 of the images I posted.

    http://www.thebeighs.com/ubuntu/ubuntu_question_site/Photos_files/Media/Picture%201/Picture%201.jpg?disposition=download

    I am connected via a USB to SATA controller made by JMicron Technology Corp. Since the enclosure has failed, i can not use it to connect.

    I tried to use the new enclosure they sent me with the new drive, but LaCie has made it so that newer enclosures with updated firmware can not be used to read older drives, even though they are from the exact same unit. I think that is pretty poor development. One would think they would make their firmware backward compatible.
  11. What about taking the drives out of their enclosure and connecting them directly to your PC and getting the data off the disk? You want your data back right? Then you can just put them back in the new unit, reformat and put it back.

    If its soft-RAID which i suspect, you may not need to take them out of the enclosure, but i'd need to see the partition layout to judge on that.

    While you posted alot of data, i do not see the output of "sudo fdisk -l /dev/sdb" or a screenshot of Partition Editor, which is what i need to judge whether you can recover your data at this point or need to move the disks out of their enclosure and connect one of them internally.
  12. Yes, I have taken them out of the enclosure and connected one of them via the above mentioned controller. They were in mirrored "SAFE" mode (RAID1), so I should be able to just copy the data off of one of the drives.

    Also, below is a link to the Partition List as you requested:

    http://www.thebeighs.com/ubuntu/ubuntu_question_site/Partition.html
  13. I am assuming my data is on the partition at the bottom of the list (/dev/sdb2) which is is an xfs file system containing 930.55GB. I estimate that I have about 600GB used on that partition.
  14. Indeed. :)

    You need to install additional software to use that XFS partition.

    Go to System->Administration->Synaptic Package Manager. Click Search and type "xfs" then double click the "xfsprogs" package and click the Apply button. After installation, you should be able to mount the XFS partition.

    After having installed xfsprogs, try if you can access the partition the easy way:
    click Places->Home folder. On the left side you should see something like "930GB media". Click on it and it should mount automatically, and you should see your files. :)
  15. OK, everything went well up until the "...you can access the partition the easy way" part. when i click on Places->Home folder it does not show up. is there another way to access it or "map it" so that it mounts?
  16. Open a terminal (Applications->Accessoires->Terminal)
    enter exactly:

    sudo mkdir /mnt/xfs
    sudo mount -t xfs -r /dev/sdb2 /mnt/xfs

    Now click the Places->Home Folder again and navigate to the root, then to the "mnt" folder, then to the "xfs" folder. Now you should see your files.

    It will be mounted read-only, to avoid it changing the files. Just check if you can read it and if so you should be able to move that data via the network to other places.
  17. OK - I feel like I am getting sooo close. I got the attached message...

    http://www.thebeighs.com/ubuntu/ubuntu_question_site/Terminal_Window.html

    What did I do wrong?

    Thanks for all your help!!!
  18. Sorry about my late response, i had some issues with these forums.

    I didn't expect that message; could you give me some further text output of the following commands?

    First retype the command:
    sudo mount -t xfs -r /dev/sdb2 /mnt/xfs
    (it will fail with the same message thats ok)

    dmesg | tail
    dmesg | grep sdb
    cat /var/run/dmesg.boot | grep sdb
    mount

    (so 4 separate commands; they all do nothing but give text output; information only they don't affect anything else)

    Also, did you close all other windows/apps? Just to be safe, exit the partition manager and close all nautilus windows (nautilus = the file manager which you use to browse folders). Though that shouldn't be the problem. :)

    You may indeed be close. It may also be the /dev/sdb disk is used by software RAID; linux can read RAID configuration of other brands and apply its own software RAID. With the output of the commands i gave you i should be able to figure that out.

    I'll be back here tomorrow, to check on your progress. :)
  19. jason@jason-ubuntu:~$ sudo mount -t xfs -r /dev/sdb2 /mnt/xfs
    [sudo] password for jason:
    mount: /dev/sdb2 already mounted or /mnt/xfs busy
    jason@jason-ubuntu:~$ dmesg | tail
    [11716.539192] usb 1-1: USB disconnect, address 5
    [11717.348524] usb 1-1: new high speed USB device using ehci_hcd and address 6
    [11718.117255] usb 1-1: configuration #1 chosen from 1 choice
    [11718.221074] uvcvideo: Found UVC 1.00 device Built-in iSight (05ac:8502)
    [11718.244572] input: Built-in iSight as /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0/input/input11
    [15878.765765] usb 1-1: USB disconnect, address 6
    [15879.580520] usb 1-1: new high speed USB device using ehci_hcd and address 7
    [15880.915419] usb 1-1: configuration #1 chosen from 1 choice
    [15881.026694] uvcvideo: Found UVC 1.00 device Built-in iSight (05ac:8502)
    [15881.050961] input: Built-in iSight as /devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1/1-1:1.0/input/input12
    jason@jason-ubuntu:~$ dmesg | grep sdb
    [ 52.520287] sd 3:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
    [ 52.522915] sd 3:0:0:0: [sdb] Write Protect is off
    [ 52.522943] sd 3:0:0:0: [sdb] Mode Sense: 00 38 00 00
    [ 52.523005] sd 3:0:0:0: [sdb] Assuming drive cache: write through
    [ 52.530873] sd 3:0:0:0: [sdb] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
    [ 52.533389] sd 3:0:0:0: [sdb] Write Protect is off
    [ 52.533393] sd 3:0:0:0: [sdb] Mode Sense: 00 38 00 00
    [ 52.533395] sd 3:0:0:0: [sdb] Assuming drive cache: write through
    [ 52.533530] sdb: sdb1 < sdb5 sdb6 sdb7 sdb8 sdb9 sdb10 > sdb2
    [ 52.554638] sd 3:0:0:0: [sdb] Attached SCSI disk
    [ 53.448325] md: bind<sdb2>
    [ 53.499541] md: bind<sdb5>
    [ 53.506366] md: bind<sdb7>
    [ 53.555532] md: bind<sdb8>
    [ 53.561454] md: bind<sdb9>
    jason@jason-ubuntu:~$ cat /var/run/dmesg.boot | grep sdb
    cat: /var/run/dmesg.boot: No such file or directory
    jason@jason-ubuntu:~$ mount
    /dev/sda1 on / type ext3 (rw,relatime,errors=remount-ro)
    tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
    varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
    udev on /dev type tmpfs (rw,mode=0755)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    lrm on /lib/modules/2.6.28-16-generic/volatile type tmpfs (rw,mode=755)
    securityfs on /sys/kernel/security type securityfs (rw)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/jason/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=jason)
    jason@jason-ubuntu:~$
  20. Ah yes, the "md" driver or Multiple Device driver is using your /dev/sdb disk as it detects that disk as being a RAID-member. To be able to mount it normally, we have to disable "md" first. md is just Linux software RAID, that is compatible with many other RAID formats so it detects your disk as being part of a RAID.

    Maybe the simplest is to disable the detection of RAID errors, by adding this text to the kernel boot line:

    raid=noautodetect

    To do this, reboot until you see the ubuntu boot menu where its counting from 5 to 0. Press "e" to edit the boot line, you should be able to add the "raid=noautodetect" to the existing boot line.

    So when you get the boot menu:
    - press 'e'
    - press a space
    - enter "raid=noautodetect"
    - press enter to boot
    - open a terminal and repeat the "sudo mount -t xfs -r /dev/sdb2 /mnt/xfs" command
    - check /mnt/xfs to see if you can access your files

    Hope this works. :)
  21. Here is a link to another Screen Shot:

    http://www.thebeighs.com/ubuntu/ubuntu_question_site/Text_Output.html

    By the way, where are you from? Like me, you must never sleep, because you post 24/7. Thanks again for your help. When this is all over, I owe you a beer, or a keg...
  22. Hehe yeah i don't sleep, i feed my body through enzymes once a month so i can stay up 24/7. :)

    Just kidding, in fact i have to do alot of work at night, but have spare time in between so like to be occupied, and browsing forums is one occupation i do. :)

    Let me know if the raid=noautodetect option worked, allowing you to successfully mount your drive.
  23. OK, i had to take a day off from this, so here is where I am. I tried to edit the boot line, but got some different messages when i was following the directions.

    http://www.thebeighs.com/ubuntu/ubuntu_question_site/Editing_Boot_Line.html

    In the first screen, I hit "e" on the highlighted selection. when i got to the next screen i was lost. Which line am i editing, or am i adding a line?

    Sorry for my lack of experience in all of this Linux stuff. I have had NO experience with it before last week. I do find it intriguing though.
  24. Sorry my mistake! You're using GRUB while i use a different loader, which behaves a little different.

    These instructions should help you:
    http://grumpymole.blogspot.com/2007/05/ubuntu-how-to-edit-grub-boot-parameters.html

    copy-paste:
    * Press 'e' to start editing.
    * Scroll down to the "kernel..." line. The is the line that tells Grub which kernel to boot with and the parameters to be passed to the kernel when it boots are placed at the end of this line.
    * Press 'e' again to edit this line.
    * Move to the end of the line. You will see any existing parameters and can add other new parameters to the end.
    * Parameters are separated by spaces and are mostly either a single word (e.g. nolapic), or an equation (e.g. acpi=off).
    * Once you have added the parameter to the end of the line, press Enter to accept the editing.
    * Then press 'b' to boot using that kernel and those parameters.


    So when you scroll to the end, make sure to insert a space, and add the "raid=noautodetect" without the quotes, hit enter and hit 'b' to continue booting.

    Hope it finally works now!
  25. OK, here is the latest. When i go into the terminal window i still get the message:

    mount: /dev/sdb2 already mounted or /mnt/xfs busy

    I still can not see the drive. There is nothing in the /mnt/xfs folder. I feel so stupid, like I am doing something wrong. I hope I am not frustrating you. Any more ideas?
  26. You shouldn't feel stupid its certainly not your fault!

    In fact, its the md driver that is attaching your drive without your permission, that's a violation of a user's authority in my opinion, and thus a bug. But.. that's rather philosophical. :)

    Try this:
    1) first go to synaptic again (System->Administration->Synaptic) and install the "mdadm" package if not already installed. This is to administer md-arrays or software RAID arrays. md is the kernel raid driver while mdadm is the utility to configure/control it.

    2) gather some information just in case, can't hurt, and paste it in this thread:
    mount
    dmesg | grep -i md
    sudo fdisk -l
    ls -l /dev/md*
    sudo mdadm --detail /dev/md0

    3) this is the actual trick, and should stop your RAID array, may not work if the /dev/md0 device not exist, in that case the above information should help me find the right command, but it 'should' work:
    sudo mdadm --stop /dev/md0

    4) mount your volume:
    sudo mount -t xfs -r /dev/sdb2 /mnt/xfs

    If it still doesn't work -- don't give up! At least i won't since it should work this is just a minor annoyance -- it should work! The md-driver being so intrusive is annoying though. :P

    If it did work: hurray! I don't need the information in step 2) only if its still not working. In that case i'll bring my shotgun and emasculate(*) the md driver myself. :D

    Quote:
    e·mas·cu·late (-msky-lt)
    tr.v. e·mas·cu·lat·ed, e·mas·cu·lat·ing, e·mas·cu·lates
    1. To castrate; to remove the testicles of;
    2. To deprive of strength or vigor; weaken.


    Hear from you :)
    -sub
  27. I'll be on a business trip this weekend, so you won't receive a further reply until Monday. Please don't give up though - we'll get through it. :)
  28. I am also having the same issue. jbeigh, were you able to resolve the issue?
  29. Hi,

    I have the same issue with Western Digital's WD My World Book II (1TB - RAID: 2x 500GB).

    The command:

    sudo mount -t xfs -r /dev/sdb4 /mnt/xfs

    Returns:

    mount: /dev/sdb4 already mounted or /mnt/xfs busy


    It doesn't seem to show in "Places > Home Folder".

    Any help would be awesome!
  30. I had the same problem with my Lacie drive. 1 TB 2Big. Drives were mirrored , drives were good , enclosure bad. I found a software solution. UFSEXPLORER.COM. The software and a USB external hard drive adapter did the trick. actually pretty simple. Even better when you can find the software online. You know what sites I mean. Free.
  31. Hi,

    I did not read the whole thread, but having the same problem I found an "easy" solution:
    1. get an old PC where you can put in a hard drive to be formatted later. That can be some old drive with only a couple of GB, Linux doesn't need much.
    2. get the Knoppix Live CD here :http://www.knoppix.net/
    this is a live CD that allows you to copy a working Linux on your PC without any hassle.
    3. put one of the LaCie Raid disks into a USB enclosure and connect it to the PC
    4. start up the PC with the newly installed linux
    5. go to the shell (before mounting the graphical interface) and type exactly "sudo mdadm --assemble --run /dev/md0 /dev/sdb2"
    sdb2 is your RAID, mdadm mounts the RAID
    6. exit the shell and load the graphical interface
    7. The RAID appears in your linux file manager and can be copied wherever you want!

    Enjoy
  32. pschlief: that's a nice method, thanks for sharing.

    It appeared to me that jbeigh was very close to recovering his data (would be a shame if he didn't - after all trouble). The only thing that didn't work in the end was mounting the XFS volume from a separate physical disk. This is likely because the disk is part of a RAID-array, and the /dev/md0 device is created.

    I am curious however, it should have just worked:
    1. install xfsprogs as it uses the XFS filesystem
    2. check with Partition Editor (System->Administration->GParted)
    3. try to mount, click Places->Home; then click ".. GB Filesystem" on the left.

    Anyone who still needs help with this; if the tips in this thread do not help; please post all your data and i'll have a look. :)
  33. Quote:
    Hi,

    I did not read the whole thread, but having the same problem I found an "easy" solution:
    1. get an old PC where you can put in a hard drive to be formatted later. That can be some old drive with only a couple of GB, Linux doesn't need much.
    2. get the Knoppix Live CD here :http://www.knoppix.net/
    this is a live CD that allows you to copy a working Linux on your PC without any hassle.
    3. put one of the LaCie Raid disks into a USB enclosure and connect it to the PC
    4. start up the PC with the newly installed linux
    5. go to the shell (before mounting the graphical interface) and type exactly "sudo mdadm --assemble --run /dev/md0 /dev/sdb2"
    sdb2 is your RAID, mdadm mounts the RAID
    6. exit the shell and load the graphical interface
    7. The RAID appears in your linux file manager and can be copied wherever you want!

    Enjoy


    I tried this, but when I enter the shell command, I get "Has No Superblock, assembly aborted" Can you guide me past that?
  34. Hey Sub Mesa, I tried the command:

    4) mount your volume:
    sudo mount -t xfs -r /dev/sdb2 /mnt/xfs

    I got back that the mount point doesn't exist. Can I create it? If that's the only thing stopping me, then I'll be in good shape.
    Thanks!
  35. 
    sudo mkdir /mnt/xfs
    


    would make the directory to mount to
  36. Thank you sir! That worked, but now it's telling me that the special device doesn't exist... such a deep rabbit hole.
  37. Are you sure you are running XFS? That is not a filesystem you can have available in Windows.

    You can mount on /mnt or just create another directory you wish:

    sudo mkdir /blabla
    sudo mount -t xfs -r /dev/sdb2 /blabla

    Then your files should be in the root directory /blabla
  38. I did try that, but it didn't like it. I was actually using Ubuntu, and then tried Knoppix. No dice on that, but I ended up getting tired of fighting it and purchased the UFS Explorer program. I just connected the drive up to windows xp, ran the program and it was like butter. About $50, but sometimes the money is worth it. Like in this case. :) Thanks for the replies though.
  39. Indeed a very nice program - too bad it's not free. But you should have had success with Ubuntu also.

    Either way, grats on getting your data back!
  40. richter1956@yahoo.com
    sub mesa said:
    Indeed a very nice program - too bad it's not free. But you should have had success with Ubuntu also.

    Either way, grats on getting your data back!


    Hello from Italy (Mac os x user).
    I try to resume my case (sorry if it is too long)
    I own a Lacie 2 Big 1,5 TB using it in safe mode 750 GB.
    Well some time ago i realized that one disk was out of order. I don't know when it went out of order because the NAS continued to work regularly (only with some clicks from the damaged unit).
    I decided to stop it waiting to buy a replacement disk.
    I couldnt find the same disk so i tried to put a Barracuda 1TB (not from LACIE) but the NAS unit didn't recognize it but continued to work regularly.
    So i to turned off the NAS waiting to buy a USB2 external disk for backup purpose (i decided to trash the NAS after the backup).
    Today i powered up the NAS for the final backup but unpredictably it seems crazy or half dead so that i can't see it on the net (sometimes the front light blink red/blue, sometimes it doesn' light up, no way to see it on the network, the power off switch doesn't have any effect, etc).

    I put that NAS drive into a USB enclosure and I checked the disk with the normal Leopard disk utilities.
    I could see 7 partitions named:
    disk4s2 (the biggest one 697 gigabytes)
    then
    disk4s5, 6, 7, 8, 9, 10
    They are all defined as LINUX except the #5 defined LINUX-SWAP

    I installed the PARAGON software (10 days try) and it succeeded to mount only 2 partitions while the biggest one remained unmounted.

    Someone have similar experience?
    On that (safe raid?) disk i stored all the photos of my life...

    A friend of mine had similar experience with another LaCie unit. I guess that in the future i won't buy even a cable from them...

    By the way... at the beginning of that NAS career i lost the AFP access.
    The files were still present but downloading by SMB the files uloaded by AFP was a disaster because all the MAC resources on older files were lost making them simple "EXEC" icons unusable!


    Thank you for your understanding.
    Alberto
  41. Alberto...

    I have the exact same thing with my LaCie 2Big Network unit with two 500GB drives in safe mode.
    I got a blue / red blinking LED 2 days ago on the front LED and on the back LED related to one of the 2 drives.
    the other drive had a solid blue LED.
    red/blue blinking LED means that the drive is booting (or trying to boot)

    The LaCie technical people were not optimistic when I contacted them and I got the same sales pitch "send your unit to a data recovery specialist" They believe that the drives might be corrupt thanks to RAID but that the Data should still be there...

    they recommended to do the following:
    The procedure below will reset the 2Big Network to factory settings:
    IMPORTANT NOTE: Following the procedure below can ERASE ALL DATA on the drive. Prior to following these directions, verify important data is stored securely on a different storage device.
    1 Switch the drive OFF. Once it has shut down, ensure the power switch remains in the OFF position.
    2 If the drive is in the SAFE mode, move the RAID switch to the BIG mode.
    3 PRESS AND HOLD the button on the front.
    4 MOVE the power switch to the ON position. The light on the front of the drive will start blinking.
    Once the light stops blinking, RELEASE the front button.
    5 When released, it will begin BLINKING AGAIN.
    6 When it stops, PRESS AND HOLD the front button. The light will begin to blink again.
    7 When the light stops blinking, RELEASE the button.
    The drive is now resetting itself. Switch the RAID selector back to SAFE if desired.
    To restore data if it was lost during the process, recreate the shares and users on the unit prior to the reset. Any firmware updates applied will need to be applied again.

    I did not yet do this because, like you... I do not have a backup for my data
    I actually trusted that the LaCie in SAFE mode would PROTECT my data - after all... why use safe mode and only half of the drive's capacity when you can combine the 2 drives and have more storage space.. ARRRGH!

    anyway, I have a friend who has the identical NAS and I would like to try to use his before trying to reset my box.
    In my case, LaCIe believe that their hardware is defective and that it needs a reset... but the drives are a critical componenet to getting their hardware back in shape..

    good luck with your setup... please do let us know how it goes
    and I will report on my results in the coming days
    this is hugely frustrating!
  42. tbox...
    i'm still working on.

    I have a friend with the same identical NAS (we bought them the same day at the same shop).
    I put my lonely disk into his NAS but... i got a faster blinking and no results.
    That surprised me because i was sure that my disk could work into his NAS!

    Double strange because my lonely disk surely worked for a month into my NAS before it went wrong.

    Now i changed strategy so I put that drive into a USB adapter and installed UBUNTU and i can see the array on the desktop but it doesn't mount.

    Since i am a mac user i tried to use File Salvage.app and it recovered almost 200.000 files correctly but.... the bad side is that the file weren't structured at all and they lost their name!
    Imagine a folder containing 41.000 jpg files named "File00001.jpg" to "file41.000.jpg".
    the same for DOC, PSD, MP3, etc etc.
    It's better than nothing but if i can't recover the folder structure i will be able only to recover the photos while my backups of my CD-ROMs (i developed many cdroms) will be totally useless since a single cd rom contained lot of spare pct. doc. etc etc structured into their folders.
    Fot the photos i used a little app that rebuilt the filename using the EXIF data so i could separate the files using their creation date. The file without exif data has been named with the current date :-((
    I got some wrong date due to the camera that was wrongly set up (example 1970's date).

    I tried a win software called R-studio and i could see SOME of the old disk structure but only a very little part.

    UFFFFF
    i'll continue hoping to find some magic exper user who will be able to help me to mount the disk with the original structure!

    You say "hugely frustrating" ....
    yes!
    Think that a friend of mine lost data on a Lacie Raid too and i own a USB box that is giving me some problem: a lacie usb box.

    Surely i won't buy anything from LACIE in the future!

    Keep in touch

    Alberto
  43. OK... it's Sunday
    and I decided to pick up the ball again and give it another shot.

    I followed La Cie's RESET guidelines and made it all the way to step 4

    THe LED on the front of the unit
    never came on or even blinked... the La Cie machine is broken
    and I believe that my drives are still OK

    if I were to send this unit to the distributor, they would send it to LaCie
    and they would surely delete all my Data

    thus... WHAT TO DO?


    My friend and I bought 2 of these crap units a few years ago
    and I am hoping that when I get a hold of his unit, my data will be accessible.

    I can always try to do a reset on his unit AFTER I BACKUP HIS DATA

    sheesh... what a waste of time and energy!
  44. hello tbox...
    i worked with the unit of my friend but i didn't back up his data LOL...
    Apparently no problem since all the username , partitions and other data are written on his disk.
    Simply: HIS unit with my disk didn't work but when i re-inserted his disks into his unit then all worked perfectly.

    (by the way: my friend recently lose the AFP protocol on that crap and after the firmware update he had huge roblems too).

    As i told you i could perform a recovery of all the files with no root structure.
    I was wondering if there is some recovery service able to recover the whole disk in the original form and i was wondering about the pricing for such services.

    Are you informed about that?

    I always hope that some Linux expert could read about our problem suggesting some magic procedure to restore the raid ...

    keep in touch!
  45. hi to all.
    any update about that?
    my device failed too and I had a RAID 0... is there a way to retrieve data?
    I tried with a friend Lacie, same model, but i got same results as richter1956:
    HIS unit with my disk didn't work but when i re-inserted his disks into his unit then all worked perfectly

    please help me
  46. sub mesa said:
    pschlief: that's a nice method, thanks for sharing.

    It appeared to me that jbeigh was very close to recovering his data (would be a shame if he didn't - after all trouble). The only thing that didn't work in the end was mounting the XFS volume from a separate physical disk. This is likely because the disk is part of a RAID-array, and the /dev/md0 device is created.

    I am curious however, it should have just worked:
    1. install xfsprogs as it uses the XFS filesystem
    2. check with Partition Editor (System->Administration->GParted)
    3. try to mount, click Places->Home; then click ".. GB Filesystem" on the left.

    Anyone who still needs help with this; if the tips in this thread do not help; please post all your data and i'll have a look. :)


    Hi sub mesa
    Thanks for all your work here! I too am having trouble with a lacie 2 big drive specifically accessing the data on the hard drive. I have removed the hard drive from the lacie box and pluged it directly into my motherboard via sata cable. I have downloaded the latest ubuntu OS and I am booting that from a USB memory key.

    I have followed your post with alberto but have not had any luck accessing my drive. It is present in the system and as you can see below it is the sdc drive with?10 partitions. None are accessible to me. Not sure if the install error with mdadm is relevant or the fact that I could not create a md0 file (actually I really dont have any idea what that means either! lol).

    I don't have any experience with ubuntu except for with my recent problem with data access to this drive. Looks like all the info points to umbutu and the mdadm program but I am really not sure where to go from here.

    Any help would be greatly aprreciated!

    I bought the drive to have a central space where if one drive went down I had a back up with the raid 1 configuration. little did I know that box failure leads to much sleepless research!

    Thanks

    Shane
    :o
    ubuntu@ubuntu:~$ sudo apt-get install mdadm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    mdadm is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 159 not upgraded.
    2 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up initramfs-tools (0.98.1ubuntu6) ...
    update-initramfs: deferring update (trigger activated)
    cp: cannot stat `/vmlinuz': No such file or directory
    dpkg: error processing initramfs-tools (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of mdadm:
    mdadm depends on initramfs-tools (>= 0.85eubuntu24); however:
    Package initramfs-tools is not configured yet.
    dpkg: error processing mdadm (--configure):
    dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
    Errors were encountered while processing:
    initramfs-tools
    mdadm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ubuntu@ubuntu:~$ # fdisk -l
    ubuntu@ubuntu:~$ fdisk -l
    ubuntu@ubuntu:~$ fdisk-l
    fdisk-l: command not found
    ubuntu@ubuntu:~$ sudo fdisk -l

    Disk /dev/sda: 2002 MB, 2002780160 bytes
    62 heads, 62 sectors/track, 1017 cylinders
    Units = cylinders of 3844 * 512 = 1968128 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xbb0eb409

    This doesn't look like a partition table
    Probably you selected the wrong device.

    Device Boot Start End Blocks Id System
    /dev/sda1 ? 896832 1382432 933323145+ 66 Unknown
    Partition 1 has different physical/logical beginnings (non-Linux?):
    phys=(1010, 16, 43) logical=(896831, 25, 13)
    Partition 1 has different physical/logical endings:
    phys=(906, 97, 3) logical=(265114, 11, 23)
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 ? 1 1 0 72 Unknown
    Partition 2 has different physical/logical beginnings (non-Linux?):
    phys=(101, 116, 32) logical=(0, 41, 32)
    Partition 2 has different physical/logical endings:
    phys=(370, 114, 47) logical=(0, 41, 31)
    Partition 2 does not end on cylinder boundary.

    Partition table entries are not in disk order

    Disk /dev/sdb: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xbb14e257

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 13 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sdb2 13 25497 204697600 7 HPFS/NTFS
    /dev/sdb3 25497 57368 256000000 7 HPFS/NTFS
    /dev/sdb4 57368 91202 271771648 7 HPFS/NTFS

    Disk /dev/sdc: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0b5289df

    Device Boot Start End Blocks Id System
    /dev/sdc1 1 125 1004031 5 Extended
    /dev/sdc2 126 91201 731567970 83 Linux
    /dev/sdc5 1 16 128457 82 Linux swap / Solaris
    /dev/sdc6 17 17 8001 83 Linux
    /dev/sdc7 18 18 8001 83 Linux
    /dev/sdc8 19 40 176683+ 83 Linux
    /dev/sdc9 41 124 674698+ 83 Linux
    /dev/sdc10 125 125 8001 83 Linux
    ubuntu@ubuntu:~$ examine /dev/sdc
    examine: command not found
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc
    mdadm: cannot open /dev/sdc: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc1
    mdadm: cannot open /dev/sdc1: Permission denied
    ubuntu@ubuntu:~$ ^C
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc2
    mdadm: cannot open /dev/sdc2: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc3
    mdadm: cannot open /dev/sdc3: No such file or directory
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc4
    mdadm: cannot open /dev/sdc4: No such file or directory
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc5
    mdadm: cannot open /dev/sdc5: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc6
    mdadm: cannot open /dev/sdc6: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc7
    mdadm: cannot open /dev/sdc7: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc8
    mdadm: cannot open /dev/sdc8: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc9
    mdadm: cannot open /dev/sdc9: Permission denied
    ubuntu@ubuntu:~$ mdadm --examine /dev/sdc10
    mdadm: cannot open /dev/sdc10: Permission denied
    ubuntu@ubuntu:~$ mdadm -examine/dev/sdc9
    mdadm: -e does not set the mode, and so cannot be the first option.
    ubuntu@ubuntu:~$ mdadm --assemble --run /dev/md0 /dev/sdc9
    mdadm: failed to create /dev/md0
    ubuntu@ubuntu:~$ sudo mdadm --assemble --run /dev/md0 /dev/sdb2
    mdadm: cannot open device /dev/sdb2: Device or resource busy
    mdadm: /dev/sdb2 has no superblock - assembly aborted
    ubuntu@ubuntu:~$ sudo mdadm --assemble --run /dev/md0 /dev/sdb2
    mdadm: cannot open device /dev/sdb2: Device or resource busy
    mdadm: /dev/sdb2 has no superblock - assembly aborted
    ubuntu@ubuntu:~$ sudo mdadm --assemble --run /dev/md0 /dev/sdb2
    mdadm: cannot open device /dev/sdb2: Device or resource busy
    mdadm: /dev/sdb2 has no superblock - assembly aborted
    ubuntu@ubuntu:~$ fdisk -l/dev/sdc
    fdisk: invalid option -- '/'

    Usage:
    fdisk [options] <disk> change partition table
    fdisk [options] -l <disk> list partition table(s)
    fdisk -s <partition> give partition size(s) in blocks

    Options:
    -b <size> sector size (512, 1024, 2048 or 4096)
    -c switch off DOS-compatible mode
    -h print help
    -u <size> give sizes in sectors instead of cylinders
    -v print version
    -C <number> specify the number of cylinders
    -H <number> specify the number of heads
    -S <number> specify the number of sectors per track

    ubuntu@ubuntu:~$ fdisk -l /dev/sdc
    Cannot open /dev/sdc
    ubuntu@ubuntu:~$ sudo fdisk -l /dev/sdc

    Disk /dev/sdc: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0b5289df

    Device Boot Start End Blocks Id System
    /dev/sdc1 1 125 1004031 5 Extended
    /dev/sdc2 126 91201 731567970 83 Linux
    /dev/sdc5 1 16 128457 82 Linux swap / Solaris
    /dev/sdc6 17 17 8001 83 Linux
    /dev/sdc7 18 18 8001 83 Linux
    /dev/sdc8 19 40 176683+ 83 Linux
    /dev/sdc9 41 124 674698+ 83 Linux
    /dev/sdc10 125 125 8001 83 Linux
    ubuntu@ubuntu:~$ sudo mdadm --stop/dev/md0
    mdadm: unrecognized option '--stop/dev/md0'
    Usage: mdadm --help
    for help
    ubuntu@ubuntu:~$ mount
    aufs on / type aufs (rw)
    none on /proc type proc (rw,noexec,nosuid,nodev)
    none on /sys type sysfs (rw,noexec,nosuid,nodev)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    none on /dev type devtmpfs (rw,mode=0755)
    none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    /dev/sda on /cdrom type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    /dev/loop0 on /rofs type squashfs (ro,noatime)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    none on /dev/shm type tmpfs (rw,nosuid,nodev)
    tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
    none on /var/run type tmpfs (rw,nosuid,mode=0755)
    none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)
    /dev/sdb2 on /media/6880C42680C3F898 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
    /dev/sdb3 on /media/9CBED170BED14384 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
    /dev/sdb4 on /media/7A8029378028FB71 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
    ubuntu@ubuntu:~$ sudo mdadm --detail/dev/md0
    mdadm: unrecognized option '--detail/dev/md0'
    Usage: mdadm --help
    for help
    ubuntu@ubuntu:~$ sudo mount -t xfs -r /dev/sdc2mnt/xfs
    Usage: mount -V : print version
    mount -h : print this help
    mount : list mounted filesystems
    mount -l : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
    mount -a [-t|-O] ... : mount all stuff from /etc/fstab
    mount device : mount device at the known place
    mount directory : mount known device here
    mount -t type dev dir : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
    mount --bind olddir newdir
    or move a subtree:
    mount --move olddir newdir
    One can change the type of mount containing the directory dir:
    mount --make-shared dir
    mount --make-slave dir
    mount --make-private dir
    mount --make-unbindable dir
    One can change the type of all the mounts in a mount subtree
    containing the directory dir:
    mount --make-rshared dir
    mount --make-rslave dir
    mount --make-rprivate dir
    mount --make-runbindable dir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using -L label or by uuid, using -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say man 8 mount .
    ubuntu@ubuntu:~$ sudo mdadm --assemble --run /dev/md0 dev/sdc2
    mdadm: cannot open device dev/sdc2: No such file or directory
    mdadm: dev/sdc2 has no superblock - assembly aborted
    ubuntu@ubuntu:~$
  47. And a little more information you may need (You asked someone in a previous post)


    ubuntu@ubuntu:~$ fdisk -l
    ubuntu@ubuntu:~$ sudo fdisk -l

    Disk /dev/sda: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0b5289df

    Device Boot Start End Blocks Id System
    /dev/sda1 1 125 1004031 5 Extended
    /dev/sda2 126 91201 731567970 83 Linux
    /dev/sda5 1 16 128457 82 Linux swap / Solaris
    /dev/sda6 17 17 8001 83 Linux
    /dev/sda7 18 18 8001 83 Linux
    /dev/sda8 19 40 176683+ 83 Linux
    /dev/sda9 41 124 674698+ 83 Linux
    /dev/sda10 125 125 8001 83 Linux

    Disk /dev/sdb: 2002 MB, 2002780160 bytes
    62 heads, 62 sectors/track, 1017 cylinders
    Units = cylinders of 3844 * 512 = 1968128 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xbb0eb409

    This doesn't look like a partition table
    Probably you selected the wrong device.

    Device Boot Start End Blocks Id System
    /dev/sdb1 ? 896832 1382432 933323145+ 66 Unknown
    Partition 1 has different physical/logical beginnings (non-Linux?):
    phys=(1010, 16, 43) logical=(896831, 25, 13)
    Partition 1 has different physical/logical endings:
    phys=(906, 97, 3) logical=(265114, 11, 23)
    Partition 1 does not end on cylinder boundary.
    /dev/sdb2 ? 1 1 0 72 Unknown
    Partition 2 has different physical/logical beginnings (non-Linux?):
    phys=(101, 116, 32) logical=(0, 41, 32)
    Partition 2 has different physical/logical endings:
    phys=(370, 114, 47) logical=(0, 41, 31)
    Partition 2 does not end on cylinder boundary.

    Partition table entries are not in disk order

    Disk /dev/sdc: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xbb14e257

    Device Boot Start End Blocks Id System
    /dev/sdc1 * 1 13 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sdc2 13 25497 204697600 7 HPFS/NTFS
    /dev/sdc3 25497 57368 256000000 7 HPFS/NTFS
    /dev/sdc4 57368 91202 271771648 7 HPFS/NTFS
    ubuntu@ubuntu:~$ sudo mount -t xfs -r /dev/sdb2 /mnt/xfs
    mount: mount point /mnt/xfs does not exist
    ubuntu@ubuntu:~$ sudo mount -t xfs -r /dev/sdb2 /mnt/xfs
    mount: mount point /mnt/xfs does not exist
    ubuntu@ubuntu:~$ sudo mount -t xfs -r /dev/sda2 /mnt/xfs
    mount: mount point /mnt/xfs does not exist
    ubuntu@ubuntu:~$ sudo mkdir /mnt/xfs
    ubuntu@ubuntu:~$ sudo mount -t xfs -r /dev/sda2 /mnt/xfs
    mount: /dev/sda2 already mounted or /mnt/xfs busy
    ubuntu@ubuntu:~$ dmesg | tail
    [ 36.461352] lp: driver loaded but no devices found
    [ 36.490437] ppdev: user-space parallel port driver
    [ 37.000196] [drm] nouveau 0000:03:00.0: Allocating FIFO number 2
    [ 37.004232] [drm] nouveau 0000:03:00.0: nouveau_channel_alloc: initialised FIFO 2
    [ 45.329507] eth1: no IPv6 routers present
    [ 167.196518] [drm] nouveau 0000:03:00.0: nouveau_channel_free: freeing fifo 2
    [ 168.426389] [drm] nouveau 0000:03:00.0: Allocating FIFO number 2
    [ 168.429825] [drm] nouveau 0000:03:00.0: nouveau_channel_alloc: initialised FIFO 2
    [ 771.780029] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
    [ 771.782074] SGI XFS Quota Management subsystem
    ubuntu@ubuntu:~$ dmesg | grep sda
    [ 4.900470] sd 10:0:0:0: [sda] 1465149168 512-byte logical blocks: (750 GB/698 GiB)
    [ 4.900708] sd 10:0:0:0: [sda] Write Protect is off
    [ 4.900783] sd 10:0:0:0: [sda] Mode Sense: 00 3a 00 00
    [ 4.900812] sd 10:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    [ 4.901074] sda: sda1 < sda5 sda6
    [ 4.922744] sda7
    [ 4.924034] sda8
    [ 4.927566] sda9
    [ 4.927869] sdb: sda10 > sda2
    [ 4.935499] sd 10:0:0:0: [sda] Attached SCSI disk
    [ 5.589026] md: bind<sda5>
    [ 5.608849] md: bind<sda2>
    [ 5.611827] md: bind<sda7>
    [ 5.616248] md: bind<sda8>
    [ 5.632541] md: bind<sda9>
    ubuntu@ubuntu:~$ cat /var/run/dmesg.boot |grep sda
    cat: /var/run/dmesg.boot: No such file or directory
    ubuntu@ubuntu:~$ cat /var/run/dmesg.boot | grep sda
    cat: /var/run/dmesg.boot: No such file or directory
    ubuntu@ubuntu:~$ mount
    aufs on / type aufs (rw)
    none on /proc type proc (rw,noexec,nosuid,nodev)
    none on /sys type sysfs (rw,noexec,nosuid,nodev)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    none on /dev type devtmpfs (rw,mode=0755)
    none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    /dev/sdb on /cdrom type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    /dev/loop0 on /rofs type squashfs (ro,noatime)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    none on /dev/shm type tmpfs (rw,nosuid,nodev)
    tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
    none on /var/run type tmpfs (rw,nosuid,mode=0755)
    none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)
    /dev/sdc1 on /media/System Reserved type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
    /dev/sdc2 on /media/6880C42680C3F898 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
    /dev/loop1 on /media/casper-rw type ext2 (rw,nosuid,nodev,uhelper=udisks)
    ubuntu@ubuntu:~$
  48. Ok sorry for the spam. jsut finished trying the last of your suggestions and posting the text from that. gives a little info. Thanks!

    ubuntu@ubuntu:~$ dmesg |grep -i md
    [ 0.000000] RAMDISK: 7f4d2000 - 80000000
    [ 0.000000] Allocated new RAMDISK: 009a5000 - 014d2238
    [ 0.000000] Move RAMDISK from 000000007f4d2000 - 000000007ffff237 to 009a5000 - 014d2237
    [ 0.000000] Enabling unmasked SIMD FPU exception support... done.
    [ 0.000000] #12 [00009a5000 - 00014d3000] NEW RAMDISK
    [ 2.578293] Fixed MDIO Bus: probed
    [ 3.874923] pata_amd 0000:00:0d.0: version 0.4.1
    [ 3.874970] pata_amd 0000:00:0d.0: setting latency timer to 64
    [ 3.897180] scsi1 : pata_amd
    [ 3.899497] ata1: PATA max UDMA/100 cmd 0xcc00 ctl 0xc880 bmdma 0xc400 irq 19
    [ 3.899576] ata2: PATA max UDMA/100 cmd 0xc800 ctl 0xc480 bmdma 0xc408 irq 19
    [ 3.915503] scsi3 : pata_amd
    [ 3.917534] ata3: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
    [ 3.919305] ata4: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
    [ 4.442185] ata7: SATA max UDMA/133 cmd 0xa800 ctl 0xa480 bmdma 0xa000 irq 23
    [ 4.442266] ata8: SATA max UDMA/133 cmd 0xa400 ctl 0xa080 bmdma 0xa008 irq 23
    [ 4.443074] ata9: SATA max UDMA/133 cmd 0x9c00 ctl 0x9880 bmdma 0x9400 irq 22
    [ 4.443150] ata10: SATA max UDMA/133 cmd 0x9800 ctl 0x9480 bmdma 0x9408 irq 22
    [ 5.272805] md: bind<sdb5>
    [ 5.275455] md: bind<sdb7>
    [ 5.280501] md: bind<sdb8>
    [ 5.283207] md: bind<sdb2>
    [ 5.285971] md: bind<sdb9>
    [ 5.722011] [drm] nouveau 0000:03:00.0: TMDS table revision 2.0 not currently supported
    [ 5.990083] [drm] nouveau 0000:03:00.0: Detected a TMDS output
    [ 5.990230] [drm] nouveau 0000:03:00.0: Detected a TMDS output
    [ 19.149809] md: linear personality registered for level -1
    [ 19.152168] md: multipath personality registered for level -4
    [ 19.154568] md: raid0 personality registered for level 0
    [ 19.157781] md: raid1 personality registered for level 1
    [ 19.847739] md: raid6 personality registered for level 6
    [ 19.847743] md: raid5 personality registered for level 5
    [ 19.847745] md: raid4 personality registered for level 4
    [ 19.854574] md: raid10 personality registered for level 10
    ubuntu@ubuntu:~$ sudo fdisk -l

    Disk /dev/sda: 2002 MB, 2002780160 bytes
    62 heads, 62 sectors/track, 1017 cylinders
    Units = cylinders of 3844 * 512 = 1968128 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xbb0eb409

    This doesn't look like a partition table
    Probably you selected the wrong device.

    Device Boot Start End Blocks Id System
    /dev/sda1 ? 896832 1382432 933323145+ 66 Unknown
    Partition 1 has different physical/logical beginnings (non-Linux?):
    phys=(1010, 16, 43) logical=(896831, 25, 13)
    Partition 1 has different physical/logical endings:
    phys=(906, 97, 3) logical=(265114, 11, 23)
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 ? 1 1 0 72 Unknown
    Partition 2 has different physical/logical beginnings (non-Linux?):
    phys=(101, 116, 32) logical=(0, 41, 32)
    Partition 2 has different physical/logical endings:
    phys=(370, 114, 47) logical=(0, 41, 31)
    Partition 2 does not end on cylinder boundary.

    Partition table entries are not in disk order

    Disk /dev/sdb: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0b5289df

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 125 1004031 5 Extended
    /dev/sdb2 126 91201 731567970 83 Linux
    /dev/sdb5 1 16 128457 82 Linux swap / Solaris
    /dev/sdb6 17 17 8001 83 Linux
    /dev/sdb7 18 18 8001 83 Linux
    /dev/sdb8 19 40 176683+ 83 Linux
    /dev/sdb9 41 124 674698+ 83 Linux
    /dev/sdb10 125 125 8001 83 Linux

    Disk /dev/sdc: 750.2 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xbb14e257

    Device Boot Start End Blocks Id System
    /dev/sdc1 * 1 13 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sdc2 13 25497 204697600 7 HPFS/NTFS
    /dev/sdc3 25497 57368 256000000 7 HPFS/NTFS
    /dev/sdc4 57368 91202 271771648 7 HPFS/NTFS
    ubuntu@ubuntu:~$ Is -l /dev/md
    Is: command not found
    ubuntu@ubuntu:~$ ls -l dev/md*
    ls: cannot access dev/md*: No such file or directory
    ubuntu@ubuntu:~$ ls -l dev/md
    ls: cannot access dev/md: No such file or directory
    ubuntu@ubuntu:~$ ls -l /dev/md
    ls: cannot access /dev/md: No such file or directory
    ubuntu@ubuntu:~$ sudo mdadm --detail /dev/md0
    mdadm: md device /dev/md0 does not appear to be active.
    ubuntu@ubuntu:~$ sudo mdadm --stop /dev/md0
    mdadm: stopped /dev/md0
    ubuntu@ubuntu:~$ sudo mount -t xfs -r /dev/sdb2/mnt/xfs
    Usage: mount -V : print version
    mount -h : print this help
    mount : list mounted filesystems
    mount -l : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
    mount -a [-t|-O] ... : mount all stuff from /etc/fstab
    mount device : mount device at the known place
    mount directory : mount known device here
    mount -t type dev dir : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
    mount --bind olddir newdir
    or move a subtree:
    mount --move olddir newdir
    One can change the type of mount containing the directory dir:
    mount --make-shared dir
    mount --make-slave dir
    mount --make-private dir
    mount --make-unbindable dir
    One can change the type of all the mounts in a mount subtree
    containing the directory dir:
    mount --make-rshared dir
    mount --make-rslave dir
    mount --make-rprivate dir
    mount --make-runbindable dir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using -L label or by uuid, using -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say man 8 mount .
    ubuntu@ubuntu:~$
  49. Hi, first of all sorry for my english.

    Then, I have same problem and I solve it with this steps (not news, but it seems work):

    1) $sudo nano /etc/fstab
    add last line-> /dev/sdb2 /mnt/xfs xfs ro,user,noauto 0 errors=remount-ro 0 1

    2) restart

    3) $sudo mount
    -> unmount all innecessary volumes, in my case:
    $sudo umount /dev/md1

    4)$ls -la /dev/md*
    ->for all md devices:
    $sudo mdadm --stop /dev/md0
    $sudo mdadm --stop /dev/md1
    $sudo mdadm --stop /dev/md2
    $sudo mdadm --stop /dev/md3
    $sudo mdadm --stop /dev/md4

    5)$ls -la /dev/md*
    -> it must be empty

    6) sudo mount -t xfs -r /dev/sdb2 /mnt/xfs

    And it works! Good luck!
Ask a new question

Read More

NAS / RAID Enclosure Lacie Storage