Sign in with
Sign up | Sign in
Your question

Can't enter BIOS setup with new hard drive?

Last response: in Storage
Share
October 24, 2009 11:12:33 PM

I recently purchased a Samsung HD103SJ F3 1TB, connected it up and attempted to install my new copy of Windows 7 on it.
It is apparently detected by my motherboard (an old Gigabyte GA K8N Pro) as I can see the hard drive's name as the computer starts up. What is weird however, is that after pressing delete to enter setup (and it says "Preparing to Enter Setup"), it never does - it just waits indefinitely at the GigaRAID BIOS screen ("Please wait for RAID configuration" is flashing).
The fact that I can't enter BIOS setup means I can't check or adjust any of the SATA settings and hence attempt to cure the problem.
I gave up and installed Windows on a older drive I knew worked, hoping that I could use the F3 simply as a second disk (not in RAID), but exactly the same thing happens even when it there is a working bootable disk installed.
The SATA chip on my mobo has Hot Plug functionality so I am able to connect it when Windows is up and running, and it works fine...it just won't boot with it.
I suspect it could be something to do with the fact that the F3 is SATA II and my mobo almost definitely isn't, but I'm unsure how to rectify that if that is the case (I tried putting a jumper across a couple of the pins, but that rendered the drive completely undetectable).
Many thanks for any light that can be shed on my problem.

More about : enter bios setup hard drive

a b G Storage
October 26, 2009 11:47:34 AM

Clear the bios first.
Your motherboard may need a bios update for a disk of that size.
October 26, 2009 8:50:45 PM

Clear the BIOS as in dislodge the CMOS battery? I've tried that I think, but I'll try it again.

Thank you for your advice about updating BIOS. I was hoping to avoid that if possible, but I'm running out of ideas!
Related resources
a c 362 G Storage
October 27, 2009 6:10:43 PM

If your mobo has an original SATA (aka "SATA I") controller it may be unable to communicate with a SATA II device, even though they are "supposed to" work anyway. You can force the Samsung drive to go slower at the SATA I speed with a jumper. Details here from the Samsung site:

http://downloadcenter.samsung.com/content/UM/200510/200...

There is even a software tool you can get from their site if you cannot get a jumper solution to work for you.
October 29, 2009 9:54:45 PM

I think I'm already on the latest version of BIOS and hence can't update it...pity!

Yes thanks Paperdoc, I did try altering the speed with a jumper. The weird thing is that my hard drive only has 4 pins, whereas all the diagrams I've seen show 8 pins, so I'm not sure if the diagrams apply to my hard drive. Anyway I tried placing the jumper in the 4 possible vertical and horizontal positions and didn't get any results.

Is the software you speak of the "Hutil" (Hard Disk Diagnostic Utility) and/or "Disk Manager"?

What I don't really understand is how the hard drive can apparently communicate with my mobo as it detects its name and capacity, but there is some kind of barrier preventing me entering the BIOS with it...
November 1, 2009 1:16:00 PM

Cheers for the links Paperdoc.

As I can't get any further than the SATA RAID POST screen thingy with the new hard drive connected, I had to boot up with my old hard drive, then swap in the new one once ESTool was up and running. Fortunately, that worked fine and it was detected.

That third post you mentioned is a bit ambiguous - do you think he meant the SET MAX UDMA MODE wasn't there until he changed to AHCI mode, or the SATA 150(1.5) ↔ 300(3.0) option within SET MAX UDMA MODE wasn't there?

I have the SET MAX UDMA MODE, but all I can do in it is, well, set the max udma mode! I am on Mode 6 (UDMA 133) and can change it to 33, 66 or 100. Should I try changing them or the other things ESTool offers?

As far as I can see, the only options I have for my SATA controller are BASE and RAID, and I think I read somewhere on the internet that RAID mode should include things like AHCI. I've always been on RAID, so based on that other guy's post I should have the SATA speed option, but I don't....!
a c 362 G Storage
November 4, 2009 8:48:33 PM

AH! A light dawns!
You said in the original post, "it just waits indefinitely at the GigaRAID BIOS screen ("Please wait for RAID configuration" is flashing). " Now you say, "I've always been on RAID". It appears you have told your mobo to use the drive attached to this SATA port as a RAID device and it can't do that. Well, from what you say you do NOT plan to use it as a RAID device, so you should change the setting.To do that, you need to get into BIOS Setup, but your first post says it won't go there because it gets stuck trying to figure out the HDD. Disconnect that drive and boot without it, while holding down the "Del" key. (Oh, by the way, some mobos use a different way to get into BIOS - check the Gigabyte website to be sure if the "Del" key is right.) When you get into BIOS, go to where the SATA ports are set up and change the mode. Besides RAID, you may have choices like IDE (or PATA) Emulation, native SATA, or AHCI. IDE Emulation almost always will work, but you lose a few advantages, and that MAY not let you make the changes to drive communication speed that the Samsung website talks about. (BUT you may not need to - the idea that you might was based on not completely understanding your problem.) Win 7, however, is supposed to be completely able to use both native SATA and AHCI protocols for HDD's, so chose one of them if available. Then Save and Exit, and shut down. Reconnect your Samsung and boot up again f you want, go back into BIOS and check the SATA port is still set as you wish. Then, assuming you plan to use this drive with Win 7 on it as the boot drive to be used as C:, make sure you find the Boot Priority Sequence BIOS screen and set it to boot from the optical drive first, then this Samsung SATA drive next. Save and Exit with the Win 7 Install disk in the optical drive, and it should boot from there and get you started on installation.
November 5, 2009 9:02:46 PM

Thanks for the continued support Paperdoc.

I had actually been slightly confused in my first post...it actually gets stuck at the SATA RAID bit (GigaRAID is for the IDE channels I believe, SATA and Giga both appear on the same "screen" which is what confused me) so I don't think the ""Please wait for RAID configuration" is flashing" bit is relevant. The name of my new hard drive is displayed, but the cursor waits where its capacity should be displayed, so maybe it is a size issue?

Thanks for the detailed instructions, but I know how to get into BIOS (and how to do a fresh install of Windows) and have done so many, many times over the last couple of weeks! In the "Integrated Peripherals" section, there is an option to Enable/Disable "Onboard Serial ATA" (which I obviously have enabled), but I only have two choices for "Serial ATA Function"; BASE and RAID. No IDE, native SATA, AHCI or anything else. As mentioned previously, I have had it in RAID so I tried changing it to BASE and there is no difference; it still can't get past displaying the new hard drive's name, and ESTool doesn't give me the option to change speeds.

Can I flash just the SATA controller (SilImage 3512) perhaps, maybe there is a newer update for that than for my BIOS? My problem isn't related to mobo drivers that I haven't installed in Windows or anything, could it?
a c 362 G Storage
November 6, 2009 1:30:11 PM

This is starting to look like you have a bad HDD that needs warranty replacement. The BIOS message says it is trying to communicate with the HDD and actually gets as far as the disk name, so it's talking to the HDD's controller board. But it can't get any further, making me suspect the unit is unable to read its own disks. Either that, or the SATA / SATA II incompatibility is causing the problem (BUT, as I said, the "incompatibility" may not even exist if you mobo's SATA controllers are SATA II.)

Can you temporarily install the unit in another machine and see if you can get it to co-operate with that machine? If a different machine has the same trouble with it, especially if it is a SATA II controller machine, that would REALLY say the HDD is bad. But if a different machine with SATA II controller CAN talk to the disk just fine, you know there's something odd in your machine. Before doing this, though, see if you can download any HDD testing utilities from the Samsung site. If the new machine can talk to your drive, you should run testing utilities on it there to verify the HDD unit's condition. And if that all works, then on THAT (other) machine you could run the ES Tools software to force the older SATA communication rate setting. Then you could take it back to your machine and see if the problem is fixed.

NOTE: Before proceeding above, see my additional comments in the last section below regarding what I found in your mobo's manual!

There is no way to "flash" one controller chip on a mobo. In fact, all of the code that can be revised by a "flash" operation is in the BIOS EEPROM, so the only updating you could do is the entire BIOS.

The problem cannot be linked to Windows drivers. You're not getting close to that - you're getting stuck in the BIOS before it ever finishes the POST, and it looks like it has not even got to the point of trying to read boot data from the HDD.

I was just looking at your mobo's main manual and noted a few things to check.
1. It has 2 original (slower 1.5 Mb/s) SATA ports provided by the Silicon Image controller. So, using a SATA II HDD with it might cause this "incompatibility" problem.
2. It provides two standard IDE ports from the main chipset and recommends you use these (or at least one of them) for your optical drive(s). As with any other IDE port, each of these can handle up to two devices if your ribbon cable has the connectors for it.
3. It also provides two additional IDE ports (3 and 4) to be used ONLY for HDD's from a Gigaraid controller chip that gives you RAID capability on these IDE ports only. It appears from your screen messages that this is the controller chip that is trying to do something and freezing.
4. The two SATA ports are provided by a Silicon Image controller chip. They also have RAID capability optional. The simple hardware diagrams suggest that somehow the Gigaraid and SIL controller chips share some part of a pathway to the main chipset.

I am now wondering if somehow the boot sequence gets the HDD's name from the Silicon Image SATA controller, then the other Gigaraid controller takes over and tries to access a device it does not have, and freezes.

The downloadable manual I got shows Integrated Peripherals configuration beginning on page 47. I'm sure you have IDE drives, and I expect they are connected to the two main IDE ports, 1 and 2, located above the battery next to the Floppy Drive port. So you certainly want the Primary and Secondary On-Chip PCIIDE ports Enabled. Then you have the Onboard SATA ports that should be Enabled and set to BASE mode (not RAID). Then comes the on-board Giga-RAID ports. I expect there is no device attached to those ports (bottom right corner of the mobo), so they should be DISabled so the BIOS makes no attempt to use them. I am hoping that this will help to solve your problem by preventing the BIOS's POST process from trying to make sense of the devices on the GigaRAID ports when there are none!

Even if you get this to work so your board can boot, you still will have the potential for a SATA controller / SATA II HDD mis-match. I can see what you say - this BIOS does not have the more modern options, so your only choice is really "native SATA" mode (called "BASE") or RAID mode. For longer-term operations this should not be a problem because Win 7 DOES know how to deal with native SATA devices. But there still MIGHT be a problem if the ES Tools utility really does require that the SATA HDD be run in AHCI mode in order to make its communication speed adjustment. But, you could get lucky. You may not have to make any adjustment if the drive and controller can negotiate their differences without your intervention. Or, can you use jumpers on your drive to make the change? Or, ES Tools may be able to make the adjustment in the available mode. Anyway, all of this only becomes possible if you can get all the way through the BIOS POST routine.
November 10, 2009 9:22:18 PM

Wow that was a long reply!

It's true that it apparently has trouble reading its capacity on bootup. However, after booting up with another disk and plugging in the new hard drive, it seems to work fine so I suspect it is not faulty. Also, I ran the tests in ESTool on it, and it passed them all.

Installing in another machine is a good idea...I tried doing so in the other desktop in y household, but as that mobo is I believe less "good", it unsurprisingly didn't work...ESTools didn't even detect it.

Speaking of this other desktop, I removed its floppy drive to run the various diagnostic tools on my PC. And now, the other destop can't load its operating system! I have no idea how removing a floppy drive could do that, so maybe it's a coincidence. Either way, the fact that I now have two desktops not functioning properly is giving me more of a reason to simply buy more hardware or come up with some solution which solves both problems and doesn't involve getting my PC to boot up with the new hard drive.

By the way, I'd already tried disabling "GigaRaid" - no change. I may try contacting Samsung to ask them how to set the F3 to run at SATA I speeds given that it only has four jumpers.

Whatever I do, I'll keep you posted!
a c 362 G Storage
November 12, 2009 12:37:44 PM

The new problem with your older machine may have a simple solution. My bet is that machine's BIOS had its Boot Priority Sequence set to boot from the floppy drive first, then default to the hard drive if there was no bootable disk in the floppy drive. However, you removed that drive unit. So when it boots it tries to check the floppy drive for a bootable disk and finds - there is no such device! Then it gets stuck trying to make it work. Either return the floppy drive to that unit, or change its BIOS settings so it does NOT try to use the floppy drive to boot from, and that may fix the problem.
November 13, 2009 9:20:49 PM

I did return the floppy drive! Windows (2000!) starts to load so the hard drive is detected, but it only gets about 3 "bars" across before waiting for a couple of minutes, then it asks for a system recovery disk, which I will not be able to find!

I'm talking with people with newer boards about setting the slower speed in their machines...
February 28, 2010 7:50:21 AM

I know what the problem is. And it has nothing to do with what has been said so far. I had this same exact problem. Even with the exact same HDD! And a similar motherboard. That is a Socket A board, right? (I didn't bother looking it up.) Anyway, your problem, and your answer, is this: the firmware on the motherboard for the RAID controller chip is too outdated to support hard drives of this size. And Gigabyte never bothered to release a BIOS which includes newer firmware. What needs to be done is a newer firmware needs to be downloaded for the RAID controller, and it must be integrated with the motherboard BIOS. That is, your BIOS needs to be modded. Then flash your mobo with modded bios. It's actually much easier than it sounds. I have the SI 3112 raid controller on my mobo. Depending on what yours is you may have to do a little more work finding the appropriate download.

To read my own thread which I started about this same issue, and the successful resolution to it go here:
http://hardforum.com/showthread.php?t=1491016

I stumbled across this thread from a google search about something else (trying to figure out the correct settings to use in my bios), and I decided to spread the knowledge, since I myself got saved by Captain Jack Sparrow in the same way. Good luck.

August 25, 2010 7:00:06 PM

Hi

I also believe it is a BIOS problem but you might not need to flash.

I had this problem and solved it by:
-Disconnecting the harddrive(s)
-Go into the BIOS
-Connect the harddrives and detect them
-Select 'LARGE' instead of 'AUTO'
-Save and exit

The 'AUTO' setting was the problem. Whenever I put 'AUTO' again the problem returns.
You probably don't have to connect the drives when the computer is on if you can set 'LARGE' for all unused drive slots and save. Connecting while the computer is switched off after that should work.

Cheers,
Jaco
August 26, 2010 8:17:04 AM

Jaco. Read my post. I believe what you suggest does not address the problem. The problem is the old SATA controller not being able to handle such a large HD. I had the exact same problem with an even older SocketA-based gigabyte mobo in combination with that exact same HD. All sorts of plugging and unplugging did not solve it; modding the bios by inserting a newer version of the SATA controller did solve it.
!