Sign in with
Sign up | Sign in
Your question

Help! 3D graphics problem - ATI Radeon 9800xt graphics card

Last response: in Graphics & Displays
Share
July 15, 2008 6:06:49 AM

Hi it's my first post here. Really need some expert advice from this forum.

Bought this graphics card on Ebay. The seller claimed card works with my motherboard and Windows Vista - that I can display the Aero glass graphics etc.

The drivers that came with the installation CD was outdated - I didn't know and it crashed my PC (black screen can't see anything) so I had to reinstall Windows. Originally I was on Windows XP but I decided to upgrade OS to Vista. Then I downloaded and installed new drivers from ATI website.

After reinstall, Vista graphics looked alright. However, my 3d graphics were bad! My Windows Experience Index scores were quite good except 3D which is only a score of 3.

Problems of 3D graphics as shown on the following pics:



As you can see, the 3D rendering has gone "weird" and I have vertical stripes on my LCD monitor which is extremely obvious when running 3D screensavers, slideshows & games. Anything to do with graphics, it's bad.

Here are my PC hardware details:

Motherboard: Gigabyte GA-8IEXP Rev 2.0 (Intel 845 chip)
Processor: Intel Pentium 4, 2.4Ghz
Graphics: ATI Radeon 9800xt 256MB AGP (manufactured by HongSun - chinese company)
Power: Antec EarthWatts 430W
Memory: 2 X 512MB (total 1GB) RAM (I'll be upgrading to 2GB soon)

My AGP slot supports 4X graphics card. This card I purchased was 8X but is backward compatible to my motherboard.

I tried to contact seller who refused to help. I also tried to contact the manufacturer but got no reply!

Can someone please help as I don't understand why I have these problems with my graphics. How do I fix this?

Thanks!
July 15, 2008 8:39:58 PM

Try uninstalling the drivers, then go into safe mode and run a program called drivercleaner and then install the newest drivers for the 9800XT series.

To say the least its 1 of 3 things. Drivers overlapping causeing corruption, no true Vista support for the 9800XT series or last but not least bad video memory.
July 15, 2008 11:21:21 PM

OK will try that and see how it goes. Cheers
Related resources
July 16, 2008 1:31:08 AM

Hi I have uninstalled the drivers, used DriverCleaner and reinstalled Catalyst new version 8.6.

I still got the same bad 3D graphics and vertical stripes on screen.

:cry: 

Have I bought a dud?
July 17, 2008 4:55:28 PM

It seems like it. Try lowering the resolution and the depth (16bit/32bit) and see if that does anything.

It does seem like the GPU has bad VRAM.
July 22, 2008 4:07:47 PM

Have the same problem, with the same graphics card,. Swapped the card for a slightly older (spare) GForce card and hey presto up and running again. (Suspected the monitor at first). Checked the 9800XT visually and found the air ducts blocked with dust and the cooling fan runs slow at first and speeds up. Possible heat damage?
July 24, 2008 10:46:00 PM

clean it out, try again
!