Sign in with
Sign up | Sign in
Your question

LiteOn ATAPI

Last response: in Storage
Share
October 31, 2009 3:36:48 AM

I bought a LiteOn Combo Drive. with SATA interface model iHAS424-98 Y

When I built my system with an EVGA 3x SLI MOBO X58
everything seemed okay. After a few reboots I noticed the MoBo displaying a ATAPI device in green lettering followed by "press any key to continue"

At first it wasn't a big deal since I was putting the system together but then when I went to install Windows 7 and tried to boot from CD-Rom the BIOS was saying no device found but there was also a separate device listed as the ATAPI and I could boot the OS through that.

Windows device manager also listed it as an ATAPI device but it worked fine when it came to reading CD's.

A few days later I went ahead and installed NERO that came with the device and it loaded drivers for the CD.

After Reboot I still get the same BIOS message, but now the Device is not under my computer and it does not boot CD's

In the Device Manager it now shows a device that is SATA ATAPI iHAS424 SCSI CdRom Device.

I can roll back the driver and when I try to update windows tells me it is the newest one.

I am wondering if the firmware on this thing is screwed up because it shouldn't be showing up as an ATAPI. LiteOn doesn't have a firmware update for it either. I thought ATAPI is associated with IDE.

Any suggestions or should I call LiteOn/ New Egg and try to get this thing returned / replaced.

More about : liteon atapi

a b G Storage
October 31, 2009 11:29:12 AM

ATAPI is just the name LiteOn decided to use for this drive (and many other models). I have the same drive and it also shows up as ATAPI iHAS424.
Both SATA and PATA are part of the IDE and ATA/ATAPI standard.

If you want to make sure your drive is working properly you can use a utility called Opti Drive Control.
m
0
l
October 31, 2009 8:25:56 PM

Right now I cant use the drive as it is not recognized by windows because there is an issue with the driver file after I installed Nero Essentials. I can't roll back the driver so I am stuck with a Drive that does not work.
m
0
l
Related resources
a b G Storage
October 31, 2009 8:52:47 PM

Your motherboard has three different SATA controllers. I would definitaly use one of the ICH10R Southbridge SATA ports.
m
0
l
November 1, 2009 5:14:21 PM

Thanks for the help. I switched it to the south port controller. I spaced and didn't realize I attached it to JMicron controller which has been giving others trouble when it comes to certain CD drives. My windows however is still not showing the CDROM it is saying there is an unsigned driver and it is not working properly. I don't know what is going on with that.
m
0
l
!