Sign in with
Sign up | Sign in
Your question

External drive problem

Tags:
  • External Drive
  • Storage
Last response: in Storage
Share
November 1, 2009 5:22:51 AM

Good Day,

i need help in my problem in external hard drive (120gb SATA) this came from an old computer and works fine, but when i insertit in an external casing to become an external drive via USB2.0, it seems that it cannot be detected with the full capacity of the drive it only detects about 8GB or Less, how ever i tried installing it in another computer to test it and it detects the full capacity. what seems to be the problem? why cant i use it as an external drive? and another thing it also happens in the SD card 2GB when i insert it in my memory card reader it detects 2GB but it doesnt show any of its contents. THANKS please help me

specs of my compter:

Computer Type ACPI Multiprocessor PC
Operating System Microsoft Windows XP Home Edition
OS Service Pack Service Pack 3
Internet Explorer 8.0.6001.18702
DirectX 4.10.0.5515 (DirectX 10)

Motherboard
CPU Type DualCore Intel Pentium D 805, 2666 MHz (20 x 133)
Motherboard Name Gigabyte GA-8I865GME-775(-RH) (3 PCI, 1 AGP, 2 DDR DIMM, Audio, Video, LAN)
Motherboard Chipset Intel Springdale-G i865G
System Memory 1536 MB (PC3200 DDR SDRAM)
DIMM1: Kingston K 1 GB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz)
DIMM3: 512 MB PC3200 DDR SDRAM (3.0-4-4-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-3-3-6 @ 133 MHz)
BIOS Type Award Modular (02/21/06)

Display
Video Adapter Radeon X1650 Series Secondary (512 MB)
Video Adapter Radeon X1650 Series (512 MB)
3D Accelerator ATI Radeon X1650 (RV535)

Storage
IDE Controller Intel(R) 82801EB Ultra ATA Storage Controllers
Disk Drive ST3320620AS (320 GB, 7200 RPM, SATA-II)
SMART Hard Disks Status OK

Partitions
C: (NTFS) 100100 MB (66080 MB free)
D: (NTFS) 100100 MB (60382 MB free)
E: (NTFS) 102.6 GB (62.3 GB free)
Total Size 298.1 GB (185.8 GB free)

More about : external drive problem

a b G Storage
November 2, 2009 11:14:11 AM

SD card: check the partition type with GParted or any other partitioning program.

m
0
l
a b G Storage
November 2, 2009 11:28:42 AM

Is the jumper correct on the hard drive in the external enclosure?
m
0
l
Related resources
November 4, 2009 7:40:01 PM

evongugg said:
Is the jumper correct on the hard drive in the external enclosure?



ohh do i have to put a jumper on my external drive??? i removed the jumper, what should i do with it? and my hard disk is sata.
m
0
l
a c 363 G Storage
November 4, 2009 8:19:27 PM

What type of drive is this 120 GB unit in the external case? If it is an older ATA drive it will have to have its jumper set to be a Master or a Slave, according to the instructions with the external drive case. On the other hand, if it is a SATA drive, there are NO jumpers for Master or Slave. BUT there may be a need for a jumper anyway. We now are using SATA II drives that communicate at twice the rate of the original SATA drives. However, some people run into the situation (and quite possibly this is yours) of having a faster SATA II drive to connect to an older original SATA controller. Now SATA II drives are supposed to be able to sense this and adjust themselves, but many can't. So drive makers have ways to force the new faster drive to slow down to original SATA communication speeds. Many (Seagate is one) do this by a jumper on pins. Seagate actually had a policy that they shipped drives with the jumper installed to force the older slower mode, and anyone who knew they had a real SATA II (faster) controller is supposed to remove the jumper.

Just MAYBE you have a drive unit that WAS jumpered to old SATA performance in a case equipped with a original SATA controller, and then you removed the jumper! If that is the case, go to the website of your disk's maker and look up how to force it to older SATA speeds, and try that out. If it solves your problem, Hurray! If not, no harm done - ALL newer SATA II controllers CAN handle an older slower SATA drive (or a new SATA II that has been forced to run slower). But if this does not solve the problem and you conclude you don't need the slower communication rate forced, you can remove the jumper again.
m
0
l
November 4, 2009 10:16:09 PM

Paperdoc said:
What type of drive is this 120 GB unit in the external case? If it is an older ATA drive it will have to have its jumper set to be a Master or a Slave, according to the instructions with the external drive case. On the other hand, if it is a SATA drive, there are NO jumpers for Master or Slave. BUT there may be a need for a jumper anyway. We now are using SATA II drives that communicate at twice the rate of the original SATA drives. However, some people run into the situation (and quite possibly this is yours) of having a faster SATA II drive to connect to an older original SATA controller. Now SATA II drives are supposed to be able to sense this and adjust themselves, but many can't. So drive makers have ways to force the new faster drive to slow down to original SATA communication speeds. Many (Seagate is one) do this by a jumper on pins. Seagate actually had a policy that they shipped drives with the jumper installed to force the older slower mode, and anyone who knew they had a real SATA II (faster) controller is supposed to remove the jumper.

Just MAYBE you have a drive unit that WAS jumpered to old SATA performance in a case equipped with a original SATA controller, and then you removed the jumper! If that is the case, go to the website of your disk's maker and look up how to force it to older SATA speeds, and try that out. If it solves your problem, Hurray! If not, no harm done - ALL newer SATA II controllers CAN handle an older slower SATA drive (or a new SATA II that has been forced to run slower). But if this does not solve the problem and you conclude you don't need the slower communication rate forced, you can remove the jumper again.




i thinks its a older version of sata it has a jumper pins but dont have any jumper on it so what do i have to do should i make it as a master or a slave to be detected on its full capacity? the brand is a western digital and its a hard disk for desktop and i just putted it in a external casing
m
0
l
a c 363 G Storage
November 5, 2009 2:14:31 AM

OK, there are four combinations, and only one can cause trouble.
Old SATA case, old SATA drive - no problem
New SATA II case, old SATA drive - no problem
New SATA II case, new SATA II drive - no problem
Old SATA case, new SATA II drive - possible problem

When I say "case", I mean the interface inside the case between case and drive. The interface between case and computer is not involved here.

For a WD 120GB SATA drive, start by searching the WD website for specs for your drive - use its exact model number. That will tell you whether you drive is SATA (old) or new SATA II. It also will tell you how to force a SATA II drive to the slower 1.5 Gb/s communication rate, quite possibly by putting a small jumper over two specified pins in the back edge of the HDD unit. If you don't have a little jumper like that, ask at a computer repair / parts shop, but SPECIFY that you want one for a SATA drive for speed adjustment, and NOT the larger jumper for an IDE drive.

By the way, you are NOT setting the drive for Master or Slave. There is no such thing in SATA. You are only forcing it to a communication speed.

If this old-SATA-compatability adjustment does not fix your problem, you may well have a dead drive. OR, it may have been Partitioned and formatted to a small Partition. Do you know how to use Disk Manager to examine details of the allocation of space on the drive to Partitions?
m
0
l
!