Sign in with
Sign up | Sign in
Your question

Why external floppy dont work anymore

Tags:
  • Device Manager
  • Floppy Disk
  • Format
  • Storage
Last response: in Storage
Share
November 2, 2009 6:06:27 PM

My external floppy used to work. I used to be able to open floppy disks. Now-It keeps saying to format. It doesn't format. I can't open a floppy disk.
I went to someone else's house to test it. I did have the old one & the new one working at someone else house.
The device manager recognizes it.
What is wrong?

More about : external floppy dont work anymore

a c 367 G Storage
November 4, 2009 8:28:31 PM

Maybe your drive just has dirty heads. You can get small kits to clean the heads of a floppy drive. They have a thing that looks like a diskette, but it contains a white scrubby material. They usually have a small dropper bottle of methanol or iso-propanol, and you put a few drops of the alcohol on the white scrubber and the put it into the disk drive. When I do this I usually try to "open" the "disk" which forces it to spin for a while until it figures out that it can't read it. Then I simply cancel the read attempt and remove the cleaner from the drive. Then you should wait a while (say, 10 minutes) for any alcohol left on the drive's heads to evaporate off before trying to use the drive on a real diskette.

Be warned: if you do have a drive with dirty heads, that can actually scratch the diskette surface, damaging it. If that happens to the first track where the root directory and FAT table are, your diskette may NOT be able to be read at all, and you'll lose the data on it. So I got into the habit (because I use floppies rarely) of cleaning the drive before use to avoid destroying the diskette I was about to use.
m
0
l
a c 127 G Storage
November 5, 2009 4:08:14 AM

Floppies never worked for me. Created a floppy, verified it read correctly, then moved it into another drive and it would have read errors.

Thank god almighty i never have to touch that darn technology ever again. Floppies are evil, they were made to annoy people and go play outside instead of mess with old ancient stone-age technology.

There, that felt like a relief. :D 
m
0
l
Related resources
November 15, 2009 1:15:21 AM

No answers yet.
In my question I said= I went to someone else's house to test both external floppy drives.
I did have Both the old external floppy drive & the new external floppy
drive = Both were WORKING at someone else's house.
The device manager recognizes it at my house.
It is cleaned ..
Maybe some setting got changed?? What is wrong?
Thanks for your help anyway.
m
0
l
a c 367 G Storage
November 16, 2009 1:22:24 PM

MAYBE your machine at home just lost track of the drivers and port for this USB device. Try using Device Manager to Remove this Device and its drivers, then disconnect it and reboot so they really are gone. Then shut down, hook it back up, and reboot again. If you have them, re-install the driver for it. Might help, who knows?
m
0
l
March 27, 2011 2:44:27 PM

I Tried that myself, didn't work, Im getting all the same errors, wont read none of my Disks, Just keeps saying that they need to be formatted and when I click yes, it then said, windows is unable to format then goes back to MY Computer screen, i have an old laptop with Win95 on it, why my dad wants to use it I dunno, but it doesnt have any games on it, so I downloaded some ol skool games on my PC here with is XP pro with SP3, it would be nice if my floopy drive would quit acting like an ass hat and just work haha., the Laptop only has A floppy drive on it, otherwise I just say tha hell with it, too much of a headache, I also have a couple of floppys already with data on them and it still doesnt read them, I've tried to lock and unlock the disk, even tape up the other hole on the other side of the floppy, tired with it lock and unlocked again, didn't work. So Floppy Disks sux ass nowdays lol
m
0
l
!