Sign in with
Sign up | Sign in
Your question

Interesting Inability to Connect

Last response: in Wireless Networking
Share
August 1, 2009 2:50:11 AM

I just bought a new Lenovo laptop. I started the configuration at work and then brought it back home. The computer was able to connect fine to the secured wireless points at work - and still is (802.1X). But when I got home, it was unable to connect to the simple, WEP-protected D-Link router.

It locates the WAP fine and prompts for the Network Key. I enter it, but it doesn't seem to receive any information from the router DHCP - or at least that seems to be the sypmtom. After about 30 seconds of the Windows icon doing its connection animation, it finally decides it's going to be 'Limited or no connectivity', with no IP, DNS, Gateway, etc.

So I temporarily set the WAP back to a completely open, unprotected setup. And the laptop connects fine. Return to WEP, and no luck.

Anyone have any ideas what might be going on. Yes, I know I shouldn't be using WEP, blah, blah, blah. Haven't tried WPA yet. (If I were just concerned with solving the problem, I could just go completely open, since I know that works.) But at this point, I'm just more curious as to what might be causing the problem. At the very least, I'm only in this particular house for another two weeks or so anyhow.

The wireless card is an Intel WiFi 5100. I'm using the Windows wireless config applet. (Though I also tried Lenovo's proprietary applet to no avail, for kicks and giggles.) It's set for DHCP, etc., etc.

The router is a D-Link DI-524, broadcasting on 802.11g, 64-bit Open WEP. Its DHCP is up and running, and my desktop is connecting to it without a problem.

Any ideas on what might the cause of it all?

ADDED: Even more interesting - if I switch the WEP pattern from HEX to ASCII, it seemed to work just fine. So I played around with it some more, and I think I figured out the culprit, but still not the root cause. It's the number 0. If a 0 is in a HEX WEP key, the laptop won't connect But if I make the WEP key 0-less (or ASCII, since it seems to handle '0's in ASCII fine), it connects without a problem. It's as if it doesn't know how to transmit a '0' in hex.

So bizarre! Anyone have any idea why that might be the real problem underlying it all??
August 1, 2009 11:18:06 PM

We have found it necessary to replace some routers because they would not work with WEP encryption. The wireless devices were not WPA capable.
Firmware update did not help.
m
0
l
August 3, 2009 1:57:12 PM

Well, the thing is, the router seems to work with the other three systems in the house, including my desktop. As I said, it's really just a bizarre, bizarre symptom.
m
0
l
!