New build PC won\'t start please help

I have a x-power pro 650 power suply on a m4a88td-v evo/usb3. Is this a good power sorce for this board?
5 answers Last reply
More about build start help
  1. Depends how much gear you have running of it, and your asking the wrong guys I think, this is more of a hardware related issue.

    I had a 600 running a i5 with all the basics, but when I did a re build and put it into a Antec Gaming case with all the lights, and a SLI running this time it shagged it self.

    Tell us more about your system... do you overclock? How manny fans, cards, and Hdd's do you have running of this Psu, if it is the Psu that you are worried about
  2. sorry to say I would not trust that PSU.

    I recommend to stay with SeaSonic, Antec, Corsair

    http://www.newegg.com/Product/Product.aspx?Item=N82E16817151096
  3. My new build did not start because the CPU 8 pin extension was bad. Once I took it out and rerouted the Power Cable to feed CPU, it booted up normally.

    Try to double check all of your wiring as a basic approach.

    Then count wattage for everything in your system.

    I use Modular 750 watters from Corsair now and those are protected by sinewave batteries.
  4. Combat Wombat said:
    Depends how much gear you have running of it, and your asking the wrong guys I think, this is more of a hardware related issue.

    I had a 600 running a i5 with all the basics, but when I did a re build and put it into a Antec Gaming case with all the lights, and a SLI running this time it shagged it self.

    Tell us more about your system... do you overclock? How manny fans, cards, and Hdd's do you have running of this Psu, if it is the Psu that you are worried about



    tHANKS FORVYOUR RESPONCE. i SOLVED THE PROBLEM BY CHANGING THE POWER SUPPLY TO A COOLMASTER 650. rUNS ALL THE FANS AND YIDEO CARDS AS WELL. THANK YOU ALL
Ask a new question

Read More

USB3 Power New Build Windows 7 Product