Sign in with
Sign up | Sign in
Your question

Lite-On Drive Problems

Last response: in Storage
Share
November 10, 2009 12:15:34 PM

I have 2 cd/dvd RW drives. 1 is an Ativa DH-3H20A which is suppose to be a Lite-on DH-20A3H clone. The 2nd is a Lite-on LH-18A1P. Both of these worked just fine when installed, but I ended up having to reinstall my copy of XP Pro due to the ICE STORM here in AR which knocked out all power for about a week. After reinstalling Windows, the drives will both read disks or can boot from them just fine, but neither will write a CD or DVD. Have tried updating firmware, and have changed write programs to just about everything I can imagine, but to no avial. Is this a case of bad drives now or is there something else I need to check? NOTE: no ability to change RMA/PIO either. Any assistance/advice with this would be greatly appreciated.

More about : lite drive problems

a b G Storage
November 11, 2009 6:45:11 AM

Did your computer experience any power shocks? You may want to try the drives with other computers.
a c 87 G Storage
November 11, 2009 5:53:06 PM

try your drives one at a time.

If they work it may be a cabling problem. If they are IDE (ribbon cable) you can get a Master/Slave conflict requiring you either set both to CS (Cable Select) or one to Master and one to Slave (rear jumpers on your drives).

SATA drives do not have this conflict.

If you have SATA I'd still try them one at a time though I couldn't guess at the problem.

Solution 1 (for Ribbon Cables)
1) Shut down PC
2) Ensure both are CS or one is MS and one is Slave

If no joy,
Solution 2:

1) Shut down your PC
2) Disconnect all cables from BOTH drives
3) Reboot and Shutdown again
4) Hook up one drive
5) If it works or not, shut down and try the other drive

November 14, 2009 7:09:24 PM

Unfortunately I don't have another computer to try drives in, so don't know if they will work in another computer. Have already tried cables and have done the CS and the Master Slave options but no help there. I tried removing both drives as suggested, rebooted then installed only one of them, but that didn't work either. I'm about to just give up on these drives and say they must be bad. I just can't understand how they can read, boot and do everything else so perfectly and still won't write.
!