Sign in with
Sign up | Sign in
Your question

Putting Fedora on Windows OS choice list

Last response: in Windows XP
Share
November 13, 2010 1:53:11 AM

Hello everyone,

I'm not sure if this is to go in the Fedora category or the windows XP category.
Anyway, here's my problem / question:

I have 2 hard drives running in a Dell Optiplex computer. One hard drive has one partition which is windows xp home edition. The other hard drive has windows xp professional as the primary and Fedora 13 as the secondary. I so far got the xp professional to show up on the os choice list but don't know how to get the Linux to show up as well.

In Fedora i changed the grub to boot xp first.

My question is, how do i get Fedora to show up on the OS Choice List when i start up the computer. This is what the boot.init looks like....


[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect



Would i add anything to this to pull up the Fedora operating system? Maybe other than WINDOWS="" what else would go there? I've searched around and haven't found anything that's related. Most of it is done within Fedora, and dealing with only 1 hard drive.

Thanks in advanced,
Braden
November 27, 2010 4:19:30 PM

Either you can have Grup/Lilo installed on your system or this a secondary option I got this from Fedora Man page,


1-) first boot with install dvd in " rescue mode"

2-) chroot /mnt/sysimage
/* root login */
root
( my password)

3-) mkdir /mnt/windows
4-) mount -t ntfs-3g /dev/sda1 /mnt/windows
5-) dd if=/dev/sd?? of=/fedora.bin bs=512 count=1

6-) /* ?? Where the boot is */
cp /fedora.bin /mnt/windows

7-) /* or run */
dd if=/dev/sd?? of=/mnt/windows/fedora.bin bs=512 count=1

/*Edit boot.ini*/
8-) nano /mnt/windows/boot.ini

/* Add C:\fedora.bin= " My Fedora 13" */

(ctrl+o ) and <enter> to save boot.ini*/

---------------
Boot.ini
edit boot.ini to look like this
-----------------------------
[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\Fedora.bin= " My Fedora 13"
!