Sign in with
Sign up | Sign in
Your question

Motherboard and GPU compatibility

Last response: in Motherboards
Share
September 29, 2008 12:31:45 PM

Will this mother board http://www.newegg.com/Product/Product.aspx?Item=N82E168...
and an Nvidia card (GTX 260) be compatible?

I see that the board has an onboard RADEON and says stuff about crossfire,but does it also do SLI?

Thanks :) 
a b V Motherboard
September 29, 2008 5:38:31 PM

Any motherboard with a PCI-E slot supports any ATI/NVIDIA PCI-E GFX card. The only diffrence is weather or not the board supports multiple cards of the same type (Crossfire for ATI, SLI for NVIDIA).

Nforce motherboards support SLI, most everything else supports crossfire.

(Note, Intel Skulltrail and the upcoming X58 support both).
February 8, 2010 8:14:22 AM

Hi, I'm can't find any info about gpu compatible hardware.

I have these right now

- msi K9N sli platinum motherboard

- amd 64 3500 + chip
_____________


- pny geforce 9600 gt


The GPU isn't working, which of these is it not compatible with ?
Related resources
a b V Motherboard
February 8, 2010 4:31:36 PM

utena678 said:
Hi, I'm can't find any info about gpu compatible hardware.

I have these right now

- msi K9N sli platinum motherboard

- amd 64 3500 + chip
_____________


- pny geforce 9600 gt


The GPU isn't working, which of these is it not compatible with ?



Nothing, that card should work fine with any CPU/motherboard combo as long as it has a PCIe x16 slot, which yours does. It sounds more like you upgraded an old system with a new video card, and the card isn't installed properly. It's probably either that the right drivers aren't installed, the drivers from the old card are still installed, or the system just isn't realizing that there's a new device attached and needs a kick in the pants to go looking for the video card. Try those options first.
March 17, 2010 7:40:42 PM

Hi

Im having a problem with my GPU

as from what I have read above my new GPU should be compatible with my old mobo.

I have just purchased a ATI Radeon HD5670 GPU.

My Pc Spec is as follows:

Mobo: DFI Lanparty UT RDX200
CPU: AMD Athlon 64 X2 Dual Core 4600+ 2.4Ghz
Ram: 2GB (2x 1GB DDR333)
Working GPU: Nvidia GeForce 7600GT
PSU: Antec Neo HE (550W)

Any one got any ideas

Regards
Andy

a b V Motherboard
March 17, 2010 8:06:17 PM

asiddle423 said:
Hi

Im having a problem with my GPU

as from what I have read above my new GPU should be compatible with my old mobo.

I have just purchased a ATI Radeon HD5670 GPU.

My Pc Spec is as follows:

Mobo: DFI Lanparty UT RDX200
CPU: AMD Athlon 64 X2 Dual Core 4600+ 2.4Ghz
Ram: 2GB (2x 1GB DDR333)
Working GPU: Nvidia GeForce 7600GT
PSU: Antec Neo HE (550W)

Any one got any ideas

Regards
Andy


What did you do to install the new card? When you're replacing an existing card, you have to make sure you remove all traces of the previous card first. A lot of problems happen because either the old card's drivers haven't been uninstalled, or the new card's drivers haven't been installed properly. Basically, there's a chance that your system is either looking for the old card, or no card at all.
March 17, 2010 8:15:34 PM

capt_taco said:
What did you do to install the new card? When you're replacing an existing card, you have to make sure you remove all traces of the previous card first. A lot of problems happen because either the old card's drivers haven't been uninstalled, or the new card's drivers haven't been installed properly. Basically, there's a chance that your system is either looking for the old card, or no card at all.


Ah I think you might have just helped me there. I havent uninstalled my NVidia drivers, but I was assuming that I could just insert the card and then boot into windows and then install the ATI drivers, but wont even display anything when I switch pc on
March 17, 2010 8:20:42 PM

Ill give that a go but I didnt think I would have made a difference until it got to Windows, fort drivers would have been operating system level
March 17, 2010 8:54:42 PM

that still didnt work but i have just tried my friends gpu ati radeon 4 series think its the 4670 and that works but my 5670 doesnt
!