Sign in with
Sign up | Sign in
Your question

2nd SATA disk not recognised by Vista on restart

Last response: in Storage
Share
November 13, 2009 10:57:15 AM

A few months ago I bought an Acer Aspire 8920G laptop. It came fitted with a Western Digital WD3200BEVT 320Gb SATA drive. I've since learned the disk specs are 5400rpm, 8Mb cache, 3Gb/s, UDMA/133 (ATA-6). The PC bus is also UDMA/133 (determined when booting an Ubuntu Live CD). The original OS was Vista Home Premium and I updated this the Vista Ultimate.

After a few weeks, I bought a 2nd 320Gb drive, this time a Fujitsu MJA2320BH G2. This is also 5400rpm, 8Mb cache, 3GB/s but (determined from Ubuntu) is UDMA/100 (ATA-5).

The new drive was installed on the 2nd SATA port and initially seemed fine, i.e. was recognised, formatted and seemed OK.

I then started to notice that if I did a restart, i.e. shutdown Vista and reboot without powering off, the 2nd drive was often not present. I checked several times that the drive was seen in the BIOS and it is always present, but, even after checking the BIOS, it would not always be recognised by Vista if the system had not been powered off. It seems that Vista marks it as hidden in Device Manager with the report that the drive had been stopped as it reported an error (Code 43).

After doing the obvious things of checking that the drive was properly connected, I ran the full Fujitsu diagnostics on the drive (over 2 hours) and it passed everything. I then contacted the supplier who, very kindly, supplied a 2nd identical drive. Unfortunately this exhibited the same behaviour. That is, the drive is recognised if I start the system after being powered off for a few minutes, but is usually stopped with code 43 if I do a restart.

Since the Western Digital and Fujitsu drives have exactly the same number of sectors I was able to use an Ubuntu Live CD to do an image copy of the WD drive onto the Fujitsu and swap the positions. The system booted fine, but now, on a restart, the Western Digital drive was often stopped with Code 43.

As mentioned, in either configuration, once the 2nd HDD has been recognised and started by Vista I haven't detected any problem, so the fault seems only to occur on a 'warm' start of Vista.

I tried contacting Acer support, having identified that in the BIOS release notes there were references the 2nd HDD (V1.09 "Fix download to 2nd HDD issue.", V1.11 "Fix download to 2nd HDD issue again.", V1.13 "Delete 2nd HDD solution."). I am currently running BIOS 1.13; there is a V1.14 available. Unfortunately, the attitude of Acer Support was that since the drive was recognised in the BIOS, their responsibility for any warranty support ended as it was a "3rd party device". The fact that the Acer supplied Western Digital drive also failed in the same way was ignored by them.

Anyway, the supplier has, again very kindly, offered to refund the price of the Fujitsu drive so I can buy an alternative, so one possibility is to buy a matching WD3200BEVT drive, but I don't want to go down this route only to find nothing has changed.

Can anyone point me at the likely cause of and ideally a solutuon to this problem?

Obviously, a workaround is to never use 'Restart' but to always shutdown the PC and power off, however, I'd prefer to have the 2nd disk fully working.

As I see it, the only difference in the drives is ATA-6 versus ATA-5 (as detected by Ubuntu, I couldn't find this in the specs); is it possible that the SATA controller (Intel ICH8M-E/M SATA AHCI controller) has some problem when doing a warm restart with different interfaces? This seems unlikely as prior the the restart or after a power off both drives work fine! The one combination I haven't tried is to use the 2 Fujitsu drives together which would then both be ATA-5 (UDMA/100); this might indicate that 'matching disk' solution would work, but it might tell me nothing.

Anyway, I think I've provided all the details I can and look forward to someone coming up with an answer.
a b G Storage
November 16, 2009 6:44:03 AM

Just to be clear: have you tried the drives on other computers? It's good though that the supplier's willing to provide replacements.

In any case, I think the most likely cause is an issue with your mobo's SATA port, or the SATA cable you used to plug in the hard drive.
November 16, 2009 11:46:51 AM

I haven't tried the drives in another machines as I don't currently have one available.

To summarize the combinations I'd tried:

WD3200BEVT on SATA port 1, first Fujitsu MJA2320BH on port 2
WD3200BEVT on SATA port 2, second Fujitsu MJA2320BH on port 2
Second MJA2320BH on port 1, WD3200BEVT on port 2

The results are that both drives are always recognised by the BIOS and that if I power the laptop off, Vista recognises the 2nd drive. Once recognised, I have never encountered any errors and the Fujitsu drives pass all diagnostics. If I do a 'warm' restart in Vista, then the drive on SATA port 2 is often stopped by Vista with a 'Code 43' error ("device reported a problem").

I feel that the problem is either in the connection for the 2nd SATA port or (more likely) the firmware which initialises the drives, but was wondering if the difference in drive technology (ATA5 vs ATA6) might affect things.

Unfortunately, Acer support are refusing to look at the problem as they claim that since the PC recognises the drives in BIOS and it's a 3rd party drive (i.e. not supplied by Acer), then that's where their responsibility ends. I am waiting to see if they would accept the probem was with the laptop if I had identical Western Digital drives. I suspect the answer will still be no.

I have concluded that Acer support is rubbish and wish I'd never bought an Acer laptop.

Derek.
!