Sign in with
Sign up | Sign in
Your question

External USB Harddrive Freezes on Write

Tags:
  • Hard Drives
  • Western Digital
  • External USB
  • Storage
Last response: in Storage
Share
November 17, 2009 11:57:36 AM

I have a 320GB WD Passport Elite external USB drive. Previous to that drive I had a 160GB model which always worked fine. This drive itself initially worked okay. Recently it has been locking up while writing to the drive. I can be using backup software or merely copying things from Windows Explorer. It doesn't matter if it is a large or small file, it just randomly stops copying within a few seconds after the copying starts. I still see the copy dialog open indefintely, but the LED lights on the drive stop flashing and remain solid (it sounds like the drive is spinning continously but the drive head is not moving). Usually at this point, I cannot even cancel the copy command, and if I try going into "My Computer" explorer locks up until I pull the USB cable out.

Reading from the drive is fine, it is only the write commands.

The drive works fine on my laptop and at work, and only doesn't work on my desktop at home. I also tried another 250GB WD drive and it has a similar write failure.

I also tried using a USB Y connector to utilize two USB ports (whether on the front or back ports) and still get failures.

Finally, this was a problem under Vista 32bit. I just formatted this computer (Dell XPS 400) and installed Windows 7 Home Premium and still has the same issue.

Any suggestions?

More about : external usb harddrive freezes write

a b G Storage
November 17, 2009 1:10:49 PM

Reformat the drive using the NTFS file system.
Try a different USB port.
m
0
l
a b G Storage
November 17, 2009 1:12:14 PM

Check the permissions on the drive.
The write failure may be due to lack of permissions.
m
0
l
Related resources
November 17, 2009 1:18:26 PM

Thanks. The drive is formatted in NTFS and the drive permissions are all set to Full Control for all users.
m
0
l
a b G Storage
November 18, 2009 2:11:38 PM

What is the speed of the hard drive in the 320GB WD Passport Elite external USB drive if you can find out?
If it's 4200 RPM, that may be your problem.
m
0
l
November 19, 2009 4:05:08 PM

I don't know about the speed. I could not find it on WD's site.

I can say that I don't think it is my USB controller. I can connect my iPod Touch to the same USB port, and set it to copy gigs of music without problems and the USB Root Hub shows a consistent draw of power (500mA as I recall for the iPod Touch).

Anyone else have any suggestions? WD External Drives work on the native Windows device driver, they do not provide other drivers. Windows 7 in use here.

This drive worked fine when I first got it, but all of a sudden is having these write issues where it freezes during a copy to the drive (doesn't matter the file size - sometimes it freezes after copying a meg or two, and sometimes after half a gig worth of files).

Another Passport Drive I borrowed from work had the same issue, yet both my drive and the one from work, function completely fine on my laptop and my office computer.

I did a scan of the drive and no bad sectors or anything.
m
0
l
January 13, 2012 11:17:58 AM

I have the same problem with the 1TB My Passport essential. I updated firmware, changed USB ports, completely reformated. No luck. I managed to get quite a few files on there, but past a certain point ( ~ 90% full), it hangs. I presume it is actually full, but is not calculating or recognizing unavailable bad sectors.
m
0
l
March 17, 2013 3:05:36 AM

Hi, livngstn

Did you ever find a solution to this problem? I've been having the same issues for a month or so and your posts are really the only ones I can find that describe the confounding issues I've been having with writing to USB externals.

Any help/advice would be greatly appreciated.
m
0
l
!