Sign in with
Sign up | Sign in
Your question

Degraded Raid 5, help?

Last response: in Storage
Share
November 22, 2009 10:07:30 AM

So i turned my comp on today and its thrown a mutiny. Wouldn't be the first time. I'm running three 500GB (ST3500320AS) hdd in RAID 5 but the 2nd disk is now not being detected and the array degraded but bootable. I'm using it now to type this. I've tried a different port and cable, but doesnt pick it up. I don't feel there is anything wrong with the drive, but im unsure how to test it, where to go from here without risk of messing up the rest of the array. If its not a hardware failure, what is at fault here?
Mainboards a Gigabyte GA-X48-DS5 with Intel ICH9R

More about : degraded raid

November 23, 2009 2:03:21 PM

hi,

safe to say - get a new hard disk and make sure your Raid-5 is no longer compromised b4 trying to figure out what is wrong.

plug that bad drive into the motherboard directly as an individual sata hdd.

1. see if the bios can detect it.

2. disconnect the dvd-rom power from the power supply, and see if the bad hdd can be detected. YES - your power supply is in a weaken state.

my gut tells me your hdd has most likely gone bad.

a weaken power supply may also be a reason. let us know your system setup & spec.
m
0
l
November 24, 2009 4:50:22 PM

Yea just been looking at them online, definately not happy running on just the two remaining drives.

I have already disconnected the good drives and tried loading it on its own, but without changing any raid settings in bios. It didnt pick it up - do I need to turn raid off in the bios? Had a feeling i do, but wasnt sure what impact that has on the array. Just trying to prevent further headaches thru my ignorance..

Will try the dvd-rom. My gut tells me its a software thing, but maybe im in denial :) 

Ah setup + spec. Wasnt sure how much details you guys needed.

3x Seagate Barracuda 7200.11 32mb 500gb

GA-X48-DS5 ICH9R bios F8A
Q9550
Vista x64 HP
Corsair TX750w
HD4870 + 4GB ram

If i've missed something obvious let me know.

Would turning bios raid off then booting hiren or minipe with the single drive connected be a option? Assuming bios detects it that is. All id need to do is format it then and it should pick up ok with the array connected? I really am out of my depth with RAID guh..
m
0
l
Related resources
November 25, 2009 9:42:52 AM

u got a good psu. so that rules it out.

turning off raid now is a very risky thing to do. if you do that backup all your raid-5 data into another hard disk by making an exact duplicate.

if your data worth more than a new hdd, get a new drive. backup before fiddling and trying to repair the bad hdd.

most likely u got a dead hard disk. i can't think of a software issue.... in the raid controller or driver.

science and learning thrives in sea of ignorance :) 
m
0
l
November 25, 2009 12:07:35 PM

Yea its definately worth more. Havnt got a big enough spare disk to back up on, only a 250. Will take a while to get a replacement drive.
Hmm ok so testing it on my own system is too risky then. If i was to commandeer my folks non-raid system for a bit and connect this drive, that should simplify things somewhat shouldnt it? It wont be looking for raid and will just ignore whatevers on the drive?
m
0
l
November 25, 2009 2:27:37 PM

Update the BIOS to F8C, it is a beta BIOS but I am using it for over half a year and am not having any problems with it. This BIOS solves some problems with the Intel ICH9R controller.

Can you post which firmware the drives have? Although maybe you bought all the drives at the same time it may be not all drives have the same firmware. It could be the firmware of the failing drive isn't fully compatible with the other drives firmware.

When you turn the machine on is the drive spinning up? Have you tried to connect the failing drive on another system or controller for only checking the SMART data? Your motherboard has a second controller which you can use to read SMART data. Have you installed the Intel Matrix Storage Manager Software? Maybe this software can tell why there is a problem.
m
0
l
November 25, 2009 3:54:35 PM

Just downloaded the new bios. Have the new firmware sitting on my desktop but wanted to get the array up n running before updating. I cant access the failed one to update it / check the version. The other two are SD15 and SD1A.

Yes, the drive is spinning up. I havent got another sata system here, no. Damn you mean the sata2 chip. Here i was thinking that was just there for decoration. Well thats interesting.

Yea i have matrix storage console. All i can get from it is that the status is degraded and hard drive member 3 is missing on port 1. Port 1 is coming up as unused. Pretty much exactly what the bios tells me on boot up.

It got built round xmas so not quite a year old yet.
m
0
l
November 25, 2009 4:29:06 PM

The X48-DS5 has 6 SATA-ports. Have you tried a port other than SATA-1? Why do you want the array up and running before updating? You are having problems and this could be the solution. F3C has been released to solve problems with the Intel ICH9R, and it seems you are having those problems.

Last but not least: have you tried a different SATA cable?
m
0
l
November 25, 2009 5:34:23 PM

Yes. Tried other ports and other cables. Not the Gsata2 ports yet tho.

Before updating the firmware, not the bios. Seagate reccomends a backup, i don't have one. Havent done a hdd firmware update before so was just being on safe side, wait til mirroring back working.
m
0
l
!