Sign in with
Sign up | Sign in
Your question

Power color 4850 cannot overclock?

Last response: in Overclocking
Share
August 1, 2009 3:10:26 PM

Hi everyone;

I just bought a Power Color 4850 512MB DDR3, and nothing I try seems to allow it to overclock.

I've tried BIOS (no option),
Rivatuner (blue screen and then crash),
ATI Tool (cannot detect the card at all)
ATI Tray tools (when i move the slider to overclock, it automatically jumps back and nothing happens)

I'm using Vista Home premium 32 bit SP1, ASUS P5kvm 1600, 4g DDR2 KVR, Intel Q8200...

Any ideas please? Much appreciated.
a b U Graphics card
a b K Overclocking
August 1, 2009 3:52:59 PM

^ have you tried updating the drivers?
m
0
l
August 2, 2009 3:32:32 AM

Yes everything is fully updated...
m
0
l
Related resources
August 3, 2009 8:38:28 AM

overshocked said:
^ have you tried updating the drivers?


Yes my monitor and graphics card drivers are updated already.
Any idea please anyone?
m
0
l
a c 106 U Graphics card
a b K Overclocking
August 3, 2009 4:10:17 PM

Use the Catalyst Control Center. Just enable overdrive, move the slider, and test your settings. Google it if you really need some step by step. If you're gonna use ATI tools or Riva Tuner then make sure you look at the realease notes to understand which driver versions they work with and which they have problems with. If you had paid attention to the Riva Tuner home page on Guru3d then you would know that they only recently added support for Catalyst 9.2
m
0
l
August 4, 2009 6:20:40 PM

like megaman said CCC overdrive is the best.
m
0
l
August 15, 2009 4:08:42 AM

I tried CCC. The latest version 9.6, with the latest version of 4850 drivers.

Overdrive is enabled by default.
However, it doesn't allow me to disable Overdrive, and it is always running at 625 Mhz GPU and 993 Mhz memory.

I can't change anything! Help anyone please?
m
0
l
August 17, 2009 9:37:07 PM

under the overdrive tab there is a lock icon click it then change the setting you want to change
m
0
l
August 19, 2009 4:29:03 AM

Thx, I changed the sliders up a bit so its running at Core 650; Memory 1058.

But the thing says under "Current Values" : 'Core 500 Memory 993"

I've tried restarting, and I didnt touch any voltages, but it still says "Current Values" : 'Core 500 Memory 993"

Does it mean the overdrive is not working properly?
m
0
l
August 19, 2009 4:33:58 AM

no it means its working correctly.... When under load the clocks will increase!
m
0
l
!