Sign in with
Sign up | Sign in
Your question

ATI hd 4850 too fast gameplay, please help! :(

Last response: in Graphics & Displays
Share
August 4, 2008 8:54:32 AM

I have just bought a gecube ATI hd 4850 512 mb graphic card. It is quite good at crysis, all of duty 4 and the other games. Bu I cannot play pro evolution soccer 2008 and pro evolution soccer 6 well. The gameplay is god damn fast in this games. I checked ati catalays control center out and changed the settings to optimal quality from performance , but nothing changed.
I downloaded the latest direct x (end user run time) I tried the lates catalayst (8.7) still no good.
What is the problem do you think? Please help!!!

More about : ati 4850 fast gameplay

a b U Graphics card
August 4, 2008 8:58:53 AM

Interesting. That would be a driver problem for sure. Clearly a bug. Check the game support forums?
August 4, 2008 10:59:39 AM

or turn down the speed on the games... but i would think you know to do this.
Related resources
August 4, 2008 11:04:03 AM

It is impossible to change speed in pes 2008 menu or settings. how can I turn down speed???
August 4, 2008 11:21:04 AM

Disable the CPU's internal L1 Cache. That'll slow everything down.
It might take windows twice as long to boot up but at least it will slow your system down to where the game will play.
How you disable L1 Cache is through the BIOS Chipset setup.
You can also try disabling a core through the BIOS.
There is a way to disable a core inside of Windows Vista for a certain applications but I don't know how to do it.
I can't stand VISTA.
August 4, 2008 11:22:15 AM

how can I do that harrycat88? my cpu is intel core 2 duo E6550.
a b U Graphics card
August 4, 2008 11:22:22 AM

You could make a profile for the games and enable vsync, that would cap the framerate at your monitor's refresh rate. I assume the game time is based on framerate like C&C but for some reason there isn't a proper cap in place to keep things from going too fast.
a b U Graphics card
August 4, 2008 11:23:49 AM

harrycat88 said:
Disable the CPU's internal L1 Cache. That'll slow everything down.

You're a tool :kaola: 

abondanzieri said:
how can I do that harrycat88? my cpu is intel core 2 duo E6550.

If you want windows to load within 20 mins, don't do it. Just don't :lol: 
August 4, 2008 11:24:04 AM

randomizer said:
You could make a profile for the games and enable vsync, that would cap the framerate at your monitor's refresh rate. I assume the game time is based on framerate like C&C but for some reason there isn't a proper cap in place to keep things from going too fast.


In PES Series always activate V-Sync !!! 08,06, basically since i can remember !!! Really !!
August 4, 2008 11:25:03 AM

how can I do that randomizer? could you possibly help?
August 4, 2008 11:27:16 AM

V-synch is on both in game and ati catalyst settings. always on!
a b U Graphics card
August 4, 2008 11:29:03 AM

I can't remember catalyst control centre well enough to know if/how you make profiles for individual games, but if you find out how, force on 8xAA and 16xAF (or higher). That ought to slow it down some ;) 
August 4, 2008 11:32:40 AM

I think 4850 is too fast for pes 2008 :) 
I did not have such a problem when I had my nvidia 8500 gt. I only had to play in medium detail and face with slow down problems in replays.
Now I have graphic monster and I cannot keep it slow :) ))
a b U Graphics card
August 4, 2008 11:33:23 AM

If only Crysis was hard to tame in that way.
August 4, 2008 11:48:47 AM

u could try running disk scan and the game as the same time......might help.....;(
August 4, 2008 11:55:11 AM

there used to be a program named 'mo-slo' for the older dos style games
when run on the faster comps of today...hmmm. Not sure if there is an
equivalent for todays systems or not....might do a google and see...?
August 4, 2008 12:11:15 PM

you could download rivatuner or atitool and downclock it till its not too fast....
a b U Graphics card
August 4, 2008 12:25:47 PM

Try forcing V-Sync; there should be an option somewhere in game. If not, do it from the Catalyst Control Panel.

Whats happening, is the game is drawing frames and progressing as fast as those frames can be drawn (as opposed to having a set speed, and drawing as many frames as possible without speeding up the game itself). Funny thing is, my 9800GX2 runs the game well above 60FPS without any increase in speed. I'm guessing ATI hasn't profiled the game yet. Guess that ATI's legndary driver support for you!
August 4, 2008 3:04:06 PM

abondanzieri said:
how can I do that randomizer? could you possibly help?


Lol

Start -> My programs -> Konami -> Pes2008 -> Click on Settings.

Check on the check box of Vertical Sync.

August 5, 2008 7:35:43 AM

radnor you must be kidding :) 
V-synch is on all the time..
August 5, 2008 2:30:08 PM

If v-sync is enabled try lowering your monitors refresh rate.

If that doesnt work, try switching the vsync so it forced in Catalyst, instead of using it from the game's settings.
Also be sure to disable frame skipping in the game options.
August 5, 2008 2:34:16 PM

abondanzieri said:
radnor you must be kidding :) 
V-synch is on all the time..


If you choose to do so in the CCC. I usually don't. Still prefer (most times) application controlled. In PES 2008 for example, activating Vsync on CCC just crashes PES.

Many games ( like PES ) are ported from consoles. Ive seen bigger bugs in other versions.
February 23, 2009 11:28:35 AM

NONO here is the thing if u have a dual or quad core processor it must be it 4 cores are too fast for some games try setting affinity for them through task manager.
October 17, 2009 10:31:25 PM

I had the same problem in Windows 7. I installed my LCD original samsung driver and used an app called D3DOverrider (comes with rivatuner) to force v-sync for pes6.exe

Now its working great!
!