Sign in with
Sign up | Sign in
Your question

BIOS update------> problems

Last response: in Motherboards
Share
October 11, 2008 11:50:42 PM

hello,

I recently updated the BIOS on my Abit IP-35 pro to the latest version. I did it using the Abit Flashmenu program, from windows. However, after restarting the PC, I get a message saying:

"CMOS checksum error".

It then says that defaults have been restored and asks me if I want to continue, or go into the setup. If I continue, it boots OK. If I try to load up my original profile again, I get the following message during the boot up:

"DISK BOOT FAILURE. INSERT SYSTEM DISK AND PRESS ENTER."

Have I damaged the BIOS on my system?

More about : bios update problems

October 12, 2008 2:11:13 AM

You'll need to clear the CMOS, then manually re-enter all your BIOS settings (you can't use any saved BIOS profiles, as they will only work with the previous version of the BIOS).
October 12, 2008 1:09:28 PM

hello,

Thanks.

I've tried clearing the CMOS many times, both using the external switch and the jumper, but this has no effect. I've also tried manually inputting the values again and saving over the original profiles, but this does nothing.

I've also found that my CPU temperature is a lot higher than usual. Despite the fan spinning at the max RPM, I still get bizarre temperature jumps.
Related resources
a c 435 V Motherboard
October 12, 2008 2:23:44 PM

Your boot order may have changed with the bios update. Go into the bios and change it to cd>floppy>hardrive. If you still get the message, check for a loose cable connection inside. Also be sure your hardrive setting in the bios is "ide".
a b V Motherboard
October 12, 2008 2:40:47 PM

m8, that's why you don't flash from Windowz. Looks to me like a bad flash.
October 12, 2008 4:33:15 PM

hello,

I'll try those suggestions ASAP. What do I do if it is a bad flash though?
October 12, 2008 5:07:53 PM

Flash it again, preferably with a floppy instead of Windows flash.
October 12, 2008 7:13:13 PM

I've tried looking at how to do that, but unfortunately I can't get my head around how to do that. I have the BIN bios file, what do I do with that?
October 12, 2008 9:28:45 PM

If you have a floppy drive, then follow these instructions.
Quote:
BIOS Upgrade Guide

1. Identify your motherboard's model and version by examining the label on the last slot.
2. Check the current BIOS ID.
3. Download the appropriate BIOS file.
4. Self-extract the BIOS file by double clicking the downloaded file.
5. Make a bootable floppy disk and copy the necessary files onto it.
6. Boot from the floppy disk.
7. FLASH BIOS
8. CLEAR CMOS DATA
To make a bootable floppy double click on My Computer and right click on the floppy drive, usually a:, and click format. In the window click on "Create an MS-DOS startup disk" and click start.

Do you understand the process?

October 12, 2008 11:03:19 PM

hello,

I've made the start up disk.

Do I copy all of the files downloaded from the abit site onto the floppy disk? If so, then the 1.44MB floppy I'm using is too small for the job. Is there any other way?
October 13, 2008 12:04:51 AM

Yes

After you unpack the zip file, and the answer is, drum roll please... use a second disk.

Kind of anticlimactic, aye? ;) 
October 13, 2008 12:32:27 AM

It just dawned on me that you can boot to a USB flash drive with that mobo. So you can put everything on a flash drive and set the USB to boot in BIOS, assuming your BIOS is functional to that point.

To be sure we are on the same page, your display works, right?
October 13, 2008 9:02:02 AM

Thanks Zorg, both of those suggestions look ok, I'll try out the USB thing first. :) 

Yes, my display works. Everything is fine when I use the default values for the BIOS.
October 13, 2008 10:18:50 AM

hello,

I've just tried re-flashing it (using the 2 floppies), and now it seems to have finished. The problem is however, the system seems to have reset itself, but has frozen in the process. I get no display. This happened from time to time after the bad flash. I get code C1 on the MB led display. Is it safe to switch the system off, or should I wait?
October 13, 2008 12:21:53 PM

OK, I did reset it, and everything booted fine. Thanks a ton!
October 13, 2008 5:17:02 PM

hello,

I've found that the temperature problems continue.

The temperature reading can be anything from 30-50C on the Abit Uguru program, and can change across the whole range in a matter of seconds. It seems to be a random number generator to me. Coretemp however reports much lower temperatures, in the twenties (which is more like what I used to get, especially considering it was quite warm here today). I would normally just ignore it, but Uguru is what controls the speed of the fans. And as the RPM depends on the (silly) temperature readings, the noise is driving me NUTS.

It's been recommended to me to try an earlier BIOS version, because the one I'm now using (v17) is designed for 45nm CPUs, rather than 60nm. Which BIOS revision should I go for?

October 13, 2008 6:45:24 PM

I don't know which BIOS to use. Do you know what you had in there before? I only have my CPU fan on the mobo and I disabled the fan controller so it runs at 100% all the time. I'm less bothered by the noise than most. It's like living near a train track, after a while you don't even hear it. I have Antec TriCool fans for the case, set on medium. I also have my X1950 Pro fan regulated by ATITool with a minimum speed of 50%. I can definitely hear the machine though. You might want to consider the TriCools for the case and lower them manually. Also there are aftermarket heatsinks that are more quiet. As you have found out, flashing the BIOS can be a little dicey.
October 13, 2008 7:00:08 PM

hello,

I tried reverting to the v16 BIOS. This solved nothing, and brought back old problems.

I then tried flashing to the v10 I think, which is my old BIOS. At first, it looked like it worked, as the fan wasn't spinning at max RPM anymore. However, when I booted into windows, I opened abit uguru. The temp reading was now on 0. The RPM was therefore stuck at dangerous low. Any ideas on why this keeps happening?
October 13, 2008 8:06:06 PM

Nope, I would put the BIOS back to the latest revision and follow my previous advice about the fans. Keep messing with the BIOS and sooner or later you will have a brick for a mobo.
!