Sign in with
Sign up | Sign in
Your question

ECS x48-A and Patriot Viper 1333MHz DDR3 Ram... PLEASE HELP!

Tags:
  • Motherboards
  • RAM
Last response: in Motherboards
Share
October 14, 2008 1:19:02 AM

I'll get straight to the problem, ram wont run at 1333MHz no matter what I attempt. :fou: 

The modules are getting 1.5 VOLTS when the sticker recommends 1.7, every time I try and touch the voltage I end up having to do a CMOS_RESET.
Every time I try to touch the DRAM Frequency, I have to do a CMOS_RESET. Trying both at the same time did nothing. When I boot up it shows the ram at 1066MHz instead of the 1333MHz speed I bought it for. My E8600 is 1333FSB so that isn't the problem and neither is the MB last I checked. Several attempts such as minor adjustments to complete BIOS flashing did nothing to help the solution. Power is 850 WATTS so that to is not the problem. The BIOS is an AWARD one so Advanced Chipset features is pretty much empty, it's all done in MIB which seems to be an utter failure at this point.
The ram is Patriot Viper 1333MHz DDR3 PC3-10666

A real helpfull solution is either a third party RAM overclocking utility or some settings through BIOS M.I.B that work. Any one have any useful suggestions?

More about : ecs x48 patriot viper 1333mhz ddr3 ram

October 14, 2008 6:54:37 PM

C'mon, help a fellow gamer out. Has anyone ever encountered something similar?
October 17, 2008 3:45:27 AM

*bump*
January 10, 2009 8:44:42 PM

I have the exact same problem. I'm wondering if you've come up with a solution?
!