Sign in with
Sign up | Sign in
Your question

Windows only recognizes 3.5GB of RAM, but BIOS sees all 4GB (XP 64)

Last response: in Memory
Share
October 14, 2008 7:29:26 PM

I have a home-built system:

Asus M3A78-T 790GX
ATI RADEON VGA SAPPHIRE HD3450 512M
AMD Phenom X4 9950
G.SKILL 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1000 (PC2 8000)
Corsair 750W PSU

All of this is running on Windows XP Pro 64-Bit with Hybrid Crossfire enabled.

The Problem:

For some reason, BIOS sees 4GBs of memory, but when I go to system information, it only sees 3.5GB.... Why is that?

I've gone into the BIOS changed the voltage to 2.1 which is what the memory packaging says... and that didn't do anything... (although, even though the memory voltage says 2.1V when I change the voltage settings, the color goes from white *1.9 and under* and then yellow *2.01 - 2.1* and then red *2.1 - above* does this mean anything??)

So anyways, I tried someone's suggestion in a previous thread about disabling memory mapping, in BIOS, and after an intense search (I'm a noob) I found that function, it was enabled, so I disabled it... When I started up Windows, System information said only showed 1.75 GB of RAM... I'm so confused... so I re-enabled memory mapping, and it went back to 3.5 GB...

Something I've considered, the Mobo has an onboard GPU installed and I've got an ATI Radeon HD 3450 and someone in another thread suggested that the onboard GPU will take up .5 GB of RAM to run... is that the case?

Also, I can't seem to get my Memory to run at the advertised speed... it's DDR2 1000, and I don't know how to set it as such... it's currently set at 800 settings, but I don't know where to change it to make it run at 1000.

Sorry for the wordiness, but I'm out of my element, lol, and I'm trying to learn...

Please help??
October 14, 2008 7:40:59 PM

Did you disable the onboard GPU in the BIOS???
October 14, 2008 7:46:48 PM

Are you saying I SHOULD disable the onboard GPU? If I disabled the onboard GPU, wouldn't that effectively disable Hybrid Crossfire?
Related resources
October 14, 2008 7:54:09 PM

Well, the On-Board GPU uses Physical Ram.................
a b } Memory
October 14, 2008 8:12:28 PM

enable memory hole.
October 14, 2008 8:18:50 PM

Okay, so that's what I'm asking... is the onboard GPU the reason why windows only see 3.5 GB? Yes? No? Please spell it out for me, because like I said, I'm new.... :(  sorry if I seem difficult, but I'm just trying to make sense of stuff
October 14, 2008 8:27:37 PM

swifty_morgan said:
enable memory hole.


Okay I'm sorry, but that just made me LOL for real.

To the OP: If your onboard GPU is active, it will automatically use up a portion of your physical memory. It seems quite logical that it would use up 512MB (or 0.5GB), so that would take your 4GB to 3.5GB. So that could possibly be what is going on.

Therefore, although you have 4GB of RAM, Windows is only allowed to see/use 3.5GB of it, as .5GB of it has been allocated specifically to the onboard GPU to use for its own purposes.
October 14, 2008 8:32:32 PM

Okay, thanks, that's all I was asking... I've been split between feeling really stupid for not knowing, but I read the manual, and I've been reading around, and nothing said anywhere that the onboard GPU would be automatically alotting itself .5GB of my 4GB that I had installed... I was afraid that I had faulty memory or something...

now... does anyone know how to set the RAM to 1000 settings instead of 800?

Now, on to the
!