Sign in with
Sign up | Sign in
Your question
Closed

Problems with games- Black Screen

Last response: in Graphics & Displays
Share
August 10, 2008 7:52:26 AM

Hello!
I have a problem running games on my PC. The problem started just recently and happens with games I never had problems with before.

It started as "Scarface" was running slow on my PC. I updated my graphic card and DirectX. After that I can play anything between 1-20 min and my monitor goes black and says "No signal, going to sleep". Sometimes the game runs with the black screen and sometimes it crashes. And it happes with all games (tried 3).

I tried updating my graphic driver 3 times...no luck.

I have a Radeon X600 Pro-4 256mb and I installed newest driver:


Can someone please help, this is very frustrating!

------------------
System Information
------------------
Time of this report: 8/10/2008, 09:46:52
Machine name: PC1
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.070227-2254)
Language: Danish (Regional Setting: Danish)
System Manufacturer: FUJITSU SIEMENS
System Model: D1826-G
BIOS: Version 5.00 R1.10.1826
Processor: Intel(R) Pentium(R) 4 CPU 3.40GHz (2 CPUs)
Memory: 1022MB RAM
Page File: 449MB used, 2011MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: RADEON X600/X550 Series Secondary
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x3E70)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_3E70&SUBSYS_0451174B&REV_00
Display Memory: 256.0 MB
Current Mode: 1024 x 768 (32 bit) (60Hz)
Monitor: Plug and Play-skærm
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6833 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 7/4/2008 05:23:45, 309248 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: I/T
Mini VDD: ati2mtag.sys
Mini VDD Date: 7/4/2008 08:33:33, 3230720 bytes
Device Identifier: {D7B71EE2-7D30-11CF-4A6E-5B24A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x3E70
SubSys ID: 0x0451174B
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_B ModeWMV8_A ModeWMV9_B ModeWMV9_A
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run
August 10, 2008 10:55:43 AM

Sounds like either a heat or power issue. What powersupply do you have? How about case? Is it well ventilated and do you have at least a couple fans moving air through it?
September 22, 2010 7:37:22 AM

I think i have the same problem and i have narrowed it down to the DirectX update. I had this issue with the screen randomly going black during games a few weeks ago and a Windows reinstall fixed it. At that moment, i actually tought it was caused by CPU overheating because i did a through clean of the computer ( a laptop) around the same time the problem stopped.

This morning, i installed the Civ5 demo. I ran it at first but it was crashing so i decided to try and update some drivers including Robson, Chipset and even the Card Reader. After trying to run the demo again, steam installed a directx update and a vc 2008 redistributable. When i ran the game, i started having the same problem again. First i tought i need to clean my laptop again, so i did, but it didnt help. Then i thought it might be a driver issue so i restored my system to before installing each driver but none of it worked. In the end, i tried to rollback before the DirectX update and the problem seems to be gone again, even after i installed all the drivers again.

For some reason, it seems that the DirectX update in question is causing this issue for me. How and why, i have no idea.
September 22, 2010 3:34:07 PM

This topic has been closed by Mousemonkey
!