Sign in with
Sign up | Sign in
Your question
Solved

SATA troubles

Last response: in Storage
Share
December 1, 2009 2:06:21 AM

Hello, I have a problem with my SATA WD1TB HD. The drive isn't showing up in the bios and I've seen it pop up once or twice but then disappears. It's like a ghost. It's a new drive that I will be using for storage only while my other drive will be my primary. I just want it to stay there long enough so I can format it. Specs of my comp:

ABIT IC7-G
P4 3.0GHz
2 gigs of Patriot RAM
Seagate Barracuda HD IDE
Western Digital 1TB SATA

Ok, here's the twist. The SATA on my mobo doesn't work at all, drivers have been installed but still nothing and decided to give up the SATA on this mobo. She's old and at the point where if I mess with her, she might just shut down one day. Yes, I am also in the process of backing everything up as well. :na:  So I bought a SATA to IDE converter and connected that into the ribbon that has the IDE. Now both the Seagate and WD are on the same ribbon and connected into the computer. I've fiddled around, but it's always one drive or the other or none. Now I know that SATA has no jumper settings and I did put the correct jumper settings for the Seagate, so what else can I do to make it show up? Thanks in advance

More about : sata troubles

Best solution

a c 342 G Storage
December 1, 2009 2:05:55 PM

Look closely at the instructions for the converter - how is it set to be Master, Slave or CS? Obviously you already know how to set the Seagate IDE unit. If the adapter only has one way it can work, you might have to change the way the Seagate is set.

For two drive devices sharing one port and ribbon cable, ONE must be Master, and the other MUST be Slave. OR alternatively, BOTH can be set to "CS" for Cable Select. In either case, plug the Master unit into the END connector - in the case of CS, the end device WILL be the Master because that's how Cable Select does its job.

If you get that all set and the result is that your Seagate is no longer the Master on the first IDE port, you MAY have to go into the BIOS Setup screen for specifying the Boot Priority Sequence to be sure it boots from the older Seagate that already has your OS, and does not try using the new drive.

There could be another issue. Your board has original (150 MB/s) SATA controllers, so you may not be able to use a newer SATA II drive without an interface speed adjustment. SATA II drives are supposed to be able to figure this out and make their own adjustment, but sometimes they don't. So disk makers have provided a way to manually force a SATA HDD to use the 150 MB/s speed, often by setting a jumper on a pin pair. This usually allows the HDD to work well with the original SATA controllers. So, did you do that when trying to use it on your SATA ports? And, for your current situation, do you have to do that when using it through the adapter? In fact, it might be a good idea anyway. In the SATA world, a 150 MB/s drive ALWAYS can work with any SATA controller. So maybe it works that way, too, when you're using that adapter.
Share
December 1, 2009 2:22:01 PM

There were no instructions for the converter, it was just basically plug and play.
The converter: http://www.newegg.com/Product/Product.aspx?Item=N82E168... Then I just plugged a male to male adapter on to that and then onto the ribbon.
The HD is a WD Caviar Green 1TB, so not SATA II. I'll definitely try out the cable select next then plug it into the end and see if that'll work. I haven't tried to put the pins on the SATA yet, but would that affect the bios trying to recognize it? Either way, I'll go and buy some pins for the SATA today. I've been reading around here also, but it seems that almost everyone has their's in the normal configuration where they plugged their's into the SATA port. Like you said, I'll probably have to use the bios config and manually make the seagate the primary boot, but that's a small matter to me. Thanks for your help. I'll update later today after I get the pins.
m
0
l
Related resources
a b G Storage
December 1, 2009 2:30:10 PM

I had the ABIT IC7-G and was able to use SATA. You have to set the IDE drive to slave when using SATA if I recall correctly. SATA must show as first device in the bios.
1 TB is too big for that motherboard. Hopefully there is a bios update somewhere for the board to see 1 TB.


m
0
l
a c 342 G Storage
December 1, 2009 2:48:28 PM

The Vantec website shows this adapter really plugs into one of the mobo IDE ports and converts it to ONE SATA port (there is a similar device to make 2 SATA ports). Presumably it establishes itself as the Master on that port and there is no possibility of a Slave there. There is no mention of the SATA speed - 150 or 300 MB/s - it uses, so you MIGHT have to force your drive to the 150 speed.

A WD Caviar Green 1TB surely IS a SATA II drive! So look up on the WD website the procedure for manually forcing it to the slower speed. It may be by setting a jumper on pins. On SATA drives those jumpers are NOT used for the old Master / Slave stuff, they are used for other things. And aside from the slow-speed-force item, you generally should not change any of them unless you know what you are doing. So read the instructions. By the way, the jumpers and pin spacing for this on a SATA drive are DIFFERENT from those on IDE drives. So if you have to go looking for a jumper, make sure you get the right size.

Given that the adapter means you are connecting the new drive to a different IDE port - not the one that already has your C: drive on it - you do NOT need to change any jumpers on the existing HDD. You might want to check in the BIOS Setup that the second IDE port actually is Enabled.
m
0
l
December 1, 2009 8:57:50 PM

@evongugg
The mobo was able to see it and I saw it on the bios, but did not see the seagate one. Unfortunately, I did everything to try and make SATA work, but was unable to.

@Paperdoc
Ah ok, didn't realize that it was actually SATA II, thanks for bringing that to my attention. I realize the adapter is for SATA to IDE, but I flipped it around and made it IDE to SATA. Then I used a male to male ide connector and connected it to the ribbon. I know that the SATA pins are different from the IDE ones, been reading up on it on the forums :D  so now it's just a matter of putting the pins on the SATA and forcing it to be 150. Second IDE port is enabled also. There was no manual that came with the adapter, should've looked on Vantec's site, thanks again for your help. Gonna try out your advice now.

EDIT: It works! I forced it to 150 as suggested. I kept the jumper on IDE as cable selected as you said and just plugged the SATA into the master slot and it read. Thanks again!
m
0
l
!