Sign in with
Sign up | Sign in
Your question

Hitachi 320gb not showing up anymore

Last response: in Storage
Share
December 1, 2009 11:27:00 PM

I have a hitachi 320GB USB external disk. The disk has worked just perfectly for me. Suddenly I connected the disk and vista doesn't do anything. No connection sound, and nothing in my computer. It's like it's not there. The drive light is on and it feels as though it's running properly but I can't access it. I'm not sure what to do, I have A TON of music saved on there and don't want to loose. Can anyone recommend anything for me?
Thanks in advance.
a b G Storage
December 2, 2009 5:46:30 AM

Try it again after rebooting the computer, if it still fails to show try a different usb port, preferably one of the rear ones, no usb hubs. If it still fails see try another usb cable, if that doesn't work, it could be a faulty hdd box.
If it can be opened without wrecking it, try connecting the drive directly to the motherboard connector, if you have a matching one for your drive.
It depends if the drive is sata or pata connection. Some newer boards don't have any pata connectors.
m
0
l
December 2, 2009 6:12:51 AM

I had similar problem when the PC suddenly stopped recognizing some external USB devices.
This solution worked for me:
Remove the problematic external USB devices.
Turn off the PC.
Disconnect the power cable from the wall outlet for 5 minutes.
While the PC have on power, press a few times on the power switch of the PC to discharge capacitors.
Reconnect the power cable to the wall outlet.
Turn on the PC.
Connect the problematic external USB devices.
m
0
l
!