Sign in with
Sign up | Sign in
Your question
Closed

Supreme FX X-Fi software won't allow me to change speaker settings

Last response: in Components
Share
September 18, 2008 2:57:16 PM

I recently purchased an Asus Maximus II Formula motherboard that comes with a Supreme FX X-Fi sound card. Installed sound card with no problems using a 5.1 logitech speaker system and there is sound coming out of my front left and front right speakers. However, when I launch the creative console that allows you to change speaker settings from headphones, to 2/2.1 to 5.1 or 7.1, the arrow that normally appears to the right of the setting that allows you to change the speaker settings is absent and I can not change the setting from 2/2.1 (i.e., my other 3 speakers aren't getting any sound because I can't change the setting). Any ideas how I can resolve this? I already tried reinstalling the software and drivers several times to no end. Seems like a strange problem that the software wont let me choose when it clearly should regardless of what speakers are or aren't plugged into it, no? Thanks for any help you can offer.
September 18, 2008 3:27:41 PM

That's a odd one. of course try updating your drivers from the web. make sure you flip the switch on the back of the speakers to 5.1. mine came set at 2.1 and it drove me crazy. check the bios for any options concerning the onboard sound. If your using vista you can open the sound manager. and make sure the speakers there are set to 5.1, reset then try the creative sound manager again.
September 19, 2008 2:59:09 AM

Tried what you said and there is still no arrow to select:-/
Related resources
January 6, 2009 7:58:33 PM

easy, the sound card must be plugged into the brow slot of your motherboard, not white slot.

Change position, then you can change speaker settings, or the sound card can't detect anything, only headphone.
March 29, 2010 7:42:52 PM

I know this is a very old thread but I had this problem and this thread keeps coming up as the first answer in google. And thought maybe some other people might need some help. To fix this (I'm using windows 7), go into your Control panel>Hardware and sound>Sound. Now click your speakers and then go to configure down in the bottom left. Then just configure your speakers for 5.1 surround sound.
March 11, 2011 2:17:15 AM

Thank you. This is still very relevant. I had the exact same issue and this last post did it . Right on ! And thank you.
May 3, 2011 3:58:13 AM

Nope. When I try this solution I only see one choice: "Stereo" ... no option for 5.1 speakers, which are what I have.
May 24, 2011 9:27:37 PM

i just had the same problem and found out how to fix it. go to Control panel. then Sound. click on speakers. then properties then click the advanced tab. change the sample rate to something a little lower. that helped me change from 2.1 to 5.1 :)  hope that helps!
May 24, 2011 9:47:14 PM

This topic has been closed by Mousemonkey
!