Sign in with
Sign up | Sign in
Your question

Need USB Drivers for Asus P5N-D Using NVIDIA 750iSLI Chipset

Last response: in Motherboards
Share
October 19, 2008 4:18:23 PM

According to both Asus and NVIDIA tech supports, the 750i SLI chipset used by my P5N-D MB uses standard Windows USB drivers and does not require any drivers specifically written for the USB devices on that MB. In the Device Manager, the USB controllers are shown as "Standard OpenHCD USB Host Controller" and "Standard Universal PCI to USB Host Controller". I believe these are generic Windows drivers. I tried updating the driver, but was told the drivers are up to date. Deleting and reinstalling the driver didn't help either. Unfortunately, these standard drivers are not working properly for an advanced USB device I'm using known as a USB digital-to-audio converter (USB DAC). This particular USB DAC uses an async communication protocol which does not function properly with the generic USB drivers. This explanation was given to me by the device's manufacturer, Wavelength Audio (www.usbdacs.com). I have spent hours on the phone with Asus and NVIDIA to no avail. They tell me the standard drivers should work, but they don't. I installed a SIIG USB PCI card which uses its own, specific NEC drivers. The USB DAC works perfectly on the USB ports of that card. This is a workaround, but I would like to get the USB ports on the MB working properly. Does anyone know if device-specific USB drivers exist for the 750I SLI chipset or whether there are any other solutions to my problem? Thanks for any help.
October 19, 2008 6:12:52 PM

Since issues like yours are vanishingly rare, there won't be any money spent developing new USB drivers for Windows unless there's some revenue attached (e.g. selling a USB card as with SIIG). I'd stick with the SIIG card; your other alternative would be to try a different OS (e.g. Mac OS or Linux) to see if their drivers support the protocol you need.
October 19, 2008 6:50:42 PM

Thanks for the reply, Mondoman. One doesn't need to change the OS to solve the problem, just switch to a system running an intel chipset instead of NVIDIA. Every other computer we tried (Dell with Intel chipset, MAC running its OS, MAC running Vista with Intel chipset) worked perfectly with my USB device. Guess what? They all used device-specific USB drivers, as indicated in the Device manager. It's only because NVIDIA didn't supply dedicated drivers that I'm having a problem. By the way, the problem may not be as vanishingly rare as you think. I saw another post somewhere on the web from a guy using the same MB, and he couldn't get his HP Photosmart printer to work, although it worked on other computers. Someone suggested he try a PCI USB card, and that's where I got that idea. I'm sure I'll never buy another MB using an NVIDIA chipset. They don't support it properly.
Related resources
October 19, 2008 6:57:36 PM

You're exactly right. I didn't mention switching to an Intel-chipset MB because I got the impression that was too "big" a jump for your situation, but Intel chipsets are much more robust and have better drivers than do nVidia chipsets. nVidia chipsets tend to introduce new features first, but after some experiences with semi-flaky nVidia-chipset boards, I've been sticking to Intel-chipset boards.
October 22, 2008 1:11:38 PM

Well, if anyone knows of another MB manufacturer besides Asus who has been more responsible and produced 750i SLI USB drivers for their MB releases, I'd appreciate the information. If they exist, I'd like to try them with my MB.
!