Services.msc Access Denied

I'm having a problem while editing a program in services.msc. I can access msconfig and services.msc without any problem but when I try to edit a program (whether for start up or anything) it returns a message of "Access Denied". Earlier, I was trying to modify the properties of ESET Services to Automatic since it have an error of "Error trying to communicate with kernel", I can access it's properties and I was about to change it's start up type to Automatic and when I clicked Apply, I got an error of "Access is Denied". Any solutions? Thanks in advance!
3 answers Last reply
More about services access denied
  1. Make sure your profile has admin rights. Check the control panel-->user options.

    Try making the services changes in safe mode. If you can do it successfully there, then you may want to scan for malware.
  2. The account I'm using right now (and this is also the account I used to make change on services.msc) has the admin rights, although at
    Safe Mode another account named Admin exists and also have the same password with my already existing account.
    I tried making changes in safe mode and it is successful. Already scanned for malware using Malwarebytes but found nothing. Didn't tried
    to make a scan with ESET Smart Security since it takes too long. Got any more suggestions?
  3. The Admin account is a default account that shows in safe mode. That's a fallback for someone whose personal profile may become corrupt, or need to do troubleshooting.

    I would recommend you run through the malware guide in my signature.
Ask a new question

Read More

Msconfig Windows XP