Sign in with
Sign up | Sign in
Your question

Problem Installing Win XP Pro SP3 on a 160 GB HD

Last response: in Storage
Share
December 5, 2009 4:19:06 PM

I have a new Seagate Barracuda Ultra ATA ST3160215A 160 GB which I want to install as a primary master instead of a failing HD. The mainboard is P4 VMM2 (VIA VT8751 Northbridge and VT8233 Southbridge chipset)
I installed the HD and it was automatically detected by BIOS, ran the XP SP3 setup, created two partitions (equal size), formatted the C: partition to install Windows on it (fast - NTFS). After copying files from the CD to the disk and restarting was completed (stage 1 of the setup), the system displays ‘Setup is restarting….’ Then I get a fatal system error:

Stop: c000021a {Fatal System Error} The Windows Logon Process System process terminated unexpectedly with a status of 0xc0000139 (0x00000000 0x0000000) The system has been shut down.

It seems to me like this error occurs when Windows tried to access the HD to run the setup.
I know that I need to enable Logical Block Addressing (LBA) for Windows to handle 160 GB, but I noticed that when my BIOS (AMI BIOS 2000) auto-detects the HD LBA doesn’t show as enabled.
The only way to enable it seems to be entering the HD sepecs manually (‘User’ mode).

However, BIOS doesn’t allow me to enter any value for the cylinders, heads…etc. they remain zero (but I can enable LBA), and so the HD cannot be accessed. When I try to navigate with the arrows to type a value, it just jumps over to the on/off settings (LBA, BLK…etc.)!
I hope I don’t need a BIOS upgrade.
This is puzzling. Can anybody offer any help?
Does Seagate have a utility for IDE disks that can automatically enter the specs as well as enabling LBA?
And can one get through without enabling LBA?

I’m stock with this HD now and it’s hard to find IDEs with smaller capacity.
Your help is really appreciated
a b G Storage
December 7, 2009 12:34:57 AM

On some BIOSes, you have to unlock "advanced controls" or something similar, so that you can enter defined values for your drives. Is this possible on your mobo?
December 7, 2009 12:40:39 PM

Thank r_manic for responding.

I think what you said about unlocking advanced controls might be what's happening here, but I can't find any option relating to this matter even after consulting the mainboard's manual. If there's something this important, it should be mentioned in the manual...but there was nothin!
Is there a key(s) that would do this unlocking on most AMI BIOSes?
Related resources
a c 362 G Storage
December 7, 2009 1:26:09 PM

Something to consider before proceeding: it may be possible that the trouble you have is NOT because of missing "48-bit LBA Support", but from some other HDD error.

You do not want to start entering Cylinder, Hear, Sector values manually. In fact, I'm sure your HDD controller does NOT use any of that in communicating with the HDD. It will be using LBA already.

LBA became the "standard" interface for HDD's long ago as their size exceeded about 8 MB. In it, the specification for location became a single number from zero to max, sent from the controller to the board on the HDD. That latter board takes care of converting to CHS co-ordinates based on its intimate knowledge of the hard drive it is managing. The issue you may be thinking of, though, is which VERSION of LBA is involved.

The original LBA system from the late '80's used a 28-bit binary number. Allowing for the fact that all PC-type HDD's use 512 bytes per Sector, that allows access to a maximum of 268,435,456 sectors or 137,438,953,472 bytes - the "137 GB limit" (aka 128 GB in Microsoft's definition of a "Gigabyte" being 1024 x 1024 x 1024 bytes). As HDD's headed higher in the late '90's, the standard was revised to "48-bit LBA", so the max number of Sectors in the new system became 281,474,976,710,656, or roughly 144 Million GB! It will take a little time to get there.

What's tricky as you try to check is that all the older systems say they have "LBA Support", whereas the new ones say "48-bit LBA Support", a subtle difference. Anyway, that system needs to be supported in three places - the hard drives (yours obviously has this since it is designed for 160 GB), the OS (Win XP has had it since SP1), and the HDD controller (usually on the mobo). ALL SATA systems have it, but older IDE systems may not. For many mobos that did not have 48-bit LBA Support built into their BIOS's, an upgrade could be downloaded and burned to add that feature. But before doing that, check that you actually need to update the BIOS to get 48-bit LBA Support.

There may be another way for you to work around this IF the problem is missing 48-bit LBA Support in the mobo's HDD controller and BIOS. Seagate did this with many of their HDD's, so maybe they did it for their Maxtor line, too- check their website. Seagate has a set of diagnostic utilities called Seatools for DOS. You download and run a file and it will create a floppy or CD disk that you boot from to load a mini-DOS and run the utilities, completely without any other OS running. It has lots of good diagnotic tests and tools. Among the tools in it is one to limit the maximum number of LBA blocks the HDD unit claims. In other words, the board on the HDD unit can be re-programmed to report to the outside world that its maximum capacity is something you set. You can use this to set it to the max that the OLD LBA system could use - 268,435,456 blocks. From then on the controller will be happy to work that way with that disk. (For future possibilities, the Seatools utility also has a way to re-set the HDD to its real max capacity.) I did this for a 160 GB Seagate HDD I installed in an older machine whose BIOS could not be updated. It is behaving as a 137 GB unit just fine.
December 9, 2009 1:58:00 PM

Paperdoc, you rock!
:bounce: 
That was very helpful. Thanks a lot, man.
I'll try these Seatools and I hope it'll work.

cheers
December 11, 2009 1:07:24 PM

I was bale to solve the installation problem by using SeaTools for DOS to reduce the capacity of the HDD to something below 137 GB and then reformatting.

I thought that was it, but it turned out that there were more troubles ahead.

Everything was fine with the system partition, but when I tried to format the second partition using Computer Manager, Windows stopped and gave the following BSOD:

A problem has been detected and Windows has been shut down to prevent damage to your computer.
KERNEL_STACK_INPAGE_ERROR

…………………
Parameters of the error:
000000F4 00000003 80e5dba8 80e5dd1c 805fa158

The first formatting attempt ran until 100% before the error, while subsequent attempts fail right away and the computer restarts.
I thought I heard a very slight clicking sound while the disk was in use, so I changed the power supply since a faulty power cable caused my old HDD to produce a loud clicking sound (although it’s still working, I think there’s been some damage).
However, that didn’t solve the problem.

Why does formatting fail? It doesn’t seem to be a power supply problem…
could it be the ribbon cable? The IDE controller? And why did it work for one partition but not for the other?
a c 362 G Storage
December 11, 2009 1:51:30 PM

So you are trying to create two Partitions out of the 130 GB (or whatever) now available in the new HDD unit. The first one apparently succeeded up to finishing the format operation, but the second one failed. Check your memory of the sequence: after Partitioning and Formatting the first (succeeded) Partition, did you exit out of Disk Manager and reboot? Or, did you start right away on creating the second Partition?

Rebooting after creating and formatting a new Partition is always a good practice, because that is when Windows updates it Registry to include the new drive data. Then it is clear and ready to proceed with the next operation. If you did not do that, maybe that's why you had a problem.

So, what to do? First, does Windows actually recognize the one Partition you created and formatted? Does it show up in My Computer properly? Can you write to it / read from it? If all this is OK, we can proceed to trying to make the second Partition. But if there's trouble with the first, let's fix that to start. For now, let's assume the first Partition is not working and needs fixing. The simplest way will be to use Disk Management to wipe out what you have so far and start fresh. In Disk Management's LOWER RIGHT pane, RIGHT-click on each Partition that exists (do the first Partition last) and Delete that Partition, until you have deleted them all and it only has Unallocated Space. Now exit and reboot, then come back to Disk Management. Starting form this empty disk configuration, Create and Format your first new Partition. Exit and reboot, then come back into Disk Management again. Now Create and Format the second Partition, then exit and reboot. Hopefully this will give you what you want.

IF there was no problem with the first Partition and only the second is fouled up, go into Disk Management and look for that bad Partition. RIGHT-click on it and Delete it so the HDD has only the one Partition with its letter name plus Unallocated Space. Exit and reboot. Go into Disk Management and RIGHT-click on that Unallocated Space to Create and Format the second Partition cleanly. I hope that will do it.

If these do not work, tell us what the displays do say, and maybe we can figure it out.
December 12, 2009 3:02:50 PM

Hi,

Thanks Paperdoc.

To answer your questions, I created both partitions using Windows setup (i.e. not with Disk Manager). Both partitions were recognized appropriately by Windows.

Anyway, I think the formatting failure was just a symptom. The problem seems to be much more serious than that.

When there’s some more-than-usual load on the HDD (such as installing a program), I hear strange noises and get BSODs with gibberish (no readable error message). Then, after the system reboots I get ‘S.M.A.R.T. status bad drive. Backup and replace. Press F1’.

Does that really mean that the disk is bad, or is it caused by a faulty IDE controller?
Is it possible that other faulty components have caused damage to the new HDD?

This system is a headache. I would like to hear your suggestions before I give up.
a c 362 G Storage
December 14, 2009 11:41:36 AM

This really does sound like a bad drive. The SMART message is generated by the hardware on the drive's board, not the computer. So if it tells you there are bad errors, it is unlikely the mobo did it. Since it's new, it should be replaceable under warranty. Usually before authorizing that the Seagate Tech Support guys will want to know what their diagnostic utility package says about the problem. So go to the Seagate website and download their Seatools for DOS. Get the version you use to burn a floppy or CD., and make that disk. You boot from the disk you made and it loads a mini-DOS into RAM that is used to run all the diagnostics independent of Windows. Note down what it says so you can tell Tech support.
December 15, 2009 1:38:00 PM

Thanks for your help, Paperdoc.
!