Sign in with
Sign up | Sign in
Your question
Solved

Only one hard disk out of IDE/SATA getting detected, screwy stuff

Last response: in Storage
Share
December 6, 2009 2:29:35 AM

Some weird stuff's been happening to me since I had a power failure last evening. I have a setup with a 10GB IDE drive and a 320GB SATA drive, with the IDE drive as primary (the 320 failed a week ago and I need to back up all the data, which is why I'm living on a 10 right now).

Thing is, uptil the power failure, both drives were being detected perfectly. After it, my Windows became super-slow and completely froze. I restarted, and it's been showing me a message on bootup saying that the 4th IDE has a bad SMART status (which I found highly suspect). On the screen, it shows that my SATA drive is being detected no problem.

I put in the Windows CD and did a chkdsk on the IDE drive, it found and fixed multiple problems. Now the drive boots up without a hitch, but even BIOS fails to recognize the SATA disk, let alone Windows. I tried scrounging the web to no avail before finally throwing in the towel.

When I wake up today, I get the same 4th IDE error, and the SATA drive detected on the screen. I'm a little joyous and figure that everything got solved by itself. I do the chkdsk routine again, and the same thing happens: IDE boots, SATA goes missing. What could be causing this, an SMPS problem? I know that power boxes tend to go suicidal after power failures. Whatever the problem is, it appears to lie on the more fundamental lines, because when the SATA drive isn't detected, it's missing from the BIOS too (I booted into a Linux LiveCD to check, and it didn't detected the SATA either).

Edit for extra:
My IDE is being detected as Slave, could that have anything to do with it? I don't have a Master IDE, and my DVD-RW is SATA-based.

Edit 2:
Also, in the CMOS setting where all the storage devices are listed, I can access all available ports (IDE, DVD-RW and the empty ones), but when I reach the second SATA, BIOS freezes in that I can't move or press ENTER. The flowing gradient on top of the BIOS continues however, so it's not a screen freeze. Also, Ctrl+Alt+Del appears to behave normally. Note that this happens when the SATA drive is not detected, haven't tried what happens when it is.

Curiouser and Curiouser:
I've found that if I keep my computer switched off for some time, say 5 minutes, and then turn it on, the SATA drive is detected in BIOS and I get the Bad SMART message for the IDE drive. From here:
Loading the Windows on IDE: Windows loads extremely slowly, last I checked, took half an hour to get to "Windows is starting up..."
Loading Windows Install CD: At the partition manager, my SATA drive is missing, and only the IDE drive shows up.
Loading LiveCD: Same thing, by the time it's running, the SATA drive is gone.

When I restart from the latter two options, the BIOS again does not show the SATA drive and the IDE drive boots normally, without the slowdowns as before (and without the SATA drive, of course).

I'm starting to suspect witchcraft now.
a b G Storage
December 7, 2009 12:04:31 AM

No man, that sounds like one screwed up mobo. I take it your motherboard's a new purchase?
m
0
l
December 7, 2009 1:17:56 AM

I'm pretty confident the motherboard is alright, there were absolutely no problems before the power failure, and I do know that the 320 GB drive is on the verge of collapse.
m
0
l

Best solution

a c 342 G Storage
December 7, 2009 6:07:00 PM

It sounds like the IDE drive is OK and the SATA is not, but there are a few other things to check.

1. On any IDE system, if there is only one device on the port it MUST be jumpered to Master - the port usually can't work without a Master, unless if tries to fix that problem itself. The only exception is that you can set all devices on an IDE port / cable to "CS" and then the device on the END of the cable will be the Master- so in that case you MUST plug the only device into the end!

2. In many current mobo's the easiest way to use a SATA device is to set its port to IDE (or PATA) Emulation mode. Many mobo's then will tell you that the SATA drive is actually on IDE port 3 or 4 or something like that as its Master. You use the phrase "4th IDE". Does it really say "IDE_4"? That would indicate it is saying "the device on IDE port #4", which is really a SATA device emulating an IDE device. There are only one or two real IDE ports on your mobo.
3. Check how your BIOS is set for all the ports. If you have only one IDE device (the 10 GB) on an IDE port, ensure that port is Enabled and the 2nd IDE port (IF there is one) is not (unless, of course, you can only Enable all at once). Once you've set the jumpers on the 10 GB unit, it should be showing up as the Master on that port. Now go to the SATA ports. You only need one Enabled for your 320 GB unit, although you may not be able to Disable others. Check that port's mode - it probably should be IDE (or PATA) Emulation.

3. Check the Boot Priority sequence, and ensure that it is booting only from the 10 GB on the IDE port, and not the SATA unit.

4. Since the SATA unit is under suspicion, disconnect it and disable its port. See if the machine behaves well using only the IDE 10 GB unit. If it does, go to the website of the maker of your 320GB SATA drive. Download from them their free drive testing diagnostics utility package. Seagate has Seatools for DOS, WD has Data Lifegard. Get the version that allows you to burn a bootable CD (or floppy). You burn that disk. Then you re-connect the SATA drive and Enable its port. Now, put your new diagnostics disk in your CD (or floppy) drive, set your BIOS to boot from that drive, and boot from the disk. It will load a mini-DOS into RAM and let you run all its diagnostics on your drives (do one at a time) without needing to use the drives to boot from. That should tell you which drive has what problems and what can be done.

What it sounds like is that the SATA drive (but it MIGHT be the IDE) has problems and all the delays and SLLLOOOWWW performance are just because the system keeps trying to use it, getting errors, and trying again.
Share
Related resources
!