Sign in with
Sign up | Sign in
Your question

Dual boot fails XP

Last response: in Windows XP
Share
December 8, 2010 9:59:52 PM

Hi gents....
I have a dual boot W2K, XP computer that was running fine. I rebooted one day and it woudn't go into XP. It said there was a missing hal.dll, but of course the file is there. This is my work computer and I have an architectural program that won't run on anything newer than XP.
Windows 2000 is on drive C and XP is on I (eye). So, when I'm in Windows 2000, I can see the XP drive, but it says there's something wrong with the drive and it can't read it. However, I can read and write to it with Ubuntu and with a BartPE XP disk. I can also read it in "Repair" mode with the XP installation disk, but I can't reinstall XP over the old installation. Also, having it automatically repair the installation didn't help. And finally, I can't seem to boot into the XP disk even without the W2K disk.

I don't really need the W2K dual boot, but I do need to get the XP drive working. At first I thought the problem was in the XP drive, but everything but the W2K drive can read it. Maybe the problem is in the W2K drive?
I sure would appreciate any help to get my XP going again.

Thanks
Gary

More about : dual boot fails

December 9, 2010 3:44:13 AM

Thanks, I'll give it a try. Since I can't even read the XP drive when I'm in W2K, it seems like the problem might be deeper than the boot.ini file.

I forgot to mention a couple more things. I've run chkdsk /r on both drives. I've checked the paths in the boot.ini files on each drive (they're OK). And, I ran fixmbr on the XP drive.

Related resources
December 9, 2010 11:27:54 AM

Save all your stuff on DVDs and delete the 2000. Install the XP instead, you can run dual boot XP.
December 9, 2010 11:40:57 AM

Thanks.
The C: drive with W2K sees the I: drive with XP, it just can't read it. Any idea why I can't read the XP drive with the W2K drive but I can read it with the XP install disk, and Ubuntu, and BartPE? It seems that the boot problem would be solved if I could read I: from C:
Maybe there's a way to make I: the boot disk? Of course, since I can't get into XP, I can't run "disk management" tool.

Gary

December 16, 2010 1:39:10 AM

For what it's worth I thought I'd wrap this up and give my solution in case it helps someone else. I appreciate the replies.

Well, the FAT was messed up enough so W2K couldn't read the drive even though other OS's did as mentioned earlier. As it turned out, it was listed as FAT12, not 16 or 32, which was really screwy. Eventually all the data was lost leaving only the MBR. The 160GB drive showed only 10MB.
I put the drive in my home computer so I could work on it. I just pulled one of my DVD recorders and plugged the drive in there.
In the past I've used a program called MiniTool Partition Wizard Home Edition to do various things on my home computer and really liked the program way more than any similar ones. It has a light weight disk recovery tool that didn't fix my drive this time, but it said to try their MiniTool Power Data Recovery 6.5, so I gave it a shot and it worked like a charm. You gotta love these great, free programs :D  I tried both the Damaged Partition Recovery and the Lost Partition Recovery. Both ways worked so I saved the "recovered" disk files from each in folders on one of my hard drives (1TB). I formatted the faulty drive and then copied the good, saved files back onto it.
I put it back in my work computer and used the install CD to reinstall XP and recover the installation. It worked like a charm and I even have my original dual boot working. I didn't have to reinstall any of the other programs.

Gary
December 16, 2010 2:02:02 AM


Thanks for coming back to enlighten us. Few people do this, it is appreciated.

This information will be put into my solutions database promptly.
October 26, 2011 9:40:34 PM

Well, here I am almost a year later with the same problem again. I'm looking for a remedy that doen't include wiping out a drive, and the XP drive (I: ) seems in tact.
Summary: Dual boot W2K (on C: ) & XP (on I: ). C is the boot drive, but XP the defaut OS.
Suddenly won't boot to XP, missing or bad hall.dll or whatever, but it's really there. Boot into W2K and it sees I:, but won't read it and says 0 bytes free space. But, boot from CD to Ubuntu (Linux) or BartPE or use the XP CD, and they all see and read the I: drive just fine.

Gary
!