Sign in with
Sign up | Sign in
Your question

Win XP cannot get master boot in bios ONLY one hd disk no dvd or cd recognized

Last response: in Storage
Share
December 10, 2009 3:54:57 PM

WinXP, One HD, Seagate Baracuda 7200.10 80GB, ST380215A, will not acknowledge Master, will boot up in Slave after 2nd power on.

Have two DVD-RW's One CD-R, have tried all, changing jumpers itermittantly, cannot get any of them recognized in BIOS or Device Manager.

I have changed the around many times to no avail.

Don't have access to re-install Windows or repair.

Thanks

Troubles@cebridge.net
December 11, 2009 10:34:27 AM

excaliber123 said:
WinXP, One HD, Seagate Baracuda 7200.10 80GB, ST380215A, will not acknowledge Master, will boot up in Slave after 2nd power on.

Have two DVD-RW's One CD-R, have tried all, changing jumpers itermittantly, cannot get any of them recognized in BIOS or Device Manager.

I have changed the around many times to no avail.

Don't have access to re-install Windows or repair.

Thanks

Troubles@cebridge.net


Does your mobo have two IDE channels from which you are running all the drives? Or are you using IDE's and SATA's or jus multiple SATA's? If you functioning WinXP HDD is IDE the BIOS doesn't need selectable jumpers with "auto-detect" or cable select config. As long as the bootable HDD is in position one on the first IDE cable and Selected in BIOS as the first "boot" device it will work. Auto-detect will find all the other drives and show their selected placement in the first screens of the boot sequence. The info will be passed to Windows which wil then configure their postition and drive letter.

Try removing all the optical drives, connect your boot HDD on the IDE channel 0, jumpered as "CS" or master or none. Drive 1 is the first connector on the cable. Boot the system and check for hardware flags in the Device Mgr. While you are there, look under the removable or IDE/ATAPI devices for the optical drives and delete all of them. Shutdown and add back one optical on the same IDE cable at connector 2 with no jumper or jumpered "CS". Boot up, watching for the listing of the optical drive in the boot screen and wait for Windows to display "new hardware found". It will lead you through the driver set-up for the drive. Once you get this successfully repeated, re-perform the sequence for the other drives. (Note: assign the drive letters in Windows for each optical drive and tag them on the front panel. It is difficult to remember which optical letter is which when outputting data.)
m
0
l
a c 357 G Storage
December 11, 2009 2:28:42 PM

General rules for setting up multiple devices on IDE ports and cables.
1. Each IDE port can handle up to two devices, provided your IDE ribbon data cable has three connectors on it. One of those (on a cable end) goes into the mobo port connector.
2. Every IDE Port in use MUST have one Master, and MAY have one Slave also. The designation is set by jumpers. The first unit's jumpers should be set to Master. However, some make distinctions between jumper settings for Master with No Slave, and Master with Slave Present. The second unit's jumpers should be set to Slave. Plug the END connector into the Master unit, the middle connector into the Slave unit.
3. EXCEPTION: you can set BOTH unit's jumpers to "CS" for Cable Select. Then the one plugged into the END of the cable WILL be the Master.
4. When mixing HDD and optical drive units on one cable / port, use the HDD as Master and the optical unit as Slave.
5. Master and Slave are pertinent ONLY to the one port the units are connected to. A second IDE port has its own Master and Slave. There is NO Master for the entire machine. There is NO Master or Slave on SATA ports (and hence no jumpers to adjust for this) - those ports only handle one device each.
6. The boot device is no longer the Primary IDE port Master as it was years ago. The Boot Sequence Priority is set completely separately in a BIOS screen section.
m
0
l
December 18, 2009 5:59:27 AM

Paperdoc said:
General rules for setting up multiple devices on IDE ports and cables.
1. Each IDE port can handle up to two devices, provided your IDE ribbon data cable has three connectors on it. One of those (on a cable end) goes into the mobo port connector.
2. Every IDE Port in use MUST have one Master, and MAY have one Slave also. The designation is set by jumpers. The first unit's jumpers should be set to Master. However, some make distinctions between jumper settings for Master with No Slave, and Master with Slave Present. The second unit's jumpers should be set to Slave. Plug the END connector into the Master unit, the middle connector into the Slave unit.
3. EXCEPTION: you can set BOTH unit's jumpers to "CS" for Cable Select. Then the one plugged into the END of the cable WILL be the Master.
4. When mixing HDD and optical drive units on one cable / port, use the HDD as Master and the optical unit as Slave.
5. Master and Slave are pertinent ONLY to the one port the units are connected to. A second IDE port has its own Master and Slave. There is NO Master for the entire machine. There is NO Master or Slave on SATA ports (and hence no jumpers to adjust for this) - those ports only handle one device each.
6. The boot device is no longer the Primary IDE port Master as it was years ago. The Boot Sequence Priority is set completely separately in a BIOS screen section.



Paperdoc:

Thanks for replying. .... err ..... what is a mobo?

I tried plugging in the ribbon to the first connector, with jumpers in all positions and without any jumpers at all. The HD failed to boot.
I used the second connector on the ribbon, with jumpers in each position and with no jumpers.
With no jumpers, Bios said it was the slave and booted up.
Tried another ribbon, same thing.

The second ribbon (for the DVD slot) also refused to recognize the DVD in the Master designating mode, it is working now in the Slave mode (using another ribbon).

I am afraid to touch anything now 'cause I've opened that case about 50 times. The DVD will play but will not recognize a DVD+R or a DVD-R.

Thanks again,

Excaliber123
m
0
l
December 18, 2009 9:46:33 AM

Excaliber123 (nice gun)

Mobo = Motherboard, shortened name.
Be sure to check your BIOS settings as Paperdoc described. You might have a loose connector in the IDE channels (although two failing together is rare). Be very careful how you line up the pins in the connectors and the cable receivers. An angled entry can distort or bend a pin. Also be sure the IDE cable is oriented properly with the drive pin bracket. They should be keyed however, I have run across cheap ones that are not. There should be a slot on the drive connector that matches the raised portion on the ribbon cable. On the cheaper cables, they just put a very small raised line in that position, so one can easily miss noticing it and without effort reverse the connector. Both ends of the ribbon cable will have numbers molded on the connector. They're really small. Look at the edges and you should see a number 1, with the other corners also labeled. Be sure to match these with your connectors on the drives and the mobo (motherboard).

If your BIOS is set correctly and the ribbon cables are attached correctly (those type of cables often malfunction after years of bending and twisting) and the cables are know to work, I would suspect problems with your connectors on the motherboard or bent pin on a drive.
m
0
l
a c 357 G Storage
December 18, 2009 1:17:20 PM

Check a few things here. And proceed methodically so you can keep track of all the settings. Since the immediate need is to get the HDD to function as your boot device, connect only that one device, and leave the optical drives out of the picture for now. They can be re-connected later when the HDD is working.

1. Take a close look at the ribbon cable you are using. There usually are different colors for the connectors. The BLUE on on the end MUST go to the mobo connector. Usually the other two are black (end, for Master) and maybe gray (middle, for Slave). Odd as it may sound, I have heard of people who had trouble putting the wrong end in the mobo port connector.
2. MingDragon has a good point about possible poor keys that allow plugging the connector in the wrong way. If there is any confusion, here is another set of clues. Look at the ribbon cable. On the side of the cable on ONE edge only you will find a red stripe. This is for PIN #1. Look now on the mobo for a label beside the port connector - it will have the number 1 printed close to one end. That's where the #1 pin is, so the cable plugs in here with the red stripe on the end labeled "1". Same thing on the HDD unit - its case will have diagrams of the edge connectors on the back, and an indication of which end of the 40-pin data connector has Pin #1 - red stripe here.
3. Decide which system you want to use for setting Master and Slave. If you go with Cable Select, set the jumpers on ALL of your devices to the "CS" setting and don't try others. The END connector of the cable MUST plug into the Master device in this case, and the middle connector will establish the Slave device. You really are supposed to have a Master on each IDE port, although there are a few that can work without one.
4. If, instead, you opt to set your own, for each IDE port set ONE device's jumpers to the Master position, and the second device to Slave. Use the diagrams on the devices to make these settings. Pay attention to each device's diagrams - they are NOT all the same. Don't just try out every possibility. When connecting, it is advised (although maybe not strictly required) that the END connector of the ribbon cable go to the 0one jumpered as Master.

So, try the "correct" way starting with ONLY your HDD to work with: either set it to "CS" or to "Master" or to "Master with No Slave", according to the diagram on it. Plug into it the end (black) connector of the ribbon cable, and the blue other end goes into the mobo's first IDE port, usually labeled "IDE_0". Make sure the HDD's power cable is in snugly. Power up and go immediately into BIOS Setup by holding down the "Del" key. Go to the Integrated Peripherals screen and make sure that your IDE_0 port in Enabled. Go back to the opening screen and check - does your HDD show up there with the right size? If not, you have a hardware problem to address - bad mobo port, bad HDD, or bad cable. But if it is there OK, go the the Advance screens and look for where you set the Boot Priority Sequence. Set it to use the HDD only, and not even try anything else. Save and Exit and it should boot from the HDD into Windows.

Now, if your HDD did not even show up in the Setup screens, what to check? Well, you could try changing the drive to a Slave setting - change its jumpers AND change to using the middle cable connector - then reboot and try again. What you reported above says even in the absence of a Master your mobo is able to work, so this is worth a try. If it does work this way, then you most probably have a good drive but could have a bad mobo port or cable.

If you got to this point, stop and check one other thing. Look closely at the connectors on the mobo and the HDD back edge. All of the pins should be there and straight, EXCEPT for one - pin #20 near the middle will be missing. It matches up with one "hole" on the cable connector that is blanked off. If any pins (other than #20) are bent or missing, you may have found the source of your trouble.

Anyway, if the "correct" way you tried first did not work and the pins are all OK, you can try different combinations of which mobo port you plug into, and which cable or connector you use, to narrow it down to which component has the problem - mobo port, cable, or HDD. Once we know that, we can help figure how to proceed to get it all working. Let us know your results. Once we get the HDD to work OK, we can get the opticals back into the picture.
m
0
l
!