Sign in with
Sign up | Sign in
Your question

2nd sata hd installation problem

Last response: in Storage
Share
December 13, 2009 11:22:35 PM

installed a 500gb sata hd in dimension 8400 as a second drive,Hooked up power and data cable. In Bios enabled sata port and then rebooted but it wouldn't start Windows Xp.Went back to Bios and checked boot sequence and it showed no hd's present. I then changed drive controller to RAID/ATA, and rebooted nad i got blue screen saying a problem with HD and to scan for virus. So i switched back to Raid /AHCI.The new hd shows up in BIOS under SATA port 3 as 500 gb but it doesn't show all the details that 1st hd on Sata port 1. Any ideas?
a c 362 G Storage
December 14, 2009 11:54:29 AM

Somehow the original HDD on SATA1 got disconnected, it seems - maybe you bumped it without noticing. Try disconnecting its data and power wires at the drive and then re-connecting carefully. Do the same for the end of the data cable at the mobo. Do this a few times each in case the contact surfaces are oxidized and need light cleaning. Close up and try booting.That MIGHT help.

What mode was your first drive (the one that was working OK up to now) using in the BIOS Setup SATA settings? Some systems use the IDE (or PATA) Emulation mode (to avoid having to load a SATA or AHCI driver when installing Windows). Once that is set, you can't change it without some other things being fixed, too, because Win XP does not have its own SATA drivers built in. So make sure the first drive's mode is set as it was originally. And it may be best to set the new drive's port to the same mode.
m
0
l
December 14, 2009 7:00:56 PM

Thanks for your reply. I went back into Bios and first drive controller is Serial ATA, Port 0 then it gives drive detail and capacity 160 gb and Drive controlled by System Bios. 2 nd drive controller is Serial ATA Port 3 details and 500gb. When I enable port 3 and reboot it goes to windowXP screen and then goes to a blank screen with no cursor, it's like it doesn't know what hd to access. I tried switching to diff driver controller but only orginal RaID AUTODETECT/ahci works. When I tried RAID it did take me to a screen that showed both drives and said to hit cntl+I to config drive. but I hit that and it did nothing, I had to reboot. Other setting went to blue screen.
I'm trying to update bios and sata drivers but I get an error on page when I try to down load driver from Dell so I'm looking for other sites for driver.Hopefully that will work.
thanks for help
m
0
l
Related resources
a c 362 G Storage
December 15, 2009 7:06:12 PM

Within the BIOS Setup screens look for where you specify the Boot Priority Sequence. I usually set mine to try the optical drive first, wherever that is attached, and then the second choice is the HDD that has your OS on it - in your case, the older smaller SATA drive on SATA_0. Then NO other choices possible for now.

It appears your machine originally had its SATA_0 port (with the older drive) set to RAID/AHCI mode. Try disconnecting your new drive and setting the old one to RAID/AHCI mode, then boot from it. I'm guessing it will boot that way. But if you re-connect the new drive to SATA_3 and configure it also to RAID/AHCI mode, it may not boot.

If that is exactly what happens, a couple of thought come to mind. First is, what is your OS? And linked to that, what size does Windows show you for your old 160 GB drive? Does it say about 150 GB total, or does it say about 128 GB? What I'm looking for here is an indication of whether your OS can deal with a HDD over 128 GB. Windows XP original edition (without any Service Packs installed) could not, so check the Help ... About screen for your OS and see what version you have of which OS. That might explain why it has trouble with the 500 GB unit. And just MAYBE the original drive was adjusted to appear NOT to be the full 160 GB and avoid this glitch.
m
0
l
December 22, 2009 8:59:10 PM

Sorry I was out of town. Yes original drive is set to Raid/ACHI and when second drive is set to same it won't boot widows from original HD. I checked original drive properties and it does show a capacity of only 144gb and not 160. OS is Windows xp pro version 5.1.2600 media edition 2002 service pack 3 as verified by sysdm.cpl and winver and winmsd.exe. So it does sound like that OS might not be able to handle a lg drive. Is there a way around that? thanks for your help
m
0
l
a c 362 G Storage
December 23, 2009 3:10:50 PM

Your OS, which includes SP3, certainly CAN handle large HDD's, and the size of 144 GB for your C: drive confirms it is working, so that's not your problem. So, some steps to figure things out.

1. Disconnect the second drive and boot. Does your machine boot up OK with only the original drive connected?

2. If it boots fine with only its original drive but can't boot with the new 500 GB unit connected, let's look for a SATA incompatibility problem. This can happen sometimes with the specific combination of a machine with an original SATA controller (150 GB/s speed), which I'm pretty sure you machine has, and a newer SATA II drive (300 GB/s speed). Although the units are supposed to be able to adjust themselves automatically, some fail to do so. The result seems to be that the BIOS thinks it is having constant errors trying to use that new drive and gets stuck there at start-up. So drive makers provide a way for you to manually force the new drive to slow down to the original SATA speed. Who made your drive? What exact model number is it? Using that info, go to the drive manufacturer's website and look for information on forcing the slower speed of 150 GB/s. On Seagate and WD drives there usually is a small set of pins on the drive back edge with a jumper you can set for this. NOTE that this is NOT for the old Master / Slave system on IDE drives, even though it looks similar with jumpers on pins. The jumpers can be for several things, so do only what the website says for SATA speed adjustment. If your drive is from another maker, search their website. for example, I think Samsung does the job with a software utility to set parameters on the drive board. Whatever you find, try manually forcing the 500 GB new unit to the slower speed, then re-install and see if that solves the problem.

Let us know how this goes.
m
0
l
December 23, 2009 5:29:10 PM

Thanks for your time. I'll try slowing down the drive. I just need to get some jumper shunts for the WDC wd5000aaks HD. They didn't come with one. I'll let you know how it turns out. Again thanks
m
0
l
a c 362 G Storage
December 23, 2009 6:28:40 PM

When you go looking, watch for a subtle detail. The pins spacing and jumpers used on SATA drives are not the same as the ones used on older IDE drives, so you can't use an IDE jumper on the pins of a SATA drive. Look specifically for the jumpers for a SATA unit.
m
0
l
!