Sign in with
Sign up | Sign in
Your question

Power Swtich connected - Won't turn on

Tags:
  • Motherboards
  • Cases
  • Power
  • LED Monitor
Last response: in Motherboards
Share
October 30, 2008 8:31:44 PM

For the life of me, I can't figure this one out.
Today, I attempted to replace the case of an old P4 system I have. Sounds simple enough.
I hook up everything just fine, plug the PSU into the wall, and the green LED on the board lights up.
I place the Power SW plugs as instructed by every site, confirmed many times, press the power button, and.. nothing happens.
I take out the old PSU, wire that to the board solely, press the power button, and nothing.
I plug the old case's power switch plug, press its power button, and nothing.
Now, the only thing that would make sense is that the board is fried. But it worked fine 20 minutes ago, and the green LED seems to work just fine.
Two cases, two PSU's later.. I am pissed off as **** because stupid ridiculous problems like this always plague my very existence.
If anyone wishes to take a crack at it, I'd thank you for it very much.

Chris

More about : power swtich connected turn

October 31, 2008 2:55:30 AM

Chris,

Ironically enough...I have the identical problem at this particular moment. Practically everything that you just described is happening to me at this very moment. In fact, I just joined Tom's Hardware forums today in order that I might find someone who could lead me in the right direction.

I had to get a new power supply for my old Gateway machine with an ATX (El Paso) motherboard because the old power supply blew out..

I got another PSU and plugged it up identically to the way that the prior PSU was plugged up, but my machine won't power up at all.

The green LED is lit up on the board, but the thing just won't power up at all. I have already tried the screwdriver trick (to jump it off using the power switch pins) which is described elsewhere on the forum, however it just won't start.

It's entirely possible that we can get a 2 for 1 resolution for our problem within the context of this thread.

Thanks,
Pat
October 31, 2008 3:10:22 AM

try plugging it in bare - out side the case. place it on some antistatic bag, reinsert the cpu, vga and memory. and try again - without any other devices. If it doesn't work take the battery out, leave it for 10-20 mins. insert battery then try booting it again.

October 31, 2008 3:26:46 AM

Not to be condescending, but make sure your secondary power connectors are connected as well, like any 4 or 8 pin power connectors your board might have. You can also try power flushing the PSU. Just unplug the PSU from the wall, hit the power button on your case like you're turning it on - the green light should go out - plug it back in, and turn it on. Sometimes that works.
Related resources
!