Sign in with
Sign up | Sign in
Your question

Recently Built System choppy in High Graphic Games

Last response: in Systems
Share
July 28, 2008 5:17:47 AM

Hi everyone :hello:  . I'm having a little problem with my system while running certain games. I am not sure if the problem is my built or it is a software conflict that is making my games run choppy. Here are the specs...

CPU: Intel E6750 (stock)
Motherboard: Azus P5k Deluxe
Ram: CORSAIR DOMINATOR 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500) Dual Channel Kit Desktop Memory
Video Card: XFX 8800 GTS 512 mb Alpha Dog Edition (Forceware: 177.66)
Sound Card: X-Fi Extreme Gamer
HD: 320 gb Seagate 7200.10 SATA
OS: Vista Ultimate
Antivirus: Norton Internet Security 2007
DirectX 10

I've run C&C3:Tiberium Wars, Company of Heroes (directx 9 ver.),Simcitiy Societies, smooth with no problem at all.
I've recently installed Age of Empires III and Call of Duty 4. I would understand that I might get a bit choppiness while running CoD4 but not from Age of Empires III. When I'm in AoE III, the games get choppy when I zoom out and my sound sounded laggy and choppy as well. When I run CoD4 at system optimal settings, I'm getting the same choppiness in game as well as the sound. I am running @ an avg of 15 fps in game on single player mode. Which is frustrating me. I went on http://www.systemrequirementslab.com/referrer/srtest to check if i pass the min and recommended requirements, and I have well over achieve it.

Can someone tell me what my problem might be? or if anyone have similar problem and it is now fix, help me out ?
Thanks in Advance!
July 28, 2008 5:25:09 AM

Need more info.

What resolution are you running COD4 at?

If you disable Norton does the problem go away?
July 28, 2008 5:27:07 AM

Oh DX 10 :p 

Heh, does COD4 have an option to run in DX 9?
Related resources
July 28, 2008 5:32:19 AM

with the system optimal settings: 1280x768 w/ 4x AA and off on AF. turned AA off and 800x600 before. still lagging. fps only increased by 2. I also tried turning of the Autoprotect only. Still didn't help.

My system is running on DX10 but I have run games w/ DX9 and it was smooth. (comapny of heroes)

I'm also running a bit choppy on World in Conflict. but definately not as bad as Age of Empires III consider that it shouldn't be a graphic intense game.

I'm running AoE III @default settings: 1280x768
July 28, 2008 5:51:02 AM

I really can't say what to expect from DX10, although I imagine it should be better.

I can tell you that I can run COD4 at 1680x1050 at pretty much max settings in DX9, with E8400, 4 gigs RAM, and an EVGA 8800GT.

How are your temps? Strategy games can be deceiving. Civ IV used to overheat my 7900GT. That usually leads to artifacts though.

Have you run Real Temp? CPU-Z? Just to check on the basic hardware stuff.

July 28, 2008 6:02:26 AM

no. I have not. I have run it before but not recently. My cpu was running around 32 degrees.
July 28, 2008 6:10:31 AM

just checked it. i'm running @ 33 degrees on my dual core
July 28, 2008 6:10:57 AM

Hmmm check for sound card updates. I think there is a beta version out that you might want to check. Sound is often a hidden problem in performance.
July 28, 2008 6:15:03 AM

that was my original concern too. but if it is.. it is affecting it tremendously. Running CoD4 @ 15fps with the spec I have is kinda a big problem... 'sigh' =(

by the way, I've ran the update too but there were no new updates @ this time. Ran in yesterday.
July 28, 2008 6:22:38 AM

Don't worry about your system specs being able to run a game. It should/is easily capable of running any game 1200x800 on high setting. The problem lies in either a combo of slightly bad drivers that show their face on certain things, one bad driver(video card or even try taking ur sound card out), or somehting isn't getting enuf power (very unlikley cause ud c more things then these games run bad).
July 28, 2008 7:30:12 AM

so i uninstall my forceware 177.66 and install the recommended driver from www.nvidia.com (175.19) . Tried the game. same thing.. running 15 fps while on the field and running a little better in the building 20fps. but it fluctuates a lot depending on what I am viewing. either looking @ the wall or looking outside of the window.. not sure why that fluctuate that much...
July 29, 2008 5:59:46 AM

anyone has any idea?
July 29, 2008 8:29:05 AM

try re-installing your graphics and download the drivers from the website

make sure cables are not loose

make sure the card isnt touching anything is shouldnt be

or

ask nvidia themselves for help ..my guess would be that someone who actually works for nvidia will know more.
July 29, 2008 4:36:10 PM

i tried 3 different versions of forceware. still no help. uninstall than install. not sure about my vid card touching "anything' that it shouldn't..

but i'm actually talking to one of the xfx tech on bjorn3d.com but doesn't seem like he has got to my question yet. he was thinking that it might be core affinity settings that is affecting my games. but it didn't help when i changed the settings... here's the link..

http://www.bjorn3d.com/forum/showthread.php?t=25089


July 29, 2008 7:15:50 PM

Simple thing, and maybe you have already tried it.

Do you have a multiple display? Can you hook one up?

If you can, run Task Manager while running the game, see what it says about memory, VM, I/O, and CPU usage.

AoE III having problems is a little weird, but it may have something to do with how many things it may be tracking. Also, the program itself may not be optomised for your system (it is a bit dated).

Have you tried other RTS games? SC? CoH? GoW? Have you tried turning down other graphical effects like reflections, particles and such? Have you patched the games themselves?

Do you have an antivirus running? Can you see what other programs are running while running these? (I had a problem with one game turning on my MPC renderer repeatedly while playing. After shutting down, ou would see about 30 "FFv" tags in the taskbar).

Just some thoughts....
February 10, 2009 9:14:24 PM

Lol surpised i found this post, but hicube i have/had the exact same problem as yourself. Call of duty 4 and age of empires III, would run choppy. Turning down video options didnt help neither, but on call of duty try enabling dual video card option even if you have 1 card, it helped me to run it properly. Still not sure whats wrong with AOE3
!