Sign in with
Sign up | Sign in
Your question

ATI Catalyst 8.8 won't install/load

Tags:
  • Graphics Cards
  • ATI
  • Graphics
Last response: in Graphics & Displays
Share
August 21, 2008 8:18:52 AM

Just built a new computer:

Q9550
Asus Rampage
G Skill 4GB
VisionTek HD 4870
32-bit Vista

Everything went smoothly until when I was trying to install ATI HD 4870 Driver. I tried to install the latest driver (8.8) but after the installation/reboot, the driver won't load and it shows that VGA driver's not installed. I tried unstalling/installing again but showed no change. I finally grabbed the CD it came with and for some reason, the driver from the CD that came with the video card installed fine. But it is 8.6 version and I wanted to update my driver to the latest. When I tried installing the latest(8.8) again over 8.6, it stayed as 8.6...Any ideas what I should do? Thanks in advance

More about : ati catalyst install load

August 21, 2008 8:48:15 AM

Uninstall completely using driver cleaner in safe mode and reinstall with security software and firewall turned off and internet disconnected.
August 21, 2008 11:43:59 AM

thanks for the reply railroaderron, i tried your suggestion but didn't seem to work. But weird thing happened, I installed the driver by itself and the 8.8 driver installed but when i try to install CCC it refuses to load up in the windows...when i right click it doesn't even show the CCC on the box :( 
Related resources
August 21, 2008 12:16:19 PM

very strange but finally got it to work! :bounce: 

instead of using the all in one package driver/CCC. i basically installed the CCC first and then the driver only (in this exact order). For some reason, if i install driver first, you'll get the resolution but you won't be able to isntall the CCC. If you install the CCC you'll have the CCC program but you can't open it until you install the driver afterwards. Took me alot of rebooting to figure it out. Hopefully ppl out there with the same problem can solve this annoyance :) 
a b U Graphics card
August 21, 2008 12:49:21 PM

Silly question, you installed your motherboard drivers first right? Also CCC needs Microsoft .NET installed to work.
August 21, 2008 6:21:23 PM

Did you grab XP drivers by accident?
August 22, 2008 4:41:41 AM

i hade that same issue my self . i had to install each driver sepretly for them to work at all . i did mine in reverse order tho . it seams to work tho . no issues as of yet .
August 22, 2008 6:38:07 AM

yeah installed the motherboard drivers first. I do believe i installed Microsoft .NET. and I'm 100% i downloaded the vista driver. I would hate myself if i was struggling because i downloaded an XP ver. :p 
!