Sign in with
Sign up | Sign in
Your question

Wrong HDD booting, tried everything!

Tags:
  • Hard Drives
  • BIOS
  • Boot
  • Storage
Last response: in Storage
Share
December 20, 2009 9:56:19 PM

Hello! I'm new to this forum, but I already have a question. :ange:  I have a Seagate P-ATA disk that boots even though I have specified in BIOS to boot from S-ATA1. The motherboard is an Abit KN9S. The boot order keeps reversing to default, and nothing can change it, I save, restart, and it is back to start! I have recently changed the BIOS battery, and everything except the BOOT priority saves properly, the clock, First boot device and so on... Installed every driver I could find on the Abit page, upgraded the BIOS, and reinstalled Windows several times.
I've had this problem ever since I changed my OS to Windows 7.
I am getting really pissed off at my motherboard, and want to kick it really hard in the south bridge. :fou: 

I want to thank anyone who bother answering! If there is any other information I can hand out, please ask!

More about : wrong hdd booting

December 20, 2009 11:09:58 PM

try disconnecting the pata drive and see if you can boot from the sata.....that way you can at least narrow down the problem......

report back what happens.....it will greatly allow people to find a solution
a b G Storage
December 20, 2009 11:11:14 PM

Have you tried disconnecting the PATA drive...?? Will it let you boot from the SATA drive if you do?
Related resources
a b G Storage
December 20, 2009 11:16:44 PM

Someone else posted while I was writing my response...

Did you have an OS installed on the PATA drive?

Which disk has the Win7 install? I presume it's the SATA1 drive, but if the PATA has an OS your boot partition is on that drive.
December 21, 2009 6:39:21 AM

It works trying to disconnect the P-ATA drive, everything works perfectly when it's disconnected, but I have family pictures and music on that disk, so I would like to have it up and running again...
I have never installed an OS on it. The message "Bootmgr is missing. Press CTRL-ALT-DELETE to restart" appears.
The Windows is installed on SATA1. When I installed Windows I made sure that the only disk running was the SATA1-disk with Windows. I also formatted it to make sure that there were no leftovers from older installs.

Thanks for the response!

Edit: I've also tried putting it in slave, which it is now, by removing the pin as in the instructions and putting on the second connector on the IDE cable, still not working
a b G Storage
December 21, 2009 2:26:17 PM

This may sound silly, but why not hook up the PATA drive via USB, so that once Win7 is up and running, power up the PATA drive via usb and away you go!

If not, you may need to use the Win7 BCEDIT command line or search online for a gui based editor to make your changes to the boot file.

Hope this helps...

;) 
a b G Storage
December 21, 2009 9:54:45 PM

Without looking at the root of your PATA drive it's difficult to say for certain, but I think, somehow, a boot partition exists on that drive that is conflicting with Win 7. Do you have jumpers set on the PATA drive? If no, set it to master. It might be some wierd conflict with cable select (but this should only occur if there's no jumper set).

I need an answer to the following before I can offer any more help. What file system is on the P drive. If it's NTFS, the Ultimate Boot CD has some NTFS tools that will probably help but I'm not familiar with them right off-hand.

This may help as well. If you can't D/L and burn the ISO image to a DVD, perhaps you can get a friend to do it for you. This image has a lot of tools on it that can help you fix a sh*tload of problems.

http://www.ultimatebootcd.com/

This link will help you create an MS-DOS boot disk from Win XP. Do you have a friend with XP that could help?

http://www.microsoft.com/resources/documentation/window...

I'll be back on later tonight, probably within the next two hours.
December 21, 2009 10:40:44 PM

@elmo2006: Yes, I have thought about an external drive cabinet, but I have a fierce struggle with available USB ports! Don't want to spend money on a converter and an USB-hub :p  Thanks for the tip about that BCEDIT thingy, btw! I resat the whole boot-file with EasyBCD, and the disk was freshly installed. Had no clue the program existed. Always used msconfig for boot options :p 

Have managed to boot with the disk now, and I am currently copying all of my stuff onto another HDD. Gonna try to format and see how it goes! I don't really think I'll dare rebooting again! I utterly hate that "Bootmgr missing. Press CTRL-ALT-DEL to restart"-message. Things are looking good for my precious files! Will backup from now on!

@Mikey5802: The disk is NTFS, the disk is an aging Seagate Barracuda 250GB drive, and the jumpers are without a jumper as the instructions say it has to be for it to be in slave! Here are my jumper settings:
Slave (Present setting) : : : : Master | : : : Cable select : | : : Master with non ATA-compatible slave | | : :
As you can see above, I have finally gotten into the disk in Windows and started digging out all of my things before i format the disk! I found a "Users" folder which I've never seen before, but no traces of any pre-existing versions of Windows. I am going to reformat it now (wish me luck!), and if that doesn't work, I will certainly look into that UltimateBootCD! I have an old desktop with windows XP Home Edition on it, so I can probably make a Boot-disk from that.

I am actually quite familiar with computers, and I am embarrassed to say that this problem is digging a huge hole in my head!

Will be back soon with an update. If all it needs is just reformatting, I am going violent on something...
a b G Storage
December 22, 2009 11:21:39 AM

Glad you got the problem resolved... Single PATA drives should have a jumper set to make it a master, w/o a jumper the drive is ususally set for a cable select environment which detects the drive by connection order instead of priority by jumper setting. There's no master-slave correlation between PATA and SATA drives.

Oh well, you got it resolved and thats the important thing.

Sorry I didn't get back toyou earlier but I sat down, had a bite to eat and conked out. Next thing I knew it was 3:00 AM.
December 25, 2009 10:26:10 AM

I formatted it and put it on the master jumper again. Now it works! Thanks for replies! I now consider this thread solved!
!