Sign in with
Sign up | Sign in
Your question

Moved computer into new case, now Windows 7 won't boot

Last response: in Windows 7
Share
December 9, 2009 5:29:18 PM

I just bought a new computer case for my computer and moved [almost] all of my computer parts into it. It's a smaller case so one of my storage HDDs had to become an external, no big deal. The OS is Windows 7 Professional x64, it was installed on a pair of SATA drives on a RAID-0 array.

Before power on, the only storage devices connected to the computer were those two SATA drives in RAID-0 and a DVD burner. I went into the BIOS setting to make sure the boot order was fine (it would check the DVD burner first and then the RAID-0 array).

The first message that came up was: Reboot and select proper boot device

A little shocked, I disabled the DVD burner and forced the computer to boot strictly from the RAID-0 array. Got the same message.

My heart was racing a little at this point and I booted up the Windows 7 DVD and ran chkdsk /r in the command prompt. But before the command prompt showed up, you would see a list of what operating systems are installed. The list was empty. There's also an 'add drivers...' option which I briefly tried but it seems Windows 7 already had the necessary drivers. IN FACT, I was able to browse through the files in my RAID-0 array via the "browse for driver" window. Everything was there. Anyway, the chkdsk completed and there were no problems. Clearly, my OS was still in the RAID-0 array but it won't boot for some reason.

The next thing I ran the startup recovery tool on the Windows 7 DVD. The report showed that the root cause was an invalid entry in the partition table and apparently the tool repaired it. I rebooted and the Windows 7 DVD's "push any key to boot from DVD..." prompt came up. I ignored it and I got the following message: Missing operating system

I checked BIOS again to make sure my RAID-0 array was still in the boot order which it still was. I also disabled the DVD burner again and rebooted directly into the RAID-0 array. Got the message: Reboot and select proper boot device

It's as if the startup repair tool did nothing at all!

Again, I was still able to browse the files on the array through the repair tools on the Windows 7 DVD. It just won't boot the operating system for some reason. Another thing to note is that the OS install is GPT based, with roughly 100 MB for the "System Reserved" partition and the remains used for the actual OS. Not sure if that matters.

Regardless, I needed this computer running for the work I have to do today so I did a format/re-install overnight. Fortunately it's just my OS/Programs that I lost.

I'm just wondering if anyone ran into the same issue and was able to fix it. I have to install new cables and a new PSU later this week so I might run into the same issue again.

Any help is appreciated. Thanks in advance!
a b $ Windows 7
December 9, 2009 6:39:50 PM

Most likely your RAID-0 array crashed or F'ed up. Glad you only lost OS/Programs. REMEMBER: ALWAYS keep backups of your important files.
m
0
l
December 9, 2009 7:39:54 PM

Thanks for your input! Not sure if it crashed because I was able to browse through the array's files through the repair tools on the Win7 DVD. I just couldn't get it to boot. Maybe the MBR or GPT header got so messed up that Windows couldn't fix it?

It really sucked because moving parts from one case to another is pretty routine. I never expected to run into this issue and if I did, I was almost sure the repair tools would have fixed it.
m
0
l
Related resources
December 9, 2009 7:58:40 PM

Fix your MBR. and see what happens. Do it manually with the command prompt in the windows boot disc. There are some other files you can try to fix from there as well.

Try these

http://support.microsoft.com/kb/927392
m
0
l
December 10, 2009 8:39:53 PM

Thanks pathasse. I didn't realize there were more manual ways to fix the MBR via the command prompt. Unfortunately, I already did a re-install as I've previously mentioned but tomorrow I'm replacing several cables and the PSU. If I run into the same situation again, I now know I have more options to try out. Thanks!
m
0
l
!