horrendous fps w/ 8800gt sli

ok i have two 8800gt's in sli mode. i am playing crysis at 1680x1050 at all settings on medium (no AA). i am getting ABSOLUTELY DISGUSTING fps (aka 12-20)!!! :fou: :fou: :fou: :( :sweat: :pfff: :cry: :(

according to this site: http://www.anandtech.com/video/showdoc.aspx?i=3341&p=13 i am supposed to be getting 46.1 on high/very high!!!! help!!!!

i have a fully capable and sli compatible system:

amd phenom 9850 black edition
asus sli certified mobo
700w sli certified psu
windows vista home premium 32bit
4gb kingston ram

does any one have advice?
18 answers Last reply
More about horrendous 8800gt
  1. when i read the title, i was going to say maybe your video cards weren't getting enough power, but 700 watts should be plenty. which motherboard/chipset do you have? if your sli is 8x/8x, then you may be bandwith limited. and if that's not that case, i can't think of anything. a phenom 9850 isn't amazing, but it should be able to handle crysis.
  2. mayeb its cause you have 32bit and not 64bit? i dunno this is a toughy
  3. of course you have the SLI bridge on them, right? Umm...
    check the temps on your cpu? maybe it's throttling?
    what's the brand on the psu?
    do you have the right drivers installed correctly? did you uninstall the old ones fully?
    and..
    you don't have the cruddy 256mb 8800gt's right?

    That's all I've got. I hope you get it figured out...
  4. my mobo is : ASUS M3N72-D AM2+/AM2 NVIDIA nForce 750a SLI ATX AMD Motherboard

    i found out thAT this mobo is only 8x/8x while in sli =(...

    and btw my phenom is oc to 2.8ghz, plenty of power

    and the 8800's are oc to 675 core clock, 1699 shader clock, and 958 mem clock.

    i have a feeling that it is a problem with crysis because my system totally RAPES games like HL2 (100+ fps) and flight sim X (50 average fps)
  5. i have the 512 version (EVGA). yea i have all the drivers installed, the sli bridge, and my psu is by thermaltake
  6. cpu runs very cool, NEVER seen it above 47C
  7. well the 8x bandwidth hardly affects their performance...its like running them on x16 on pci express 1.0...

    Are there any settings in Crysis that you need to enable in order to take advantage of both cards? I have played crysis on my current rig but am not really familiar with all the crysis tweaking (cuz i know theres a lot of tweaking that can be done)...
  8. Is crysis patched to the latest version? 1.2 i think
  9. Nik_I said:
    a phenom 9850 isn't amazing, but it should be able to handle crysis.



    ummm, i dont know what you're talking about, but phenom 9850 is plenty for crysis...
  10. crysis is patched,
  11. hey every 1, i just made a great discovery!!!! i went into task manager and closed all the processes i wasnt using, and now i get more like 20-28 fps!!!!!! much improved!!!!!!
  12. Why don't you format and just instal everything you need?
  13. uhm... what?
  14. ATTENTION!!!!!!!! DISREGARD ALL PREVIOUS POSTS!!!! I UPGRADED TO 175.19 NVIDIA DRIVERS AND I AM NOW RUNNING ALL SETTINGS MAXED + AA X2 AND GETTING 30 FPS AVERAGE!!!!! PROBLEM SOLVED AND FORUM CLOSED!!!!!! THANKS FOR YOUR HELP!!!!!
  15. fantom-feltpen said:
    hey every 1, i just made a great discovery!!!! i went into task manager and closed all the processes i wasnt using, and now i get more like 20-28 fps!!!!!! much improved!!!!!!


    This would suggest either you've got to much crap running in the background, or your CPU & Memory aren't capable of keeping up with all that and Crysis.
  16. fantom-feltpen said:
    hey every 1, i just made a great discovery!!!! i went into task manager and closed all the processes i wasnt using, and now i get more like 20-28 fps!!!!!! much improved!!!!!!


    if you got that much of an increase, then you definitely need to look closely at what else you have running in the background. and yes, new drivers could increase performance by a fair margin.
  17. chris312 said:
    of course you have the SLI bridge on them, right? Umm...
    check the temps on your cpu? maybe it's throttling?
    what's the brand on the psu?
    do you have the right drivers installed correctly? did you uninstall the old ones fully?
    and..
    you don't have the cruddy 256mb 8800gt's right?
    That's all I've got. I hope you get it figured out...


    just so people know you dont really need to have the sli bridge installed, might reduce performance by a percent or two but the pci e bus has plenty of bandwidth for cards to communicate, some people even have problems with sli bridge so are forced to leave it off.
  18. stop downloading all that porn, and those random processes called pornsearchbar.sex won't slow you down. =D
Ask a new question

Read More

Graphics Cards SLI FPS Graphics