Sign in with
Sign up | Sign in
Your question

Maxtor Onetouch 4 won't connect

Last response: in Storage
Share
December 23, 2009 6:01:56 PM

I have a maxtor onetouch 4 and a few months ago my computer shut down unexpectedly and it became fraged. i didnt worry much about it but last night a breaker in my house blew and my computer was on that circuit. I have all of my electronics run through a surge protector but i dont think it works properly. when i turned my computer back on and windows loaded i opened "my computer" to go into my terabyte but the computer couldnt recognize the drive. the drive runs when plugged in and when i connect the usb cable the light in the front of my drive stays on but no auto play comes up or even a message saying that any hardware has been attached. i never wanted to format it because i have no where to back up what was on it but now i cant even access the drive if i did format it. i have tried plugging it into other computers and nothing happens. the drive turns on and the light stays on but no recognition. i have even tried installing maxtor lite software just to see if that might joge anything but no luck. im thinking it may be the power cord its self. any suggestions would help.
Anonymous
a b G Storage
May 9, 2010 9:15:19 PM

I am having the same problem, did you ever find out what the problem was?
a b G Storage
May 11, 2010 3:41:04 AM

you can try removing the drive form the enclosure and hooking it up directly to the computer
!