Sign in with
Sign up | Sign in
Your question

Hard drive locks my BIOS (can't boot off CD-ROM with HDD inside)

Last response: in Storage
Share
December 23, 2009 6:06:00 PM

Hey all, happy holidays!

I've got a real head-scratcher here.
I have a SeaGate Momentus laptop drive 2.5" ide that I put in my desktop, using a 2.5" > 3.5" ide adapter. This SeaGate is locked with a hard drive password (not a Master Password). But my desktop never prompts for me to enter the password. It simply displays this:

Quote:
Award Modular BIOS v4.51PG
Copyright (C) Award Software Inc.

Check system health !, VCore=2.00V
CPU ID: 0673 Patch: 000E
Memory Test: 131072k good

Award Plug and Play BIOS Extension v1.4A
Copyright (C) 1999 Award Software Inc.

Primary hard disk fail
Press F1 to continue, DEL for setup

[I press F1 at this point]
_________________________________
Next page:

Diskette drive A : none Display type : EGA/VGA
Diskette drive B : none Serial port(s) : 3F8 2F8
Pri. Master disk : none Parallel port (s) : 378
Pri. Slave disk : none Memory at Rows : 0 2
Sec. Master disk : none
Sec. Slave disk : none

Verifying DMI pool data..........
DISK BOOT ERROR, INSERT SYSTEM DISK AND PRESS ENTER
_

Notice that the BIOS doesn't detect my CD-ROM drive in the Secondary Master position? However if I turn off the PC, take the SeaGate drive out, reboot, then I can see the CD-ROM in this same list. And boot from CD with no problem!

But I can't install an OS with the drive unplugged, so I tried hot-plugging the hard drive. Still no luck, all that did was cause the PC to hang. :( 

A laptop exhibits the same behavior, but instead of a DISK BOOT ERROR, it simply hang after POST.... That's why I'm trying it on my desktop PC with an adapter I bought just for this experiment.

In summary:
The hard drive has a password, but neither of my computers prompt me to enter it. And I can't zero-fill either, because the BIOSes won't boot from CD-ROM with the drive inside.

Help me please! :sweat: 
December 23, 2009 8:54:03 PM

The hard drive is preventing the BIOS from seeing the IDE devices, that much should be obvious. Or maybe the drive is shorting out the other components in the PC?

Since the drive is locked, I read somewhere else that it has to be in Slave. I looked for a jumper, but there wasn't one, so I tried jumping the pins with a flat head screwdriver, the same "DISK BOOT ERROR" came up. Then I tried making my own jumper out of copper wire bent in a loop shape, but no luck with that either.

This shouldn't be so hard, if it would just boot and ask for the password, then I could disable the password, and avoid ever having this problem repeat itself. In the old IBM Thinkpad that this SeaGate drive was in, that's how it booted: Asking for the password. But now that the IBM's dead, I guess I'm stuck with a useless hard drive.

I can't use ATAPWD to disable it, because the darn CD won't load with the drive inside any machine. Again, hot-swapping doesn't help.

Gaah! :cry:  Any suggestions people?
m
0
l
January 13, 2010 6:55:49 PM

I did a lot of research on this, and it seems IBM Thinkpads, or at least IBM Thinkpads with a "Supervisor password" will automatically lock any hard drive that is placed inside. And according to some people, the only way to unlock is with the original IBM thinkpad. (Mine has a dead mobo :(  ) Other people think a zero-fill will unlock it, and still other people say firmware update is worth a try.

I'm close to giving up, because, the only progress I've made, is that after several hot-swaps, I got the hard drive to be recognized in a Dell C600 laptop, using a boot CD for SeaTools for DOS (A Seagate drive utility program).

It's exciting, because I'm finally able to boot any CD with the drive inside, but it won't show in the Dell BIOS without a hot-swap. However, the SeaTools program hangs when attemping to access the drive... so it's not much help.
m
0
l
Related resources
!