Sign in with
Sign up | Sign in
Your question

mouse disconnect/reconnecting on it's own

Tags:
  • Mice
  • Connection
  • Components
Last response: in Components
Share
October 10, 2008 8:07:03 AM

I have an intellimouse explorer 3.0 that's only about 2 months old and already doing what my last 3 MX-518's have done. At random, it will disconnect (laser turns off, plays XP hardware disconnect audio) and stop working, and sometimes reconnect itself a moment later. Sometimes I need to replug it into the USB to fix it and sometimes I just need to walk away and come back later or switch mice.

It's really driving me crazy. My first logitech MX-518 lasted me 5-6 years and I loved it. When it went out, a friend who had switched mice sent me his used MX-518 which had been working perfectly at the time. A few months went by and it started doing the same thing as my other one. I bought a brand new one, which lasted nearly a year before doing the same. I tried replacing this one with a microsoft intellimouse which has lasted the shortest of all of them.

Before anyone asks, YES I have tested ALL of these mice with other computers and it is most definitely the mice that are problemed and not my computer (unless my computer is somehow damaging them).

I originally thought this was a problem with the wiring becoming damaged but it should be noted that the problem still occurs frequently even when my hand is off the mouse, when it is not moving at all it will still turn off and on by itself. You would think if it were a loose wire that moving it could cause it to disconnect and you would have to fiddle with it to have it reconnect, but no it manages to do both on it's own. I think something else is going on here and I'd love to know what it is and how to fix my 4 broken mice or how to prevent the same problem from affecting all the mice I use in the future.

thanks to anyone able to help.

More about : mouse disconnect reconnecting

October 10, 2008 11:46:58 AM

Could be that the connectors have lost their "spring". Had the same sort of thing happening to an old PC on the front USB's. Bit of small screwdriver waggling sorted that out for awhile but they was never the same. I think they got tramatised by the probeing.
October 10, 2008 12:30:32 PM

Almost the same problem optical usb mouse doesn't seems to work at startup but after i unplug it and insert it, it works. Any ps2 seems to work. Any suggestions btw i test all ten ports still the same problem.
Related resources
October 19, 2008 10:55:18 AM

How about 2.4Ghz interference? That seems to be a problem with other Logitech mice.
October 20, 2008 12:51:26 PM

What about 2.4Ghz? I got an e6600 running at 2,4Ghz and have the same problem as the author to this thread. What am I to do? Overclock my computer? I'm not sure how that is done.
October 22, 2008 7:52:44 AM

I put non-conducting on the 15 cm cord entering the mouse itself, and it has worked allright since I did it one day ago. I keep my fingers crossed know and hope that it won't come back.
October 22, 2008 7:55:53 AM

non conducting tape that is... usually the disconnecting/connecting thing, would have come back by now, but it hasn't yet. I got an explorer 3.0 too btw.
October 22, 2008 9:07:41 AM

it came back :( 
October 23, 2008 4:25:58 PM

I bought a new mouse, been using it for an hour without any problems. This time it WILL work :) 
October 24, 2008 12:41:59 AM

I used to have HEAPS of problems with my logitech MX5000 combo, dropping out, running slow pain in the neck... Then i realised it only played up when the microwave was running LOL moved the PC further away voila hehe
October 25, 2008 11:52:43 PM

My new mouse has worked a couple of days now without any problems. I'll keep u updated ;) 
January 8, 2014 9:37:28 AM

I had the same problem where my mouse and keyboard which were connected to USB ports rather than PS2 port use to disconnect frequently for 6-7 seconds and then reconnect.(for over 4 months) and i lost all hope. In my case power was coming from Power socket to UPS, which was further supplying to SMPS. I read all similar forums and utilized every trick which i can deploy like changing power settings, disabling gestures, updating drivers, changing OS, new mouse/keyboard etc...
Finally i changed SMPS, it did gave some hope for 1-2 days, But still issue not resolved. Suddenly an idea came to my mind of placing VOLTAGE STABILIZER to this whole unit....What i did: Placed Voltage Stabilizer in between UPS and Power socket. and of my surprise Issue got resolved. And it's been 2 months i haven't faced that issue and really happy to share the solution which could be applied by many users.
!