Sign in with
Sign up | Sign in
Your question

Weird lag in ATI Radeon HD 3850 (Sapphire) AGP8x

Last response: in Graphics & Displays
Share
August 25, 2008 12:16:54 AM

Whenever I play counter-strike based games, (cs1.6, cz, cs:s) I get this weird mouse lag and movement lag, whereas the mouse will glitch and not work when I'm trying to aim, and for the movement lag it seems to stick when I'm not sticking it. The card works great I run COD4 on pretty high specs and it runs smooth and fine but when I try to play counter strike it just aggravates me.. Any suggestions


To add to that it is a 512mb gddr3 memory AGP-8X based card, my v-sync is set to off, and I'm also currently having issues trying to find new drivers other then the ones that came w/ it on CD, I've never had any lag like this before, anything that anyone could contribute would be greatly appreciated thanks.
August 25, 2008 2:57:33 AM

did you try in direct3D mode?
August 25, 2008 3:04:35 AM

No I haven't I'll go try it now, btw I was wrong about vsync it's always off but I don't seem to lag at all when i have my fps set at 60 instead of 100, let me try it, thanks
Related resources
August 25, 2008 3:07:38 AM

I just tried it and with D3D mode I get like 80-95 fps and the same mouse lag and movement lag as before
August 25, 2008 12:00:27 PM

New problem: (same card) The drivers I've installed were from the cd but only half the time when i start up windows will it catalyst control center be in the toolbar and let me actually run the ccc... I've tried different drivers but all say the same thing: that it can't find the hardware or operating system and must shut down.

Also still the same problem as before but I have yet to see it if my fps is set to 60 and not 100.
August 25, 2008 1:49:04 PM

plAstyk said:
New problem: (same card) The drivers I've installed were from the cd but only half the time when i start up windows will it catalyst control center be in the toolbar and let me actually run the ccc... I've tried different drivers but all say the same thing: that it can't find the hardware or operating system and must shut down.

Also still the same problem as before but I have yet to see it if my fps is set to 60 and not 100.


i've tried this before -> I've tried different drivers but all say the same thing: that it can't find the hardware or operating system and must shut down.

this is with uninstalling the original thats on the discs.
August 26, 2008 6:34:06 PM

To add to that it also does it when theres 30+ people and my fps is set to 60, only problem i've occured w/ 60fps. Someone please help !
August 29, 2008 2:23:24 PM

bump
September 2, 2008 4:44:59 PM

bump
September 2, 2008 5:19:58 PM

What is the exact model of your card?
September 3, 2008 9:16:09 AM

FK NOOBS IT IS THE AGP VERSION TO GET LATEST DRIVERS FROM AGP GO HERE http://support.ati.com/ics/support/default.asp?deptID=8... FROM LEFT PANEL CLICK "Radeon Support - PC/Radeon HD 3850/Knowledge base/Gaming/Catalyst AGP Hotfix - Radeon HD 3000 and Radeon HD 2000 Series AGP products
" AND FOR MOUSE DOWNLOAD THE LATEST DRIVER FOR YOUR MOUSE OR CONFIGURE FROM WINDOWS. NOoOBS
!