Sign in with
Sign up | Sign in
Your question

Sapphire 4870 issues - no display

Tags:
  • Radeon
  • Sapphire
  • Graphics
  • Displays
Last response: in Graphics & Displays
Share
August 28, 2008 4:56:05 PM

I bought a shiny new 512MB Sapphire HD4870 to replace my (slightly) aging 8800GTS 320MB, and I can't get it to display anything. What's worse is that I can't get it display anything even after reinserting the 8800.

Here's what I've done:
- Removed 8800GTS
- Put in 4870, including 2 6-pin power cables coming direct from PSU
- No display from either output - tried a combination of naked DVI and DVI->D-Sub adapters, and different ports on two different monitors, both of which I know work
- Tried taking power from molex power connectors instead, using molex->PCI-E adaptors that came with the 4870 - no display
- Removed 4870, reinserted 8800GTS, plugged in original PCI-E power connector direct from PSU, as it was before - no display
- Detached or removed all components (HDs, DVD-RW, sound card, USB connector, RAM, extra 6-pin PCI-E power connector) - still no display
- Tried removing CMOS battery for several minutes (to reset CPU OC from before) - still no display


Specs:
Antec Neo 550W PSU
Core 2 Duo E6400 CPU (w/ Thermalright Ultra-120 Extreme)
Gigabyte 965P-DS3 MoBo
OCZ Platinum 6400 EL XTC R2 DDR2 2x1GB RAM
Audigy Xtremegamer sound card


When I turn the machine on with the 4870 connected, three lights come on. From extensive Googling, this appears to be normal.

It's bizarre that the 8800 is failing to work now. My guess, based on the fact that all the fans come on (3*Antec TriCool, 1 OEM fan on the Ultra-120, plus the ones on the gfx cards), is that I've screwed up the motherboard somehow. What do you folks think?

Any help is much appreciated!

More about : sapphire 4870 issues display

August 28, 2008 6:08:30 PM

Are those three lights on your card cause if they thats not good. I built a system recently with a sapphire 4870 and when I first started it up the card showed three lights and nothing showed on the screen. I actually had some cables wrong but when I fixed it still had one light on, so I returned it and the new one works great. So you might have a DOA card, but I have no idea why your 8800 doesn't work now.
August 29, 2008 12:24:19 AM

The three (red) lights on the 4870 only flash momentarily - from what I've read, this is some sort of standard self-test, and nothing to worry about.

But yeah, if the card is DOA, is it possible it could freak out my motherboard and cause the PCI-E slot to die? Or is there something else going on?

Thanks for your help :) 
Related resources
August 29, 2008 2:47:44 AM

Ohh thats good about the lights. I don't think a DOA card could cause the PCI-E slot to die, at least it didn't for me....but I'm not really sure. Also, just a random thought....maybe your PSU is alittle weak. I'm not very experienced but I'll try to help.

Good luck ;) 
August 29, 2008 2:35:44 PM

Did you uninstall the old drivers?
August 29, 2008 2:39:32 PM

Shadow of Dawn: the PSU should be fine for a single 4870. I've tried disconnecting all other devices and it still doesn't work. Also, the 8800 worked before but doesn't now, so unless the PSU has weakened between removing and then reinserting the 8800, I don't think that's the issue. Cheers for your help, though!

Gamerk316: Yep, I uninstalled them and then used Driver Cleaner in Safe Mode. That said, I'm not even getting a display during POST/BIOS, so the drivers can't be the issue. Thanks for the suggestion :) 
August 30, 2008 11:25:23 AM

Some updates:
- I know the 4870 works (tried it in another box).
- I tried an old-school PCI video card (which I also know is functional) in it and that didn't work either - same symptoms.
- I found a PC speaker (which I also know is functional) and attached that to the mobo, and I can't get any beeps out of it.
- I went out and bought a Gigabyte EP45-DS3, installed the CPU, plugged in the motherboard power, CPU power, CPU cooler power, 1 stick of RAM and the 4870 - and it still doesn't work, but in an interesting new way: it powers on for around 10 seconds, then it turns off for a few, then in turns on for 10 or so seconds, etc. At no stage do I get video output.
- Stuffed around with different RAM sticks, different slots, different graphics card. Same symptom as above.

I'm thinking I might try with a different PSU.

Any other ideas?
August 30, 2008 4:02:18 PM

I think trying a different PSU is a good idea, idk what else the problem could be.
September 1, 2008 1:52:55 AM

Yup, tried a different PSU - same deal.

The only components I haven't substituted are the CPU and the case.

I've bitten the bullet and taken it in for repairs at the place where I bought the new MoBo. I'll post again when I get it back, and when I have an explanation of WTF is wrong.

Thanks to all who offered their advice, particularly Shadow of Dawn! :) 
September 2, 2008 2:08:30 AM

Huh?!?! thats really weird hopefully they can fix it without too much trouble, and def post what was wrong I want to know.

Ohh, and I don't think I really helped that much.
September 2, 2008 2:42:26 AM

So it turns out that I'm an incompetent #&*%wad, and I mustn't have tested the RAM properly, because the shop said the memory was faulty. I thought I tested both sticks in a variety of slots, but either I didn't do it thoroughly enough or both sticks of RAM died simultaneously...

So now I'm sitting on 4GB of OCZ Reaper 8500 :) 

Thanks again for the help!
!