Sign in with
Sign up | Sign in
Your question
Solved

How to Auto-Login to server in a network

Last response: in Windows XP
Share
January 4, 2011 2:50:52 AM

There's a server in my local network, using Win Server 2003.
The problem is: Some users can (able) to auto-log in to server without typing username and passwords, while some users, must keep entering username and password each time they turn on their computer, or restarts.

How to set these users so they can behave just like auto-log in without having to type and type again username and password in each computer session?

I have tried this step:
1. Click start menu and choose run command:
type control userpasswords2
2. Choose the username that you want to auto login and then uncheck the user must enter a user name and password and then apply.
3. Fill the user name's password and the click ok and ok again to close the user account windows.
4. Try restarting your computer and you will see the computer will auto log on to your network now.
..from http://talk.thewebhostingdir.com/h [...] vices.html

But it unchecks the "user must enter a user name and password", so it disables all password verification, doesn't it?
Not that that I want. My computer is one of those who are able to auto-log in without that box unchecked.

More about : auto login server network

January 4, 2011 2:52:02 AM

I posted same thread in Networking -> LAN/WAN section. Please delete that thread. I think it's more appropriate to be posted here. Sorry.
m
0
l
January 4, 2011 1:57:22 PM

Explain your setup, is this a domain? Are the users using domain usernames or local? When you say "logon to the server" do you mean connect to the shares on it, or to a terminal session? How are your user groups setup? Are all these users in the same groups? How is the security on the server share/logon done, groups, users, what?

With the info you posted there can be any of dozens of things causing your issue.
m
0
l
Related resources
January 5, 2011 12:51:07 AM

Domain? I don't quite much into it, but the users are on the same workgroup and it is local, simply connected each other using switch. Yes, these users are in the same workgroup, if that's what you mean with group. The server is just a PC with shared folders to it and using Win Server 2003.

Just simple network with same workgroup name, each user can connect each other to that local area network using same workgroup name. What is user group setup? The problem is just some computers can auto-log to server, while some the rest cannot auto-log and need to keep entering username&passwd. I have checked "Remember me" option but it still keeps asking for it.
m
0
l
January 5, 2011 6:56:13 PM

If it's simple sharing, then just make sure the username/password on the server is the same as the username/password on client machine, then it won't ask for a username/password.
m
0
l
January 6, 2011 7:28:02 AM

The computer is not password-protected. There's a username, but not passworded. But it still...

My computer is also not password-protected. There's a username, but not passworded. But it doesn't ask for username & password.
m
0
l
January 6, 2011 10:37:01 AM

That's weird. You normally need to use a username/password combination. The server will not accept remote connections without a password unless you've modified the security policy, in which case the username on each machine must be identical.
m
0
l
January 6, 2011 1:04:08 PM

Situations like this is why you want to use a domain and not a workgroup. How many computers and users are in the environment? Are all the computers aside from the server the same OS? Are all the computers logging on to the same user when the computers start? What users/groups are setup for the share rights on the server? Need to check all that and make sure whatever user is being used on the PCs is setup with the rights on the server share. Are all the users connecting to the same share? How was the share mapped or connected? You can setup connections using a different user/password than the one logged on to the PC, maybe that was done in some of the cases. Try to delete and reconnect the shares on the computers with issues.
m
0
l
January 7, 2011 12:31:37 AM

hang-the-9 said:
Situations like this is why you want to use a domain and not a workgroup. How many computers and users are in the environment? Are all the computers aside from the server the same OS? Are all the computers logging on to the same user when the computers start? What users/groups are setup for the share rights on the server? Need to check all that and make sure whatever user is being used on the PCs is setup with the rights on the server share. Are all the users connecting to the same share? How was the share mapped or connected? You can setup connections using a different user/password than the one logged on to the PC, maybe that was done in some of the cases. Try to delete and reconnect the shares on the computers with issues.

Um, 10 computers 10 users. The same OS, all of them XP SP2. Uh, they have their own user account on their computer, but all of us are not password-protected. So in Welcome screen, just click on a user name, then it enters, no passwd. And all of us there are only one user account, the default admin account. We log in using default Admin account (pretty nifty, huh?) with no password. :pt1cable: 
anyway.. on the server, how do I see that? -> "setup users/groups setup for the share rights".


All users are connecting each other, by normal share (Windows recognition in "My Network Places" ), not 'forced' share like using command line in MS-DOS (I what forgot the command). So to share a folder just right-click -> Sharing and Security -> check "Share this folder on the network" -> c.OK.


anyway, the problem happens because I reinstalled the fresh, clean install Windows XP SP2 on those computers. What is domain? How do I do that? Do you mean I must use a domain?
m
0
l
January 7, 2011 3:23:27 PM

If you logon with no password, does the server let you in if you just re-type the administrtator account name and click OK?

For 10 users you are a bit at the limit for using a workgroup as far as managing rights easily, but it's doable. If you check the share on the server, what users and groups are shown in the Share and File rights?
m
0
l
January 14, 2011 2:53:40 AM

The server has name for its account and its password to log in, and it's not administrator's account. So if we type administrator's account and leave the password blank and click OK, we won't log in to the server.

If I checked share to a folder, I'm using XP, not Win 7 or Vista, so there's no 'Run as Administrator' and the button beside it (Compatibility tab, I think).

If I checked share to a folder, the box below it "Share Name" becomes available. Also, there's a checkbox "Allow users to change my files". That's all.
m
0
l
January 14, 2011 12:50:47 PM

andrern2000 said:
The server has name for its account and its password to log in, and it's not administrator's account. So if we type administrator's account and leave the password blank and click OK, we won't log in to the server.

If I checked share to a folder, I'm using XP, not Win 7 or Vista, so there's no 'Run as Administrator' and the button beside it (Compatibility tab, I think).

If I checked share to a folder, the box below it "Share Name" becomes available. Also, there's a checkbox "Allow users to change my files". That's all.


You need to check the shares on the server, not on the computer. Each XP machine will logon as a user, which is a local account in your case. The file and share rights on the server shares need to have those users in the permissions. If that is not the case, you will be promted for the access rights.

Try this, setup a group on the server called whatever you want. Add "Everyone" to that group. Then give that group rights to the files and shares on a test folder. Can everyone access that with no issues? If that is the case, you now know that the share and network is working OK. Since having Everyone in permissions is a bit of a security hole, you now need to setup this group you created with the proper user accounts for your environment.
m
0
l
January 17, 2011 12:02:40 AM

hang-the-9 said:
You need to check the shares on the server, not on the computer. Each XP machine will logon as a user, which is a local account in your case. The file and share rights on the server shares need to have those users in the permissions. If that is not the case, you will be promted for the access rights.

Ok, I just need to find a way to do just that.
hang-the-9 said:
Try this, setup a group on the server called whatever you want. Add "Everyone" to that group. Then give that group rights to the files and shares on a test folder. Can everyone access that with no issues? If that is the case, you now know that the share and network is working OK. Since having Everyone in permissions is a bit of a security hole, you now need to setup this group you created with the proper user accounts for your environment.

So are you suggesting using Active Directory?
m
0
l

Best solution

January 17, 2011 12:34:09 PM

andrern2000 said:
Ok, I just need to find a way to do just that.

So are you suggesting using Active Directory?


AD is the best way to handle users and group rights, but with only 10 users, unless you see this going up in the future, it may be more hassle to setup than to deal with the workgroup.
Share
January 21, 2011 6:20:02 AM

Best answer selected by andrern2000.
m
0
l
!