Sign in with
Sign up | Sign in
Your question

Problem with drivers for 4850 on Vista x64

Last response: in Graphics & Displays
Share
September 2, 2008 1:17:14 PM

Okay, I just got all the parts for my new computer a couple weeks ago. Put it together, had to wait on my copy of windows, got it last week and installed with no problem. I have installed all of the drivers that came with my Mobo (network card, sound, etc.) and have fully updated windows. Computer is connected to 19" LCD Tv via HDMI cable. I can boot into windows perfectly fine, it uses default VGA driver or something and shows at 800x600.

Now the problem: Everytime I install a driver for my 4850, I reboot the computer, the BIOS does its POST thing and then shows windows loading screen (with the little green bar at the bottom) after loading for about the usual amount of time the screen goes blank, but instead of bringing up login page, it stays blank.(I have noticed small colored lines across the screen a few times, but only for a fraction of a second, then stays black)

After this happens I have to boot into safe mode, and use system restore to go back to before I put the driver on.

My card has two DVI ports on the back, I have tried both to make sure I'm not using the wrong one. I have tried multiple drivers, all have exactly the same problem. The drivers I have tried are:

1.My 4850's driver disk (not sure which version) (includes CCC)
2.Windows Update installed a 4800 series driver, had same issue as others
3.Second newest driver from ASUS's website (includes CCC)
4.Newest driver from ASUS's website (includes CCC)
5.Newest driver from ATI/AMD's website (W/out CCC)

I made sure the ones I downloaded are all the Vista x64 versions, and they all seem to install correctly, then tell me to restart, then have the issue I explained above.

I am at this point clueless as to what the problem could be, any help is much appreciated!

My build:
ASUS P5Q PRO - Mobo
Intel E8400 - Proc
ASUS EAH4850 - Video
PCP&C 610W - Power Supply
Corsair 2x2GB DDR2 800 - RAM
WD Caviar 640GB - HDD

If you need any more info,
this is the full list of parts I used.
September 4, 2008 7:32:56 PM

Make sure you installed Vista Service Pack 1 and should install all updates. I have my card running in Vista x64 w no troubles.
September 7, 2008 3:19:12 AM

I have the exact same problem too! I am using PowerColor HD4850 PCS+ with Windows Vista Home Premium x64. My CPU is Intel E8500 and mobo is Gigabyte EP45-DS3.

Like you, I tried the driver on the CD that came with the graphic card, the latest driver on ATI's website, the previous version driver on ATI's website, and even the driver downloaded automatically through windows update.

Each time, the driver was installed successfully, but after restarting, the computer will not start and goes into an infinite loop of starting and shutting down. Only by booting in safe mode and doing a system restore to the state before the driver was installed, does the problem go away.
Related resources
September 7, 2008 5:56:32 AM

Download the drivers and CCC seperate. Install the drivers first to see if it boots. If it does then install CCC. I had a bunch of problems like you guys. I just built a Vista 64 and w 4850 cards 2 days ago. I downloaded the complete thing and the drivers where messed up. I installed them seperate, and things are fine.
September 7, 2008 6:27:32 AM

Sometimes also, try booting twiceor more if you can, without reinstalling again. Ive heard that sometimes happens and vista will take the drivers the second time around
September 23, 2008 2:54:14 PM

i have the same problem with a visiontek 4870 vista x64 and an asus p5n-e sli mobo. there is a 9 page forum article detailing everyones problems relating to this on the amd/ati website, with no answer in sight from amd. i tried all i could to get mine to work, but with no luck. i'll be returning my new card. first video card i've ever had to return.

just google vista 4870 black screen on startup and it will come up as first or second entry.

sorry to offer no help, but this is what i found.
September 24, 2008 2:58:47 AM

Weird I'm running home premium x64 with an asus 4850 and I haven't had any problems. Did you overclock your computer at all? If so try at the default settings. Is your ram running at the correct voltage? Is the power suply connected to the card? I dunno, maybe try going to the device manager and seeing if there isn't an odd component not installed. I've heard of people having problems with their optical drives causing conflicts. Maybe try disconnecting them.

Hope something there helps.
October 2, 2008 6:30:25 PM

While helping my neighbor build a system, I recently experienced the same issue. The resolution would only go to 1024x768 and the video card had a yellow "!" next to it in the device manager. Also, when you look up the details on the card, it would say <Unknown>. If you tried to uninstall/reinstall the driver, it would not update and would keep doing the same thing. Also, nothing that required D3D would run. Turns out, the ATi Catalyst Update that Windows Vista installed in an auto-update hosed the whole thing.

I fixed it by doing the following:

1) Use Driver Sweeper 1.5.5 (got it from guru3d.com) in safe mode to clean out all ATi drivers (or something similar).
2) Reboot the machine
3) Do a System Restore to the earliest point you can. If it's a new system build, then go to the first restore point.
4) Once the restore is done, re-install the ATi Drivers
5) Set the computer so that it DOES NOT automatically install Windows Updates.
6) Check for Updates, Un-check the ATi Catalyst Update, then right click that update and chose "Hide" so that you don't see it anymore.
7) Done. Should be working fine now and you should have no more problems.

If your system isn't a new build, or you don't have a restore point to go to, you could try to un-install that ATi Update that Windows installed and use some driver cleaning software to remove all traces of the driver. Then install a fresh driver... not sure if this will work or not because the System Restore method worked for me.

Good Luck!
January 15, 2009 7:12:59 AM

Hi there,

I came across your problem on google because I was experiencing pretty much an identical problem as yours -- P5Q SE Plus, asus 4850, vista 64-bit, installed driver after driver without anything working.

I did two things, and I'm not sure which one worked, but now things are working and I feel extremely relieved.

1. I updated the bios on my motherboard. It was easy to do using the EZ-Flash 2 utility that came with it. I followed the tutorial here: http://vip.asus.com/forum/view.aspx?id=2007021522310966...

2. after I updated my bios, I still had the same problem -- the screen would black out after getting the "starting windows" screen. I was frustrated, and decided to try a different monitor. But as I was loosening the DVI cable connected to the original monitor, the screen *poof* magically came up. My theory here is that my monitor just wasn't getting a strong enough DVI signal, and my fiddling with the cable actually got it to work.

Hope this helps you, and good luck if it doesn't!
!