Sign in with
Sign up | Sign in
Your question

Problem with PowerColor HD 4850 512mb

Last response: in Graphics & Displays
Share
September 3, 2008 10:25:15 PM

I Got my new graphics card yesterday, i used to have an 8600GTS installed. I have already removed Nvidia drivers an removed old card which i replaced with the 4850 card. I get to my desktop and it detects new hardware and asks me to install new drivers. So i do with the drivers disk. once i installed ATI drivers and CCC programs etc. i restart my computer. My computer boots up and then starts loading XP. This is where it goes wrong During when XP loads after about 10 seconds the screen goes blank and a message appears on screen saying that the monitor has lost signal and goes into standby mode. My computer sounds normal and everything and its all still working like it was before the screen went blank. Ive checked inside to make sure its all connected properly and ive went into safe mode and uninstalled the drivers and downloaded drivers from the catalyst website. The problem still happens with these drivers. Can anyone Help me? Ive tried everything deleted everything Nvidia related erm.. installed one driver at a time by restarting and installing the next bit. Still no luck :(  If anyone can help id be Most greatful!

My specs are in my sig but if u carnt see my sig its,

AMD 6000+
M2N-E mobo
EZCool 600W PSU
Corsair 2GB XMs2
PowerCHD 4850 (obvs)
DVDRW

Notes:

This is my First Graphic card upgrade
The New Hardware detected message carnt find software or read the disk. I have to manually click on disk drive or let the disk automaticly run. I did get it to search Disk drive etc. still not working also the message doesnt like to leave me alone lol. unless i Click cancal three times.
September 3, 2008 10:41:50 PM

i wonder if maybe the card isnt getting enough power?
September 3, 2008 10:47:49 PM

Well on the requirments it says 450w for a single card and 600w fo Xfire. It does display a picture the problem only occurs when i install the drivers really. Nothing else my brothers convinced its a software issue i dont know. I made sure the power supply is properly connected and everything. Still nothing :S thanx tho anyway
Related resources
September 3, 2008 10:51:23 PM

i apologize in advance but i have to ask, are you sure you are installing the right drivers? For example getting the windows 32 bit drivers instead of the 64 bit ones?
September 3, 2008 10:54:52 PM

it may actually be the psu. i've never even heard of EZCool, and from what i found on google, it doesn't sound like the best psu brand you've ever seen. it may not be delivering as many watts as it says it is.
September 3, 2008 10:57:07 PM

Yeh i am i opened up the Disk and made sure it was under Xp 32bit and the problem Still happens. i have downloaded some drivers from the catalyst website. the latest ones 8.8 and it still happens. Im thinking this is a Software conflict but i dont know how to deal with that kinda problem since this is my first time so i thought id put up a forum in a place i know experienced users go to talk this off. Im doing what i can to avoid phoning technical support lol
September 3, 2008 11:00:28 PM

I dont know what would be causing that :( 

One solution to your problem would be to just do a clean install of xp on your computer (im not sure if that is something you are interested in doing or not). If it worked after a clean install then it would most certainly a software issue, if it still wasn't working then it would have to be a hardware issue (maybe it isn't getting enough power like nik_I sugested)
September 3, 2008 11:05:42 PM

Does it not matter whether its 600w or 1000w does it depend on what kinda of PSU it is really? cuase its requirments does say 450w single card 550w crossfire?:S i do really want to aviod buying a PSU intil im 100% its that becuase it could be a defect product or it could be just the software. I do also really want to aviod Re-formating my hardrive and cleaning it all of to reinstall xp again. Ive had so much probs doing that in past. I would rather sit down with sumone and go through it bit by bit to get it solved. I dougt sumone would actually do that but mabe sum tips of what i could do software wise or things i can perform to get it solved will be helpful. Things like swipe comp software and buy a PSU are last resorts lol.
September 3, 2008 11:33:55 PM

Again sorry to ask but you have to start with the basics. How did you go about removing the old nvidia drivers?
a b U Graphics card
September 3, 2008 11:44:02 PM

Do you have .Net installed? Pior to your driver installation?
September 4, 2008 12:16:44 AM

Hi again guys I have Fixed the issue i had found out that i delted the Nvidia Chipset drivers and LAN drivewrs This disabled proper function of my PCI slot. Make sure u tell anyone who installed an ATI card on an NVIDA board NOT to Delete Nvidia Chipset drivers or LAN drivers only the Display Drivers. To aviod an unstable computer. Thanx everyone for the help :D !!!
September 4, 2008 12:24:36 AM

lol :D  yes the easy way to get rid of the necessary drivers is just uninstalling them from the device manager under display adapters

Congrats on fixing the issue and hope the new card works out well for you
!