Ext. HDD not detected on System startup

Strange problem here. I have two external USB drives, Seagate FreeagentPro 750 gb and Fujitsu MHW2160BH 150 gb. Seagate works properly for over a year, now i decided to plug Fujitsu (used it before i bought Seagate, and it also worked perfectly). Now the problem: If Seagate is plugged in, Fujitsu drive is not detected on system startup. If after System is booted you unplug Fujitsu and plug again, it is detected (btw, sometimes it says "device can work faster" and it is really even slower than flash). I tried to plug both in front usb ports, back usb ports, one in front and one in back... The result is the same. Both HDDs use their own power suppliers, electricity works ok here.

OS: Windows 7 x32 (well, i had the same on x64), i have latest BIOS version.
2 answers Last reply
More about detected system startup
  1. Sounds like the startup issue could be a bios setting and or a limitation of the usb chipset. If this is a desktop computer, do you have a usb card you can throw in? Might solve your issue by having one one in the motherboard i/o ports and one on the usb pci card you added. See if there is an updated chipset driver for the motherboard, this also could solve it.
  2. I had similar problems, and fixed it with a cheapo $10 USB 2.0 card.
Ask a new question

Read More

Hard Drives Fujitsu Seagate Storage