Sign in with
Sign up | Sign in
Your question

P43Twins1600 new build won't boot, plz help

Last response: in Systems
Share
August 11, 2008 2:58:08 AM

I recently won an ASRock P43Twins1600 mobo and tried to build my first homebuilt system with it.
Naturally it won't boot. Fans spin, lights are lit, but no post and no video signal. I tried clearing CMOS and even replaced with a new CMOS battery. No joy. I'm sure there must be some incompatible part that I'm too ignorant to figure out...

New Parts:
Case: Rosewill R5601-BK
CPU: Intel Core 2 Quad Q6600 Kentsfield 2.4GHz
Power: RAIDMAX VOLCANO RX-630A 630W
RAM: CORSAIR DOMINATOR 2GB 240-Pin DDR2 SDRAM 1066 (PC2 8500)
Video Card: SAPPHIRE 100242L Radeon HD 4850 512MB 256-bit GDDR3 PCI Express 2.0 x16

Any help would be greatly appreciated.
August 11, 2008 3:14:16 AM

Have you tried using another set of RAM
August 11, 2008 3:14:51 AM

Did you plug the 4/8 pin 12v ATX Cpu power connector in.

Most likely you didn't.
Related resources
August 11, 2008 12:06:27 PM

rctycoon: Unfortunately, I don't have any extras to try on this board. My previous system is AMD with AGP video. I think my next step is probably to get other RAM and another Video Card to try from Newegg. Of course, that means I'll probably be paying restocking fees to send stuff back, which sucks. The specs for the mobo are not very specific as to what RAM is compatible; no specific voltages are listed or anything and they don't have a compatibility list available. I'm waiting to get some sort of reply from ASRock with some help for this, but thought I'd try here too.

roadrunner197069: Its a 4 pin and yes, I did plug it in. Thanks anyway...
August 11, 2008 12:47:18 PM

It could be any number of things. You RAM could need a voltage setting in the BIOS other than the default.

Your PSU could be bad.

It could simply be a bad connection somewhere, or perhaps the back of the board is making contact somplace it shouldn't.

Did you try with just one stick of RAM to start?

Did you confirm the jumpers are placed correctly for your CPU FSB requirement?

Connect a small speaker to the "chassis speaker header" on your MB, and you should be able to hear error beeps which may tell you what is wrong.

Also: The manual looks fine to me :) 

http://download.asrock.com/manual/P43Twins1600.pdf
August 11, 2008 12:52:46 PM

Do you have the case speaker hooked up?
If so, is it giving any beep codes?

For a quick start, triple check all power connections.
Remove and reseat your video card.
Make sure your RAM, CPU and CPU fan are properly mounted.
If you can beg/borrow/steal another set of standard DDR2 800 RAM and a known good PSU, do it.
Many motherboards still have compatibility issues with DDR2 1066 and higher RAM.
RaidMax is not a very good quality PSU manufacturer.
There is always a chance you got one of their defects.

Anyways, check these.
Hopefully it is something simple.
If not, post back and we can try to help you some more.
August 11, 2008 12:54:10 PM

Borrow a friends single ddr2 dimm, that runs at 1.8v, and try boot with that. Then if that works set the ram voltage @ 2.1v. Save. Put in your ram and try again
August 11, 2008 2:15:14 PM

Thanks for all the advice!

-Case Speaker is connected and there are no beeps.

-I am using only one stick of RAM (I got a dual kit, but I figured I should try to get things running with only one first...). Unfortunately I don't know anyone who has DDR2 RAM that I could borrow. I thought about getting some DDR2 1066 at 1.8v from Newegg to try, if it worked I would return the Corsair RAM. Should I give up on 1066 and get DDR2 800 instead? (Not my first preference but I'm willing to take advice...). I did carefully check the mobo manual and, as I said, it doesn't reference any voltage requirements. Also, their website is sadly devoid of any compatibility list for RAM. I do plan to ask ASRock about it whenever they get back to me. Their response time has been good so far regarding delivery issues, but they are in an earlier time zone and I haven't heard from them yet this morning about the no boot issue.

-I read some review sites on the Raidmax PSU that said it was a good model and 630 watts seemed sufficient to run the new setup. Everything does seem to be getting power. Also, I used the Raidmax in my previous system for a few months with no issues.

-I have tried removing and reseating EVERYTHING, including the CPU (so I could visually check the socket which looks fine, no pins out of place...). I did clean and reapply the Arctic Silver and the stock cooler actually went on easier the second time. I'm pretty confident about the current seating of everything (Video Card, RAM, CPU).

-Proximon:
Regarding the FSB jumpers, they are set to default. The wording in the manual seemed to imply that they would only need to be changed if trying to overclock, which I'm not. FSB for my CPU is 1066. I'm afraid to tamper with the jumpers without knowing what I'm doing. Is there a danger of damaging the CPU if I set the jumpers to "overclock" to 1066 and I'm not actually overclocking anything? I will definitely try it if there's no danger to the CPU. This is something I will be adding to the list to ask ASRock, so thanks for mentioning it!

August 11, 2008 2:51:59 PM

Naw I'm sure they are fine then. Sometimes MB makers mess up and put jumpers in wrong, so I wanted you to check.

Sometimes sites with less technical expertise than they should have get ahold of PSUs and feel obligated to review them. They put multi-meters on the connectors and think they have tested. It takes some pretty good equipment to do it right.

However, if your PSU was working at least good enough to drive your old PC, I doubt it's gone bad. Or badder or something.

Take off all the memory and the GPU. Just leave the CPU. Do you still get no beeps?
August 11, 2008 5:30:30 PM

Proximon:

Good idea, thanks.
But, still no beeps after removing RAM and GPU. Oh well, looks like a dead board. Hopefully ASRock will replace it.
If not, any suggestions of mobos that will be able to use the new parts I got?
August 11, 2008 11:14:44 PM

I am having the same issue, however one DIMM slot (the one furthest from the CPU) does not seem to work with the DDR3 RAM. I have two 2-GB DIMMs and the system only works with one in the opposite slot.

Does anyone have any further ideas?
September 1, 2008 2:58:25 AM

I have the P43Twins1600 also. I and other users have found it to be a big hassle. It will not run DDR3 1333 as stated in the specs, and most users need to downgrade thier memory. ASRock support is completely unresponsive and limited to thier form email. I am going to swap mine for an Asus or Gigabyte mobo for about $60 more because I know I can get support from them. What can I say, I got it cheap, and it cost me a lot more than I saved already.

My recommendation, STAY AWAY FROM ASROCK.
September 8, 2008 11:48:15 PM

Yeah, I had to pay to send the board back for replacement cause ASRock wouldn't cover the shipping, and with the shipping I've paid out on replacing other parts for testing (processor, video card, etc.) this has turned out to be an expensive "free" board. I got a Biostar board instead and if I ever get the replacement ASRock board and can verify it even works, I'll be giving it away to a family member...
!