[Solved] WD Caviar Green 1tb HDD

Hi All

I recently purchased a 1tb SATA Western Digital Caviar Green HDD. I installed it yesterday and to my surprise when installing windows it only showed up as 7.9gb. I went into the bios where it showed up as 8.4gb. I decided to boot ubuntu from the disk to take a look at my partitions. All I had was 931gb of unallocated space. I put a partition on the space and went back into windows setup and the partition didn't show up. For the record I'm using windows 7 64bit setup, but I also tried vista 32bit and that didn't work. For some reason, now the disk doesn't even show up in ubuntu, and yes it is still spinning.

My computer specs are:

Intel Core 2 6320 1.86ghz
ASUS P5S-MX SE Motherboard
2x 2gb DDR2 Ram

Thanks in advance
11 answers Last reply
More about solved caviar green
  1. oh it may be a bios bug,Did u flashed ur bios before?
  2. Nope I've never flashed my bios
  3. I think it may be a bios bug! Are u using the latest bios?
  4. I'm not sure, how would I flash my bios?
  5. I flashed my bios and after that it showed properly in the bios. I loaded up windows setup where it recognized the harddrive and began installing. I waited a while and it didn't do anything, then an error message came up saying it couldn't assign a drive letter or something. So I restarted and went into the setup again where it only recognized the harddrive as 7.9gb. When I highlighted the drive it said something wasn't enabled in the bios, it didn't specify a specific thing. So I went into the bios and noticed that 32bit data transfer or something like that was disabled. Not knowing what that was I enabled it. I went back into windows setup where the harddrive appeared as 1tb but it still had the something wasn't enabled in the bios message. I really don't know what to do as I cant install windows.
  6. That 8 GB size rings a vague bell. I'm thinking maybe what is NOT enabled is "LBA". But what puzzles me is that these days ALL drives use the second-generation version thereof, called "48-bit LBA", so your BIOS should have got that message from the HDD and automatically enabled it.

    Check in BIOS whether LBA is enabled on your drive. On the main BIOS Setup start-up screen, try using the option to Auto-Detect your drive to force it once again to get the drive's info from it, and see if that changes anything.

    Of course, you may have that uncommon problem, a faulty new hard drive.
  7. In the BIOS my harddrive now shows as 1tb and LBA has been set to auto the whole time. So I went into windows set up where it showed 931gb of unallocated space but it had a message down the bottom saying that windows cannot be installed to that drive. I clicked on it and a message popped up saying 'This computers hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu.'
  8. That's an interesting message from Windows Install. Now I'm wondering if the drive's mode is set correctly in BIOS. Tell us what mobo you have - make and model - so we can look at its manual. In the BIOS where you set the SATA port configuration, I expect you do have the SATA ports Enabled. But next to that should be a place to set its mode - usually choices like IDE emulation, native SATA, AHCI, RAID. How is yours set? Win 7 is supposed to be able to handle the first three all by itself.Usually you do not choose RAID unless you plan to use a RAID array, but that is not always the case - depends on how your BIOS is arranged. There also are some older boards that implemented SATA as an add-on to IDE and the two systems interact and require careful settings. If we can read your manual, we may be able to help further.
  9. Well I returned the drive to the store and they gave me a full refund, it must have been faulty.
  10. Just for your reference, 931GB is the total size of the drive is Windows, not 1000GB like you might expect.
  11. Yeh I know that, I mentioned it before.
Ask a new question

Read More

Hard Drives Western Digital Storage