USB doesn't work with SDHC media, but does with SD

As stated in the title, I have a Gigabyte GA-EP45-UD3P motherboard with Windows 7 64bit.
Note: This problem existed for me in Windows Vista 32bit.

Whenever I plug in a SanDisk Micromate with a SDHC memory card in it, the USB drives take forever to show as a device.
Accessing the device to browse the card can take up to 2 minutes.
Once open, I can browse the directories but I cannot copy files to or from the device.
The Device Manage shows the USB devices are working properly.

- I tested the MicroMate on another Windows 7 64bit machine and had no problems.
- I tested a second MicroMate on my machine and the other machine and still had the same result (slow/non-working on mine, and it worked fine on the other machine).
- I tested the MicroMate on front USB ports and rear USB ports with the same results.
- The USB ports work fine for all other USB drives (keychains, external drives, camera, my voice recorder, etc)

I'd update the driver for the MicroMate, but since it is a Mass Storage Device (in essence), the drivers are built in to Windows, so SanDisk doesn't make

However, if I put in a normal SD card - not an SDHC card - the MicroMate works perfectly (no lag, no problems, can copy and browse easily, etc)

What is the issue my computer is having with SDHC cards?
7 answers Last reply
More about doesn work sdhc media
  1. Are you sure the card reader supports SDHC cards? A lot of older ones don't...
  2. Yes, I can plug it in to the other Windows 7 64bit machine and the SDHC card works perfectly.
  3. I updated the JMicron storage controller, but the issue still persists.

    SDHC cards don't work. SD cards do.
  4. how is the SD card formated? NTFS?
  5. FAT (Fat32 specifically)

    And a bit further, the computer does this for ANY sdhc card.
  6. The answer is this:

    Somewhere along the path of communications between the motherboard and Windows is a miscommunication about the device type/controller of the memory card reader. One is misidentifying the device and causing an error in the other.

    Tonight I'll test out the memory card reader on the same hardware, but with Ubuntu booted instead of Windows. I'm going to guess that the card works fine in Ubuntu. I'll be sure to up date this post later with outcome.
  7. It was not a virus problem. It is a problem with the Motherboard and Windows 7 as I stated in my previous post. If I boot in Ubuntu, the card reader works perfectly.
Ask a new question

Read More

Flash Media USB Devices Storage