Sign in with
Sign up | Sign in
Your question

4870 Random Lockups

Last response: in Graphics & Displays
Share
September 9, 2008 3:26:29 AM

So I purchased a 4870 for my first build. I'm paranoid about doing things myself, but I figured I'd give it a shot. Everything is working great so far with one minor exception..

First off, I'm running a AMD Phenom 9950 Black Edition CPU on an ASUS M3A78-T mobo with 8 GB of mushkin XP 1066 RAM. Everything is being powered by a Corsair 750W power supply. I'm currently using catalyst 8.8 (came with 8.5, but was having problems with them as well)

The problem is when I run any sort of 3d game (WoW, CoD4, and now Warhammer Online), my system eventually completely locks up, forcing a reset. Sometimes the screen goes black, sometimes, I get brown-grey vertical bars, and more recently, whatever is being displayed pixelates and freezes. Sometimes it happens after only a few minutes, others after up to two hours.

I've manually changed the fan speed, and it doesn't seem to run much higher than 55C so combined with the four other fans in the case (excluding CPU fan) I really don't think heat is to blame here. I'm at a total loss to find anyone with a similar problem on the web, and am at a bigger loss with what to do about my predicament.

Any suggestions?

More about : 4870 random lockups

September 9, 2008 3:52:47 AM

I'm hoping you plugged in both 6 pin PCIe power connectors...
September 9, 2008 4:13:48 AM

Uninstall all drivers and everything related to ATI or Nvidia then install the NEW CCC 8.8 from the ATI website.
Related resources
September 9, 2008 4:28:51 AM

It could be a heat issue seeing how it locks up after a while of gaming. Pop the side off the case and/or put a spare fan in the case so it blows directly on the card and see what happens. You may also have a defective card. Swap it out if you can.
September 9, 2008 4:43:05 AM

Do you have 4x2GB Ram modules then? Try using only two and see what happens. I am not familiar with AMD setups / chipsets but I know on Intels you have to up the RAM voltage if you want to use 4 modules. That is one thing that popped into my head seeing your specs. Taking two modules out is a quick way to see if your RAM is going nuts.

Aside from that, you should do an ATI driver clean out. Snag driver sweeper from Guru3D. Remove all ATI programs through the unistall software option in the control panel. Start in safe mode and use driver sweeper to remove all other ATI files. Restart to the normal OS and you should be set to install the new ATI drivers.

http://downloads.guru3d.com/Guru3D---Driver-Sweeper-(Setup)-download-1655.html

If the driver clean out doesn't work it will at least get you on the right foot.
September 9, 2008 4:56:03 AM

First things first .
Test the memory
Run Memtester86 for at least two passes thru the whole test.
Next test the CPU
run Prime 95 make sure you test all cores by runing a thread on each.
Now you can play with the card run 3dmark

These can help you stress the system in diferent way's
Most PC lockups are due to RAM and PSU.

You can also run things like knoppix or ubuntu off a CDROM this will illiminate windows as the cause of your lockups.

kgrach

September 9, 2008 1:06:38 PM

This is actually an issue that's been going on for a while in the AMD forums with the 4800 series of cards. Games are at random causing the PC to lock up entirely forcing you to cut power and reset. At times the game can run fine for hours, other times it runs for just a few minutes. The issue SEEMS to be coming from the power saving features in the card.

People have had some luck changing the cards settings to get rid of these features but in my case it forced me to disable the card and reinstall all the drivers after a complete sweep. It was happening to me mainly in games which the card was breezing through (Spore, WoW, TF2) but not resource intensive titles (Crysis, Bioshock, Assassin's Creed) which supports the theory that the cards are switching in and out of power saving mode and causing lockups. Once I reinstalled the drivers after a clean sweep and ONLY installed Cat 8.8 (DO NOT install older drivers from the CD) all the problems are gone. I've had no lockups since then.

Also, I'm not sure if it's the same with the 4870 (I have the 4870x2) but entering and then exiting a 3d app when I start the PC actually "resets" the GPU and it then runs cooler. Again I'm not sure about the single GPU cards.

Make sure to run other tests just to rule out and faulty components but once that's done there are a few things you can try.
September 9, 2008 5:18:40 PM

bring the temp down with ccc profile manager
September 9, 2008 7:03:05 PM

Thanks for the suggestions. I poked around the unofficial Sapphire forums, and found a good number of threads related to my problem.

- Yes, I got four 2gb sticks. I made no changes to the RAM's voltage in BIOS, so it's a good possibility that that could be my problem. I found a couple threads on the Sapphire User Forums that suggested RAM voltage as a cause. Memtester is running on my machine (I'm at work, so I won't know the results until I get home)
- I'm going to put it through 3dMark's and Prime95's paces once I get home and check on the RAM.
- I've created a catalyst profile adjusting the fan speed, and while I'm running games (WoW, CoD4, Warhammer Online, specifically), I tend to run pretty cool. I've got three case fans, and an additional PCI slot fan, and it's rarely much higher than 55C. Being paranoid, I bought a CPU fan upgrade:

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Now, having done some reading, I've heard reference to everything from the RAM voltage, CCC's AI, and PSUs.

I'm not terribly worried about the PSU (+12V@60A [single rail]). This is the specific model:

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

CCC *should* be a relatively simple fix. A couple posters suggested setting the AI to 'advanced', or, failing that, completely uninstalling and reinstalling 8.8.

But if it is, in fact, the RAM voltage, I'm a completely newbie at tweaking that. Assuming its just a matter of going into my BIOS and changing the voltage, (my RAM is listed at being 2.0v-2.1v), are there any other steps I should be aware of once that's been done?
September 10, 2008 1:53:16 AM

UPDATE: Memtester ran all day with 0 errors. Removed two modules of RAM, and thus far no lockups.

However, I uninstalled CCC and ran driver sweeper. Upon restarting, I got a MOM.Implementation error. Everything I'm reading is pointing at having to dick around with my registry. Am I looking at a reinstall of windows?


So, assuming that my RAM is to blame, I've gone into my BIOS and determined the voltage on my RAM is set to auto (being defined as up to 2.4V). What sort of ramifications would turning it up to 2.0 entail? As I've said before, I'm pretty new to BIOS and the like.
October 1, 2008 4:26:24 PM

Bro, I have the solution for you.

Quote:
Problem Description

After a lot of searching and annoyance I have finally found a solution to an issue that kept me from using my new graphics card. As the title already mentions the graphics card I'm talking about is the Sapphire ATI Radeon HD 4870.
The issue I had with the card was the following:

When running any kind of 3D game (WoW, WAR and others) my system would completely lock up after an undetermined amount of time sometimes it would lock up 1 minute into the game, while other times I could play for around 5 hours without a problem. Either way, whenever the lock up occurred all that I could do to fix it was a hard reset.
When the lock up occurred sometimes the screen would go completely black and hang the entire system, other times I would get brown/grey vertical bars over my screen, and other times again it would pixelate the entire screen and then go black again. It was also possible that the game would sometimes keep on running in the background, but without being able to see anything it's pretty hard to play.

The first thing that came to my mind about this problem was that the card was overheating, even though I found it odd as the game could crash not even 5 minutes into the game. But to exclude it I checked my temperatures either way, with RivaTuner and GPU-Z, and found that my temps were indeed not overheating. The hottest temp I had going at any given time was 55 degrees Celsius on my VRAM, the rest (GPU Core etc.) was either at 50 or below. I have to note here that I had RivaTuner apply a Fan profile to keep it running at 40% all the time, hence the pretty cool temps.

After it turned out it wasn't overheating I started searching the Internet for people with the same problem and hopefully a fix. I found that I wasn't the only one, but I also discovered that fixes were not easy to come by. However in the end I found a solution and one that actually works, even better yet I found 2 solutions.
The actual problem, which some people started calling the PowerPlay problem, was that the ATI card would keep switching the GPU clock speed between 500 Mhz and 750 Mhz. This would cause the card to, at some point, stop responding as it couldn't cope with the switches. As these switches happened nearly every second when running a 3D game. The switching is normally required when running either a 2D application (500 Mhz, require less GPU) or a 3D application (750 Mhz, require more GPU).


Quote:
Permanent Solution, ONLY for Sapphire ATI Radeon HD 4870 512MB DDR5

!Important to note for this solution is that this works ONLY for the Sapphire ATI Radeon HD 4870 512MB DDR5!
This is because this solution requires a BIOS update of the card, which is provided by Sapphire.

So, to make sure you have the correct card, it's easiest to consult the box where the card came in. On the box you will find a green sticker with some barcodes and some serial numbers. The BIOS update is only applicable if on your sticker the serial numbers are:

* PN 188-01E85-001SA
* SKU# 11133-00-20R


Also you can check these settings in the ATI CCC:

* Original BIOS on board with date: 24.07.2008
* BIOS version: 011.006.000.003.000000


If all of this checks out for your card the BIOS update can be done. To do the BIOS update we will need a few things:

1. The BIOS update from Sapphire, http://www.sapphiretech.com/us/support/drivers.php
2. An alternative download from RapidShare, http://rapidshare.com/files/148339275/Sapphire_HD4870_w...
3. ATI Win Flash, for easier BIOS updating in Windows, http://www.techpowerup.com/downloads/1122/Winflash_2.0....


With both these we can perform the BIOS update. Note that it is also possible to flash the card via the regular ATI flash but I decided to go for the WinFlash solution. As it doesn't require the creation of a Boot Disk.
The steps to undertake to flash the BIOS.

1. First, make sure to end all applications which do something with the GFX card (such as RivaTuner or any game)
2. Install ATI WinFlash to a "simple location" (fex. C:\WinFlash)
3. Unzip the contents of the BIOS update into a folder
4. Copy/Paste the file named 1e8501sa.002 from the folder where you extracted the BIOS update, to the ATI WinFlash install folder
5. Click on the Start menu and select Run
6. Type in "cmd" (without the quotes) and press OK
7. Browse to the install path of ATI WinFlash (fex. C:\WinFlash)
8. Run the BIOS update by executing: atiwinflash.exe -f -p 0 1e8501sa.002
9. Wait until the flashing finishes, should it fail do NOT reset, yet try to flash again
10. If it worked, reboot your system.


A note about the WinFlash utility, if your card is not in the top slot, or if you want to update two cards you can do so by changing the command line. The third parameter in the list is the PCI-E slot (the 0), where 0 is the top slot, and where 1 is the PCI-E slot below it. So if you were flashing your card in the second slot the command line would look like: atiwinflash.exe -f -p 1 1e8501sa.002

Edit:
Flashing the 4870 in DOS, with a bootable USB stick

As Maeror had an issue with his card where he could not flash it in Windows anymore, I added this section as well. This details flashing your 4870 BIOS via a DOS boot. It requires you to have a USB stick which you can use to create it as a bootable "disk".
Also please note that this solution requires the ATIFlash utility! This is not the ATIWinFlash utility, which I mentioned in the other Flash solution. The ATIFlash is a DOS only program and needs to be run from there. It can be found in the BIOS update that is downloaded from the Sapphire website.

The instructions to do this are as follows:

1. Create your USB boot stick in windows with USB Boot drive (HPUSBFW), found at: http://www.elektroni.fi/Stilt/Asus_Rampage/HPUSBFW.zip
2. Download the boot files and extract them to a folder of your choice from: http://www.elektroni.fi/Stilt/Asus_Rampage/USB-Boot.zip
3. Run the HPUSBFW program. Select the correct USB device from the drop-down menu, set file system to FAT32 and check Create a DOS startup disk. Then browse for the extracted boot files (now in the folder of your choice) and press start to begin formating it.
4. Copy ATIFlash and the BIOS file to the USB stick under Windows
5. Restart the computer
6. Enter the Motherboard BIOS (by pressing the Delete key at startup) and set the first boot device to the USB stick that you created
7. Save that settings in the MoBo BIOS and exit
8. Your PC will then automatically boot to DOS
9. Flash with the command as described: "atiflash -f -p 0 1e8501sa.002" (without the quotes). And then wait till it prompts you that you need to restart the PC
10. When rebooting, go back to your MoBo BIOS and change first booting device back as it was before


After having flashed my BIOS I have been able to play all day yesterday without a single problem. Also the reports I've heard from other people who applied this fix are only positive. Either way I can finally (after having my ATI card for about a week or so) play the game without having to rely on my older card.


Quote:
Workaround Solution, should work with any ATI card

The first solution is the easier and safer solution to do. Also this should work on any of the other ATI cards and is not limited to the Sapphire cards only. The solution for this is to fixate the GPU clock speed at 750 Mhz via RivaTuner. To do this the following steps are necessary.

1. Download and install RivaTuner, http://downloads.guru3d.com/download.php?det=163
2. After installation, start up RivaTuner.
3. Click on the expansion symbol, in the greyed out text box. This will bring up a list of icons.
4. Click on the first icon in the list shown, it's called Low-level system settings.
5. In the Overclocking tab, tick the "Enable low-level hardware overclocking" box to on.
6. It might be smart to reboot if you have been playing some games / running some apps, either way let RivaTuner detect the speed.
7. Set the core clock speed to 750 Mhz (the speed required for 3D apps)
8. In the section "Overclocking profile settings", type in a profile name (fex. WAR) and click on the disk icon to save the profile.
9. Press OK to be returned to the main RivaTuner screen.
10. Go to the Launcher tab and click on the green + symbol.
11. Choose to add a "Regular item" and press OK
12. Type in a name (fex. WAR), the other boxes should be enabled now.
13. Tick the box "Associated overclocking profile", and select the profile we made in step 8.
14. Tick the "Associated Application" and fill in the path and filename of the warpatch.exe (fex. "C:\Program Files\Warhammer Online - Age of Reckoning\warpatch.exe")
15. Click OK to save the settings.


What we have done now, is create a shortcut inside RivaTuner that we can click on to start up WAR with the changed GPU clock speed. This means that whenever you'd like to run WAR, you should start it via RivaTuner's Launcher tab.
Alternatively, it's possible to have RivaTuner automatically apply the clock speed at the startup of Windows every time you boot. To do this, do everything up until step 7, and then tick the "Apply overclocking at Windows startup" box, and press Save. This will make the GPU clock speed at 750 Mhz all the time. While this is easier, since you don't have to run specific applications, or apply the profile each time, it lets the GPU run at an increased speed even if it's not required.


August 17, 2010 3:05:58 PM

This thread has helped me immensely with playing games on my computer using the RivaTuner method. However, I now play a game that has no .exe file, as it launches through the game company's launcher. I have tried fixing the problem once and for all, but when I get to #7 of the 'Permanent Solution' I don't know what to do next. Could someone explain it even clearer please? I like to think I know my way around a PC but can't fill in the gaps in the instructions, so I'm sure it's something obvious I'm not doing.

i.e. I have the black box, but what do I do now? I go to the file where I installed atiwinflash and try running the .exe but don't know what to do after? I am using the Raidshare link + the atiwinflash link, is this right? I didn't know what I needed from the main website.

Thanks in advance.
!