Sign in with
Sign up | Sign in
Your question

Bios Update Failed on a Asrock 775Dual-Vsta

Last response: in Motherboards
Share
November 30, 2008 12:04:34 PM

I tried a bios update on a 775DUAL-VSTA and it failed{the pc starts but the screen reamins black} is there any chance to repair , without any hot swap?????PLS HELP
a b V Motherboard
November 30, 2008 12:30:12 PM

Try resetting the BIOS with the jumper, if you are very lucky, that will do it.
Also, make sure to remove all but 1 stick of memory.
If that doesn't do it, I hate to say it, but you are the proud owner of a dead motherboard. The only thing you can do is get another BIOS chip from the manufacturer (if your chip is removable), or take it to a shop where they can reflash it for you, or send it back to manufacturer and have them reflash it for you.
November 30, 2008 12:33:26 PM

ASRFLASH.EXE: The Flash Memory Writer utility is included in the WinZip format of BIOS file. It updates the BIOS by uploading a new BIOS file to the programmable flash ROM chip on the motherboard. To determine the BIOS version of your motherboard, press <F2> to enter the BIOS setup utility during bootup, and check the BIOS version from the Main menu. Larger numbers represent a newer BIOS file. This utility works only in DOS mode. )

How do I check the BIOS version?
1.The BIOS version can be found during system boot up.
2.The BIOS version can be found in BIOS setup utility.
The Flash Memory Writer utility can not be suitable for all ASRock motherboards. Please use the Flash utility which is included in each BIOS file to update its BIOS. Also ASRock motherboard MUST use ASRock's Flash utility to update BIOS, those uncertified BIOS flashing tools will cause motherboard damage.
1. Create a bootable system floppy disk.
2. Download an updated ASRock BIOS file (WinZip format with .zip file extension) from the web site, unzip the BIOS file and save both ASRFLASH.EXE utility and BIOS file to the disk you created in step 1.
3. Boot from the disk you created in step 2.
4. At the "A:\" prompt, type ASRFLASH, hit space bar once, and type BIOS file name then press <Enter>. For example: A:\ASRFLASH K7S41GX2.00 <Enter> then you will see a message "Please wait for BIOS loading ROM".
5. After 30 seconds, you will see the message "Flash ROM Update Completed - Pass", then you have finished upgrading the BIOS.
6. After finishing upgrading the BIOS, please remove the floppy disk. Restart your system and press <F2> to enter the BIOS setup utility during boot up.
7. In Exit menu, please select "Load Default Settings" and press <Enter> to continue.
8. Select "Exit Saving Changes" and press <Enter> to exit the BIOS setup utility.
9. Now, system is booting up with new BIOS.

If you encounter problems while updating the new BIOS, DO NOT turn off your system since this corrupt BIOS might cause your system failed to boot up. Just repeat the process, and if the problem still persists, update the original BIOS file. If the Flash Memory Writer utility was not able to successfully update a complete BIOS file, your system may not be able to boot up. If this happens, your system will need service.
Related resources
a b V Motherboard
November 30, 2008 12:42:15 PM

^ All of that is fine and dandy if the PC will boot. Once you shut it off, and all you get is a black screen, (as the OP plainly said is the problem) it's pretty much all over.
November 30, 2008 12:45:54 PM

Which is why flashing your BIOS is not something like a driver update, it has a good chance of killing your motherboard and should only be done for very specific reasons.

Only the manufacturer can help you now, really.
Anonymous
a b V Motherboard
November 22, 2009 7:09:08 AM

hi to all, i have a question about bios, i tried to install the new operating system which is windows 7. for 1 day it seems okay, then i tried to remove my hard disk on the case and clean it up. after that i connected it again to the system board. the problem now is, the system won't boot on the welcome screen. i tried to run the set up repair manager, but then, it says that my bios is not updated. and is not ACPI compliant.
!